summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-18 16:49:48 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-18 16:49:48 +0100
commitae5461bf21976a1198c7dc2771519ba96d2d42c3 (patch)
tree740baeafcd4b5b1a00620262cd25809672606882
parentf2c0453470b2eebe38a0691d2b0c176e5aa51339 (diff)
php-bartlett-PHP-CompatInfo: add patch for broken extension report
-rw-r--r--PHP_CompatInfo-2.14.0.patch11
-rw-r--r--php-bartlett-PHP-CompatInfo.spec10
2 files changed, 20 insertions, 1 deletions
diff --git a/PHP_CompatInfo-2.14.0.patch b/PHP_CompatInfo-2.14.0.patch
new file mode 100644
index 0000000..ab11208
--- /dev/null
+++ b/PHP_CompatInfo-2.14.0.patch
@@ -0,0 +1,11 @@
+--- PHP_CompatInfo-2.14.0/PHP/CompatInfo/Report/Extension.php 2013-03-16 10:58:51.000000000 +0100
++++ PHP_CompatInfo-2.14.0/PHP/CompatInfo/Report/Extension.php 2013-03-18 16:36:30.001438567 +0100
+@@ -45,7 +45,7 @@
+ $this->totalConditions = 0;
+ $this->globalVersions = array('4.0.0', '');
+
+- if ($this->isEmpty($elements)) {
++ if ($this->isEmpty($extensions)) {
+ return;
+ }
+ $this->printTHeader($base, false, $extensions);
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index e1cf6a0..4b3d970 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -9,7 +9,7 @@
Name: php-bartlett-PHP-CompatInfo
Version: 2.14.0
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
Group: Development/Libraries
@@ -42,6 +42,9 @@ Patch22: 0022-fix-covers-annotation.patch
Patch23: 0023-fix-mysqli-reference-for-php-5.5-trans.patch
Patch24: 0024-fix-gd-reference-for-php-5.5.0alpha6.patch
+# https://github.com/llaville/php-compat-info/issues/76
+Patch25: %{pear_name}-2.14.0.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.2.1
@@ -110,6 +113,7 @@ cd %{pear_name}-%{version}%{?prever}
%patch22 -p1
%patch23 -p1
%patch24 -p1
+%patch25 -p1
# remove checksum for patched files
sed -e 's/md5sum.*name/name/' \
@@ -193,6 +197,10 @@ fi
%changelog
+* Mon Mar 18 2013 Remi Collet <remi@fedoraproject.org> - 2.14.0-3
+- add patch for broken extension report
+ https://github.com/llaville/php-compat-info/issues/76
+
* Mon Mar 18 2013 Remi Collet <remi@fedoraproject.org> - 2.14.0-2
- provides phpci
- cleanups