summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-02 10:28:57 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-02 10:28:57 +0200
commita496f37c96336c06cfd49bac75e3f7c291cd8738 (patch)
treefe85a9c3a59dba770ece801a803f66d94c31ea63
parentae5461bf21976a1198c7dc2771519ba96d2d42c3 (diff)
php-bartlett-PHP-CompatInfo: 2.14.1
-rw-r--r--0025-array_column.patch24
-rw-r--r--0026-fix-gd-reference-for-php-5.5.0beta2.patch96
-rw-r--r--PHP_CompatInfo-conf.patch18
-rw-r--r--php-bartlett-PHP-CompatInfo.spec29
4 files changed, 159 insertions, 8 deletions
diff --git a/0025-array_column.patch b/0025-array_column.patch
new file mode 100644
index 0000000..f7f5f6c
--- /dev/null
+++ b/0025-array_column.patch
@@ -0,0 +1,24 @@
+From 77931f9c94a4cb639f62cf077ae7faaf701973a9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 20 Mar 2013 14:45:23 +0100
+Subject: [PATCH] new 'array_column' function
+
+---
+ PHP/CompatInfo/Reference/standard.php | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/PHP/CompatInfo/Reference/standard.php b/PHP/CompatInfo/Reference/standard.php
+index 68cbc66..5762d01 100644
+--- a/PHP/CompatInfo/Reference/standard.php
++++ b/PHP/CompatInfo/Reference/standard.php
+@@ -756,6 +756,7 @@ public function getFunctions($extension = null, $version = null, $condition = nu
+ 'password_hash' => array('5.5.0-dev', ''),
+ 'password_needs_rehash' => array('5.5.0-dev', ''),
+ 'password_verify' => array('5.5.0-dev', ''),
++ 'array_column' => array('5.5.0-dev', ''),
+ );
+ $this->applyFilter($release, $items, $functions);
+
+--
+1.8.1.5
+
diff --git a/0026-fix-gd-reference-for-php-5.5.0beta2.patch b/0026-fix-gd-reference-for-php-5.5.0beta2.patch
new file mode 100644
index 0000000..9b46cea
--- /dev/null
+++ b/0026-fix-gd-reference-for-php-5.5.0beta2.patch
@@ -0,0 +1,96 @@
+From 7c4f30cbcaae602d81c9cff6adaa9b32f676955c Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 28 Mar 2013 13:05:00 +0100
+Subject: [PATCH] fix gd reference for php 5.5.0beta2
+
+---
+ PHP/CompatInfo/Reference/gd.php | 32 ++++++++++++++++++++++++++++++++
+ 1 file changed, 32 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/gd.php b/PHP/CompatInfo/Reference/gd.php
+index d10be0f..1ddb29f 100644
+--- a/PHP/CompatInfo/Reference/gd.php
++++ b/PHP/CompatInfo/Reference/gd.php
+@@ -78,6 +78,9 @@ public function getFunctions($extension = null, $version = null, $condition = nu
+ $items = array(
+ 'gd_info' => array('4.3.0', ''),
+ 'image2wbmp' => array('4.0.5', ''),
++ 'imageaffine' => array('5.5.0-dev', ''),
++ 'imageaffinematrixconcat' => array('5.5.0-dev', ''),
++ 'imageaffinematrixget' => array('5.5.0-dev', ''),
+ 'imagealphablending' => array('4.0.6', ''),
+ 'imageantialias' => array('4.3.2', ''),
+ 'imagearc' => array('4.0.0', ''),
+@@ -149,6 +152,7 @@ public function getFunctions($extension = null, $version = null, $condition = nu
+ 'imageline' => array('4.0.0', ''),
+ 'imageloadfont' => array('4.0.0', ''),
+ 'imagepalettecopy' => array('4.0.1', ''),
++ 'imagepalettetotruecolor' => array('5.5.0-dev', ''),
+ 'imagepng' => array('4.0.0', ''),
+ 'imagepolygon' => array('4.0.0', ''),
+ 'imagepsbbox' => array('4.0.0', ''),
+@@ -161,7 +165,9 @@ public function getFunctions($extension = null, $version = null, $condition = nu
+ 'imagerectangle' => array('4.0.0', ''),
+ 'imagerotate' => array('4.3.0', ''),
+ 'imagesavealpha' => array('4.3.2', ''),
++ 'imagescale' => array('5.5.0-dev', ''),
+ 'imagesetbrush' => array('4.0.6', ''),
++ 'imagesetinterpolation' => array('5.5.0-dev', ''),
+ 'imagesetpixel' => array('4.0.0', ''),
+ 'imagesetstyle' => array('4.0.6', ''),
+ 'imagesetthickness' => array('4.0.6', ''),
+@@ -210,11 +216,25 @@ public function getConstants($extension = null, $version = null, $condition = nu
+ 'GD_MINOR_VERSION' => array('5.2.4', ''),
+ 'GD_RELEASE_VERSION' => array('5.2.4', ''),
+ 'GD_VERSION' => array('5.2.4', ''),
++ 'IMG_AFFINE_ROTATE' => array('5.5.0-dev', ''),
++ 'IMG_AFFINE_SCALE' => array('5.5.0-dev', ''),
++ 'IMG_AFFINE_SHEAR_HORIZONTAL' => array('5.5.0-dev', ''),
++ 'IMG_AFFINE_SHEAR_VERTICAL' => array('5.5.0-dev', ''),
++ 'IMG_AFFINE_TRANSLATE' => array('5.5.0-dev', ''),
+ 'IMG_ARC_CHORD' => array('4.0.0', ''),
+ 'IMG_ARC_EDGED' => array('4.0.0', ''),
+ 'IMG_ARC_NOFILL' => array('4.0.0', ''),
+ 'IMG_ARC_PIE' => array('4.0.0', ''),
+ 'IMG_ARC_ROUNDED' => array('4.0.0', ''),
++ 'IMG_BELL' => array('5.5.0-dev', ''),
++ 'IMG_BESSEL' => array('5.5.0-dev', ''),
++ 'IMG_BICUBIC' => array('5.5.0-dev', ''),
++ 'IMG_BICUBIC_FIXED' => array('5.5.0-dev', ''),
++ 'IMG_BILINEAR_FIXED' => array('5.5.0-dev', ''),
++ 'IMG_BLACKMAN' => array('5.5.0-dev', ''),
++ 'IMG_BOX' => array('5.5.0-dev', ''),
++ 'IMG_BSPLINE' => array('5.5.0-dev', ''),
++ 'IMG_CATMULLROM' => array('5.5.0-dev', ''),
+ 'IMG_COLOR_BRUSHED' => array('4.0.0', ''),
+ 'IMG_COLOR_STYLED' => array('4.0.0', ''),
+ 'IMG_COLOR_STYLEDBRUSHED' => array('4.0.0', ''),
+@@ -245,13 +265,25 @@ public function getConstants($extension = null, $version = null, $condition = nu
+ 'IMG_FLIP_HORIZONTAL' => array('5.5.0-dev', ''),
+ 'IMG_FLIP_VERTICAL' => array('5.5.0-dev', ''),
+ 'IMG_FLIP_BOTH' => array('5.5.0-dev', ''),
++ 'IMG_GAUSSIAN' => array('5.5.0-dev', ''),
++ 'IMG_GENERALIZED_CUBIC' => array('5.5.0-dev', ''),
+ 'IMG_GD2_COMPRESSED' => array('4.0.0', ''),
+ 'IMG_GD2_RAW' => array('4.0.0', ''),
+ 'IMG_GIF' => array('4.0.0', ''),
++ 'IMG_HAMMING' => array('5.5.0-dev', ''),
++ 'IMG_HANNING' => array('5.5.0-dev', ''),
++ 'IMG_HERMITE' => array('5.5.0-dev', ''),
+ 'IMG_JPEG' => array('4.0.0', ''),
+ 'IMG_JPG' => array('4.0.0', ''),
++ 'IMG_MITCHELL' => array('5.5.0-dev', ''),
++ 'IMG_NEAREST_NEIGHBOUR' => array('5.5.0-dev', ''),
+ 'IMG_PNG' => array('4.0.0', ''),
++ 'IMG_POWER' => array('5.5.0-dev', ''),
++ 'IMG_QUADRATIC' => array('5.5.0-dev', ''),
++ 'IMG_SINC' => array('5.5.0-dev', ''),
++ 'IMG_TRIANGLE' => array('5.5.0-dev', ''),
+ 'IMG_WBMP' => array('4.0.0', ''),
++ 'IMG_WEIGHTED4' => array('5.5.0-dev', ''),
+ 'IMG_XPM' => array('4.0.0', ''),
+ 'PNG_ALL_FILTERS' => array('4.0.0', ''),
+ 'PNG_FILTER_AVG' => array('4.0.0', ''),
+--
+1.8.1.5
+
diff --git a/PHP_CompatInfo-conf.patch b/PHP_CompatInfo-conf.patch
new file mode 100644
index 0000000..58bd881
--- /dev/null
+++ b/PHP_CompatInfo-conf.patch
@@ -0,0 +1,18 @@
+--- PHP_CompatInfo-2.14.1/phpcompatinfo.xml.dist 2013-04-01 18:17:03.000000000 +0200
++++ PHP_CompatInfo-2.14.1/phpcompatinfo.xml 2013-04-02 10:15:27.000000000 +0200
+@@ -1,6 +1,6 @@
+ <?xml version="1.0" encoding="utf-8" ?>
+ <phpcompatinfo
+- reference="PHP5"
++ reference="ALL"
+ report="summary"
+ reportFileAppend="false"
+ cacheDriver="file"
+@@ -12,6 +12,7 @@
+
+ <cache id="file">
+ <options>
++ <save_path>/tmp/phpci-%{USER}</save_path>
+ <gc_probability>1</gc_probability>
+ <gc_maxlifetime>86400</gc_maxlifetime>
+ </options>
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 4b3d970..453f50e 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -8,8 +8,8 @@
Name: php-bartlett-PHP-CompatInfo
-Version: 2.14.0
-Release: 3%{?dist}
+Version: 2.14.1
+Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
Group: Development/Libraries
@@ -18,6 +18,11 @@ License: BSD and MIT
URL: http://php5.laurent-laville.org/compatinfo/
Source0: http://bartlett.laurent-laville.org/get/%{pear_name}-%{version}%{?prever}.tgz
+# Update configuration for best experience
+# Reference = ALL known extension (instead of installed ones)
+# Make cache / save_path user specific
+Patch0: %{pear_name}-conf.patch
+
# Update reference for PHP 5.5
# https://github.com/llaville/php-compat-info/commits/php-5.5
Patch1: 0001-cuirl-reference-for-php-5.5.patch
@@ -41,9 +46,8 @@ Patch21: 0021-new-intl-changes-in-php-5.5.patch
Patch22: 0022-fix-covers-annotation.patch
Patch23: 0023-fix-mysqli-reference-for-php-5.5-trans.patch
Patch24: 0024-fix-gd-reference-for-php-5.5.0alpha6.patch
-
-# https://github.com/llaville/php-compat-info/issues/76
-Patch25: %{pear_name}-2.14.0.patch
+Patch25: 0025-array_column.patch
+Patch26: 0026-fix-gd-reference-for-php-5.5.0beta2.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -92,6 +96,12 @@ This package provides experimental references for PHP 5.5.
# Package is V2
cd %{pear_name}-%{version}%{?prever}
+# Copy upstream default configuration
+cp phpcompatinfo.xml.dist phpcompatinfo.xml
+# Apply our changes
+%patch0 -p1 -b .rpm
+
+# PHP 5.5 updated references
%patch1 -p1
%patch2 -p1
%patch3 -p1
@@ -114,6 +124,7 @@ cd %{pear_name}-%{version}%{?prever}
%patch23 -p1
%patch24 -p1
%patch25 -p1
+%patch26 -p1
# remove checksum for patched files
sed -e 's/md5sum.*name/name/' \
@@ -140,9 +151,7 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
sed -i -e 's/\r//' %{buildroot}%{_bindir}/phpci
# Create default package configuration
-sed -e '/reference=/s/PHP5/ALL/' \
- %{buildroot}%{pear_cfgdir}/%{pear_name}/phpcompatinfo.xml.dist \
- >%{buildroot}%{pear_cfgdir}/%{pear_name}/phpcompatinfo.xml
+install -pm 644 phpcompatinfo.xml %{buildroot}%{pear_cfgdir}/%{pear_name}/
%check
@@ -197,6 +206,10 @@ fi
%changelog
+* Tue Apr 02 2013 Remi Collet <remi@fedoraproject.org> - 2.14.1-1
+- Update to 2.14.1
+- make cache path user dependent
+
* Mon Mar 18 2013 Remi Collet <remi@fedoraproject.org> - 2.14.0-3
- add patch for broken extension report
https://github.com/llaville/php-compat-info/issues/76