summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-10 11:48:03 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-10 11:48:03 +0200
commit9995b53c6dd2941a4c0e2da1c1f24670d49a05fb (patch)
tree11bbf25a6651d021b1e4f33316b51ce15ef65591
parent3f12cd621593faa3da769d5b6967da8893c59f6c (diff)
php-bartlett-PHP-CompatInfo: 2.16.0
-rw-r--r--0012-curl-reference-for-php-5.5-more.patch14
-rw-r--r--0029-fix-reference-curl-wrappers-enabled.patch49
-rw-r--r--0030-fix-sphinx-test.patch29
-rw-r--r--0032-new-soap-constants.patch27
-rw-r--r--PHP_CompatInfo-2.14.0.patch11
-rw-r--r--PHP_CompatInfo-conf.patch8
-rw-r--r--php-bartlett-PHP-CompatInfo.spec15
7 files changed, 41 insertions, 112 deletions
diff --git a/0012-curl-reference-for-php-5.5-more.patch b/0012-curl-reference-for-php-5.5-more.patch
index ef4b807..0d5eec1 100644
--- a/0012-curl-reference-for-php-5.5-more.patch
+++ b/0012-curl-reference-for-php-5.5-more.patch
@@ -11,7 +11,7 @@ diff --git a/PHP/CompatInfo/Reference/curl.php b/PHP/CompatInfo/Reference/curl.p
index c12dc0f..e59bda4 100644
--- a/PHP/CompatInfo/Reference/curl.php
+++ b/PHP/CompatInfo/Reference/curl.php
-@@ -93,12 +93,16 @@ class PHP_CompatInfo_Reference_Curl
+@@ -93,12 +93,16 @@
'curl_multi_init' => array('5.0.0', ''),
'curl_multi_remove_handle' => array('5.0.0', ''),
'curl_multi_select' => array('5.0.0', ''),
@@ -28,7 +28,7 @@ index c12dc0f..e59bda4 100644
'curl_unescape' => array('5.5.0-dev', ''),
'curl_version' => array('4.0.2', ''),
);
-@@ -142,6 +146,7 @@ class PHP_CompatInfo_Reference_Curl
+@@ -142,6 +146,7 @@
'CURL_NETRC_IGNORED' => array('4.0.2', ''),
'CURL_NETRC_OPTIONAL' => array('4.0.2', ''),
'CURL_NETRC_REQUIRED' => array('4.0.2', ''),
@@ -36,15 +36,16 @@ index c12dc0f..e59bda4 100644
'CURL_RTSPREQ_ANNOUNCE' => array('5.5.0-dev', ''),
'CURL_RTSPREQ_DESCRIBE' => array('5.5.0-dev', ''),
'CURL_RTSPREQ_GET_PARAMETER' => array('5.5.0-dev', ''),
-@@ -166,6 +171,7 @@ class PHP_CompatInfo_Reference_Curl
+@@ -166,7 +171,7 @@
'CURL_VERSION_KERBEROS4' => array('4.0.2', ''),
'CURL_VERSION_LIBZ' => array('4.0.2', ''),
'CURL_VERSION_SSL' => array('4.0.2', ''),
+- 'CURL_WRAPPERS_ENABLED' => array('5.4.15', ''),
+ 'CURL_WRITEFUNC_PAUSE' => array('5.5.0-dev', ''),
'CURLAUTH_ANY' => array('4.0.2', ''),
'CURLAUTH_ANYSAFE' => array('4.0.2', ''),
-@@ -324,6 +330,9 @@ class PHP_CompatInfo_Reference_Curl
+@@ -325,6 +330,9 @@
'CURLM_OK' => array('4.0.2', ''),
'CURLM_OUT_OF_MEMORY' => array('4.0.2', ''),
@@ -54,7 +55,7 @@ index c12dc0f..e59bda4 100644
'CURLMSG_DONE' => array('4.0.2', ''),
'CURLOPT_ACCEPT_ENCODING' => array('5.5.0-dev', ''),
-@@ -497,6 +506,13 @@ class PHP_CompatInfo_Reference_Curl
+@@ -498,6 +506,13 @@
'CURLOPT_WRITEFUNCTION' => array('4.0.2', ''),
'CURLOPT_WRITEHEADER' => array('4.0.2', ''),
@@ -68,6 +69,3 @@ index c12dc0f..e59bda4 100644
'CURLPROTO_ALL' => array('4.0.2', ''),
'CURLPROTO_DICT' => array('4.0.2', ''),
'CURLPROTO_FILE' => array('4.0.2', ''),
---
-1.7.11.7
-
diff --git a/0029-fix-reference-curl-wrappers-enabled.patch b/0029-fix-reference-curl-wrappers-enabled.patch
deleted file mode 100644
index def5a3b..0000000
--- a/0029-fix-reference-curl-wrappers-enabled.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 2b72e131738149824ae06904ea7a1505ceb72da8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 4 Apr 2013 11:17:07 +0200
-Subject: [PATCH] fix curl ref for php 5.4.15 (CURL_WRAPPERS_ENABLE)
-
----
- PHP/CompatInfo/Reference/curl.php | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/PHP/CompatInfo/Reference/curl.php b/PHP/CompatInfo/Reference/curl.php
-index 507bea0..a5f6488 100644
---- a/PHP/CompatInfo/Reference/curl.php
-+++ b/PHP/CompatInfo/Reference/curl.php
-@@ -172,6 +172,7 @@ public function getConstants($extension = null, $version = null, $condition = nu
- 'CURL_VERSION_KERBEROS4' => array('4.0.2', ''),
- 'CURL_VERSION_LIBZ' => array('4.0.2', ''),
- 'CURL_VERSION_SSL' => array('4.0.2', ''),
-+ 'CURL_WRAPPERS_ENABLE' => array('5.4.15', ''),
- 'CURL_WRITEFUNC_PAUSE' => array('5.5.0-dev', ''),
-
- 'CURLAUTH_ANY' => array('4.0.2', ''),
---
-1.8.1.5
-
-From 519b2819557c82a7b34825a71e9c72359fe1d5e7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sat, 6 Apr 2013 07:00:29 +0200
-Subject: [PATCH] fix curl ref for php 5.4.15 (CURL_WRAPPERS_ENABLED)
-
----
- PHP/CompatInfo/Reference/curl.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/PHP/CompatInfo/Reference/curl.php b/PHP/CompatInfo/Reference/curl.php
-index a5f6488..879208f 100644
---- a/PHP/CompatInfo/Reference/curl.php
-+++ b/PHP/CompatInfo/Reference/curl.php
-@@ -172,7 +172,7 @@ public function getConstants($extension = null, $version = null, $condition = nu
- 'CURL_VERSION_KERBEROS4' => array('4.0.2', ''),
- 'CURL_VERSION_LIBZ' => array('4.0.2', ''),
- 'CURL_VERSION_SSL' => array('4.0.2', ''),
-- 'CURL_WRAPPERS_ENABLE' => array('5.4.15', ''),
-+ 'CURL_WRAPPERS_ENABLED' => array('5.4.15', ''),
- 'CURL_WRITEFUNC_PAUSE' => array('5.5.0-dev', ''),
-
- 'CURLAUTH_ANY' => array('4.0.2', ''),
---
-1.8.1.5
-
diff --git a/0030-fix-sphinx-test.patch b/0030-fix-sphinx-test.patch
deleted file mode 100644
index 73bc64a..0000000
--- a/0030-fix-sphinx-test.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From d75d31cc71065a6c7f44de9f029e255dce18aab9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 12 Apr 2013 08:53:32 +0200
-Subject: [PATCH] fix sphinx reference test
-
----
- tests/Reference/SphinxTest.php | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/Reference/SphinxTest.php b/tests/Reference/SphinxTest.php
-index d91ef30..39714bf 100644
---- a/tests/Reference/SphinxTest.php
-+++ b/tests/Reference/SphinxTest.php
-@@ -42,9 +42,12 @@ protected function setUp()
- {
- // Constants conditionnaly exists (according to libsphinx version)
- $this->optionalconstants = array(
-+ 'SPH_RANK_EXPR',
- 'SPH_RANK_FIELDMASK',
- 'SPH_RANK_MATCHANY',
- 'SPH_RANK_PROXIMITY',
-+ 'SPH_RANK_SPH04',
-+ 'SPH_RANK_TOTAL',
- );
- $this->obj = new PHP_CompatInfo_Reference_Sphinx();
- parent::setUp();
---
-1.8.1.5
-
diff --git a/0032-new-soap-constants.patch b/0032-new-soap-constants.patch
new file mode 100644
index 0000000..59b3385
--- /dev/null
+++ b/0032-new-soap-constants.patch
@@ -0,0 +1,27 @@
+From 8df8c44ed7d416709e9c1aa1277b075216cde4be Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 10 May 2013 11:19:28 +0200
+Subject: [PATCH] new SOAP_SSL_METHOD_* in php 5.5.0RC1
+
+---
+ PHP/CompatInfo/Reference/soap.php | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/soap.php b/PHP/CompatInfo/Reference/soap.php
+index 3c7d4c0..bd342a6 100644
+--- a/PHP/CompatInfo/Reference/soap.php
++++ b/PHP/CompatInfo/Reference/soap.php
+@@ -154,6 +154,10 @@ public function getConstants($extension = null, $version = null, $condition = nu
+ 'SOAP_ENC_OBJECT' => array('5.0.0', ''),
+ 'SOAP_FUNCTIONS_ALL' => array('5.0.0', ''),
+ 'SOAP_LITERAL' => array('5.0.0', ''),
++ 'SOAP_SSL_METHOD_TLS' => array('5.5.0-dev', ''),
++ 'SOAP_SSL_METHOD_SSLv2' => array('5.5.0-dev', ''),
++ 'SOAP_SSL_METHOD_SSLv23' => array('5.5.0-dev', ''),
++ 'SOAP_SSL_METHOD_SSLv3' => array('5.5.0-dev', ''),
+ 'SOAP_PERSISTENCE_REQUEST' => array('5.0.0', ''),
+ 'SOAP_PERSISTENCE_SESSION' => array('5.0.0', ''),
+ 'SOAP_RPC' => array('5.0.0', ''),
+--
+1.8.1.6
+
diff --git a/PHP_CompatInfo-2.14.0.patch b/PHP_CompatInfo-2.14.0.patch
deleted file mode 100644
index ab11208..0000000
--- a/PHP_CompatInfo-2.14.0.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- PHP_CompatInfo-2.14.0/PHP/CompatInfo/Report/Extension.php 2013-03-16 10:58:51.000000000 +0100
-+++ PHP_CompatInfo-2.14.0/PHP/CompatInfo/Report/Extension.php 2013-03-18 16:36:30.001438567 +0100
-@@ -45,7 +45,7 @@
- $this->totalConditions = 0;
- $this->globalVersions = array('4.0.0', '');
-
-- if ($this->isEmpty($elements)) {
-+ if ($this->isEmpty($extensions)) {
- return;
- }
- $this->printTHeader($base, false, $extensions);
diff --git a/PHP_CompatInfo-conf.patch b/PHP_CompatInfo-conf.patch
index 58bd881..a66a4a8 100644
--- a/PHP_CompatInfo-conf.patch
+++ b/PHP_CompatInfo-conf.patch
@@ -1,13 +1,5 @@
--- PHP_CompatInfo-2.14.1/phpcompatinfo.xml.dist 2013-04-01 18:17:03.000000000 +0200
+++ PHP_CompatInfo-2.14.1/phpcompatinfo.xml 2013-04-02 10:15:27.000000000 +0200
-@@ -1,6 +1,6 @@
- <?xml version="1.0" encoding="utf-8" ?>
- <phpcompatinfo
-- reference="PHP5"
-+ reference="ALL"
- report="summary"
- reportFileAppend="false"
- cacheDriver="file"
@@ -12,6 +12,7 @@
<cache id="file">
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 7c1b0f5..3b0d509 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -1,5 +1,4 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%global pear_name PHP_CompatInfo
%global channel bartlett.laurent-laville.org
@@ -8,8 +7,8 @@
Name: php-bartlett-PHP-CompatInfo
-Version: 2.15.0
-Release: 2%{?dist}
+Version: 2.16.0
+Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
Group: Development/Libraries
@@ -51,9 +50,8 @@ Patch25: 0025-array_column.patch
Patch26: 0026-fix-gd-reference-for-php-5.5.0beta2.patch
Patch27: 0027-fix-curl-ref-for-latest-libcurl.patch
Patch28: 0028-fix-reference-for-datetimeinterface.patch
-Patch29: 0029-fix-reference-curl-wrappers-enabled.patch
-Patch30: 0030-fix-sphinx-test.patch
Patch31: 0031-fix-opcache-reference-php550beta3.patch
+Patch32: 0032-new-soap-constants.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -133,9 +131,8 @@ cp phpcompatinfo.xml.dist phpcompatinfo.xml
%patch26 -p1
%patch27 -p1
%patch28 -p1
-%patch29 -p1
-%patch30 -p1
%patch31 -p1
+%patch32 -p1
# remove checksum for patched files
sed -e 's/md5sum.*name/name/' \
@@ -168,6 +165,7 @@ install -pm 644 phpcompatinfo.xml %{buildroot}%{pear_cfgdir}/%{pear_name}/
mkdir -p %{buildroot}%{_mandir}/man1
install -pm 644 %{SOURCE1} %{buildroot}%{_mandir}/man1/phpci.1
+
%check
cd %{pear_name}-%{version}%{?prever}
@@ -221,6 +219,9 @@ fi
%changelog
+* Fri May 10 2013 Remi Collet <remi@fedoraproject.org> - 2.16.0-1
+- Update to 2.16.0
+
* Fri Apr 12 2013 Remi Collet <remi@fedoraproject.org> - 2.15.0-2
- add upstream man page (from github)