summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-18 09:24:53 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-18 09:24:53 +0100
commit84e9eb4770992c16b375c255d80275db7350159e (patch)
treef70706e6868d4ce0c01b54f524dbbaa338055ee1
parente4d15d90222d85648b5ef9b285a52726b8b0fe0f (diff)
php-ZendFramework: 1.12.3 (backport)
-rw-r--r--0001-fix-gd-reference-for-php-5.5.0alpha6.patch56
-rw-r--r--php-bartlett-PHP-CompatInfo.spec7
2 files changed, 62 insertions, 1 deletions
diff --git a/0001-fix-gd-reference-for-php-5.5.0alpha6.patch b/0001-fix-gd-reference-for-php-5.5.0alpha6.patch
new file mode 100644
index 0000000..0af7d88
--- /dev/null
+++ b/0001-fix-gd-reference-for-php-5.5.0alpha6.patch
@@ -0,0 +1,56 @@
+From 94a4f11cac43454ed26d37fb71b4eafc4de61bc6 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Sat, 9 Mar 2013 16:26:31 +0100
+Subject: [PATCH] fix gd reference for php 5.5.0alpha6
+
+---
+ PHP/CompatInfo/Reference/gd.php | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/gd.php b/PHP/CompatInfo/Reference/gd.php
+index 60e16f3..d10be0f 100644
+--- a/PHP/CompatInfo/Reference/gd.php
++++ b/PHP/CompatInfo/Reference/gd.php
+@@ -118,6 +118,8 @@ class PHP_CompatInfo_Reference_Gd
+ 'imagecreatefromxpm' => array('4.0.1', ''),
+ 'imagecreatetruecolor' => array('4.0.6', ''),
+ 'imagecreatefromwebp' => array('5.4.0', ''),
++ 'imagecrop' => array('5.5.0-dev', ''),
++ 'imagecropauto' => array('5.5.0-dev', ''),
+ 'imagewebp' => array('5.4.0', ''),
+ 'imagedashedline' => array('4.0.0', ''),
+ 'imagedestroy' => array('4.0.0', ''),
+@@ -129,6 +131,7 @@ class PHP_CompatInfo_Reference_Gd
+ 'imagefilledrectangle' => array('4.0.0', ''),
+ 'imagefilltoborder' => array('4.0.0', ''),
+ 'imagefilter' => array('5.0.0', ''),
++ 'imageflip' => array('5.5.0-dev', ''),
+ 'imagefontheight' => array('4.0.0', ''),
+ 'imagefontwidth' => array('4.0.0', ''),
+ 'imageftbbox' => array('4.0.7', ''),
+@@ -217,6 +220,12 @@ class PHP_CompatInfo_Reference_Gd
+ 'IMG_COLOR_STYLEDBRUSHED' => array('4.0.0', ''),
+ 'IMG_COLOR_TILED' => array('4.0.0', ''),
+ 'IMG_COLOR_TRANSPARENT' => array('4.0.0', ''),
++ 'IMG_CROP_BLACK' => array('5.5.0-dev', ''),
++ 'IMG_CROP_DEFAULT' => array('5.5.0-dev', ''),
++ 'IMG_CROP_SIDES' => array('5.5.0-dev', ''),
++ 'IMG_CROP_TRANSPARENT' => array('5.5.0-dev', ''),
++ 'IMG_CROP_THRESHOLD' => array('5.5.0-dev', ''),
++ 'IMG_CROP_WHITE' => array('5.5.0-dev', ''),
+ 'IMG_EFFECT_ALPHABLEND' => array('4.0.0', ''),
+ 'IMG_EFFECT_NORMAL' => array('4.0.0', ''),
+ 'IMG_EFFECT_OVERLAY' => array('4.0.0', ''),
+@@ -233,6 +242,9 @@ class PHP_CompatInfo_Reference_Gd
+ 'IMG_FILTER_PIXELATE' => array('5.3.0', ''),
+ 'IMG_FILTER_SELECTIVE_BLUR' => array('4.0.0', ''),
+ 'IMG_FILTER_SMOOTH' => array('4.0.0', ''),
++ 'IMG_FLIP_HORIZONTAL' => array('5.5.0-dev', ''),
++ 'IMG_FLIP_VERTICAL' => array('5.5.0-dev', ''),
++ 'IMG_FLIP_BOTH' => array('5.5.0-dev', ''),
+ 'IMG_GD2_COMPRESSED' => array('4.0.0', ''),
+ 'IMG_GD2_RAW' => array('4.0.0', ''),
+ 'IMG_GIF' => array('4.0.0', ''),
+--
+1.7.11.7
+
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 9fd055b..acaed4b 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -8,7 +8,7 @@
Name: php-bartlett-PHP-CompatInfo
-Version: 2.13.2
+Version: 2.14.0
Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -40,6 +40,7 @@ Patch20: 0003-new-curl-changes-in-php-5.5.patch
Patch21: 0004-new-intl-changes-in-php-5.5.patch
Patch22: 0005-fix-covers-annotation.patch
Patch23: 0006-fix-mysqli-reference-for-php-5.5-trans.patch
+Patch24: 0001-fix-gd-reference-for-php-5.5.0alpha6.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -106,6 +107,7 @@ cd %{pear_name}-%{version}%{?prever}
%patch21 -p1
%patch22 -p1
%patch23 -p1
+%patch24 -p1
# remove checksum for patched files
sed -e 's/md5sum.*name/name/' \
@@ -189,6 +191,9 @@ fi
%changelog
+* Mon Mar 18 2013 Remi Collet <remi@fedoraproject.org> - 2.14.0-1
+- Update to 2.14.0
+
* Tue Feb 26 2013 Remi Collet <remi@fedoraproject.org> - 2.13.2-1
- Update to 2.13.2