summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-08 06:58:50 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-08 06:58:50 +0200
commit4a82ea58be4f99392c65777d96e7297d16f64fbc (patch)
tree7ca1631e11a1297530ffe576c71cf50766f61881
parent7e831fdc889e67f67070d16d8902c99fb58b371b (diff)
php-bartlett-PHP-CompatInfo: add upstream patch for missing extensions
-rw-r--r--php-bartlett-PHP-CompatInfo-upstream.patch24
-rw-r--r--php-bartlett-PHP-CompatInfo.spec11
2 files changed, 34 insertions, 1 deletions
diff --git a/php-bartlett-PHP-CompatInfo-upstream.patch b/php-bartlett-PHP-CompatInfo-upstream.patch
new file mode 100644
index 0000000..dfbac43
--- /dev/null
+++ b/php-bartlett-PHP-CompatInfo-upstream.patch
@@ -0,0 +1,24 @@
+From bcd5f85c93653ea2ba06b7a246b0b4778217c0f9 Mon Sep 17 00:00:00 2001
+From: Laurent Laville <laurent.laville@gmail.com>
+Date: Wed, 7 Oct 2015 21:52:18 +0200
+Subject: [PATCH] fix for issue GH-210
+
+---
+ src/Bartlett/CompatInfo/Analyser/CompatibilityAnalyser.php | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/Bartlett/CompatInfo/Analyser/CompatibilityAnalyser.php b/src/Bartlett/CompatInfo/Analyser/CompatibilityAnalyser.php
+index a79f05e..3577ed5 100644
+--- a/src/Bartlett/CompatInfo/Analyser/CompatibilityAnalyser.php
++++ b/src/Bartlett/CompatInfo/Analyser/CompatibilityAnalyser.php
+@@ -1221,5 +1221,10 @@ private function computeInternalVersions(Node $node, $element, $context, $extra
+
+ // update parent context
+ $this->updateContextVersion($versions);
++
++ if ($versions['ext.name'] !== 'user') {
++ // update versions of extension's $element
++ $this->updateElementVersion('extensions', $versions['ext.name'], $versions);
++ }
+ }
+ }
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index d9f6949..91e5eaa 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -17,7 +17,7 @@
Name: php-bartlett-PHP-CompatInfo
Version: 4.5.0
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -35,6 +35,10 @@ Source2: %{name}-autoload.php
# Autoload and sqlite database path
Patch0: %{name}-4.5.0-rpm.patch
+# Upstream patch for missing extensions
+# https://github.com/llaville/php-compat-info/issues/210
+Patch1: %{name}-upstream.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3.2
%if %{with_tests}
@@ -107,6 +111,7 @@ Documentation: http://php5.laurent-laville.org/compatinfo/manual/current/en/
#setup -q -n %{gh_project}-%{version}
%patch0 -p1 -b .rpm
+%patch1 -p1
cp %{SOURCE2} src/Bartlett/CompatInfo/autoload.php
# Cleanup patched files
@@ -170,6 +175,10 @@ fi
%changelog
+* Thu Oct 8 2015 Remi Collet <remi@fedoraproject.org> - 4.5.0-2
+- add upstream patch for missing extensions
+ https://github.com/llaville/php-compat-info/issues/210
+
* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 4.5.0-1
- update to 4.5.0