summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-02-22 09:49:03 +0100
committerRemi Collet <fedora@famillecollet.com>2015-02-22 09:49:03 +0100
commitfa1b616aa32ca107e061032514b2c4cc18041be4 (patch)
tree33dbc261eaafdd0de9802480d6a5b692fe1151a2
parent67ad49830a6fd94588562d124a6d09729827b764 (diff)
php-bartlett-PHP-CompatInfo: 4.0.0beta2
-rw-r--r--php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch22
-rw-r--r--php-bartlett-PHP-CompatInfo-dev.spec11
2 files changed, 17 insertions, 16 deletions
diff --git a/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch b/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
index fcfb947..455742d 100644
--- a/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
+++ b/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
@@ -1,13 +1,13 @@
diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
---- ./bin/phpcompatinfo.rpm 2015-02-04 11:23:57.000000000 +0100
-+++ ./bin/phpcompatinfo 2015-02-04 15:14:33.341279703 +0100
+--- ./bin/phpcompatinfo.rpm 2015-02-20 10:59:04.000000000 +0100
++++ ./bin/phpcompatinfo 2015-02-22 09:37:46.130869824 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
- ini_set('memory_limit', -1);
$appName = 'phpCompatInfo';
-@@ -17,8 +17,28 @@ if (\Phar::running()) {
+
+@@ -16,8 +16,28 @@ if (\Phar::running()) {
putenv("BARTLETTRC=" . strtolower($appName) . '.json');
}
}
@@ -39,8 +39,8 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
if (PHP_SAPI !== 'cli') {
return;
diff -up ./data/handleDB.php.rpm ./data/handleDB.php
---- ./data/handleDB.php.rpm 2015-02-04 15:11:49.584033737 +0100
-+++ ./data/handleDB.php 2015-02-04 15:14:04.995064027 +0100
+--- ./data/handleDB.php.rpm 2015-02-20 10:59:04.000000000 +0100
++++ ./data/handleDB.php 2015-02-22 09:36:34.008567158 +0100
@@ -11,7 +11,18 @@
* @since Release 4.0.0alpha3
*/
@@ -62,9 +62,9 @@ diff -up ./data/handleDB.php.rpm ./data/handleDB.php
use Bartlett\CompatInfo\Reference\ExtensionFactory;
diff -up ./src/Bartlett/CompatInfo/Environment.php.rpm ./src/Bartlett/CompatInfo/Environment.php
---- ./src/Bartlett/CompatInfo/Environment.php.rpm 2015-02-04 15:15:02.113498620 +0100
-+++ ./src/Bartlett/CompatInfo/Environment.php 2015-02-04 15:16:30.986169085 +0100
-@@ -22,6 +22,10 @@ class Environment
+--- ./src/Bartlett/CompatInfo/Environment.php.rpm 2015-02-20 10:59:04.000000000 +0100
++++ ./src/Bartlett/CompatInfo/Environment.php 2015-02-22 09:36:34.008567158 +0100
+@@ -34,6 +34,10 @@ class Environment
*/
public static function initRefDb()
{
@@ -76,8 +76,8 @@ diff -up ./src/Bartlett/CompatInfo/Environment.php.rpm ./src/Bartlett/CompatInfo
$tempDir = sys_get_temp_dir() . '/bartlett';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2015-02-04 11:23:57.000000000 +0100
-+++ ./tests/bootstrap.php 2015-02-04 15:11:49.584033737 +0100
+--- ./tests/bootstrap.php.rpm 2015-02-20 10:59:04.000000000 +0100
++++ ./tests/bootstrap.php 2015-02-22 09:36:34.008567158 +0100
@@ -1,8 +1,30 @@
<?php
diff --git a/php-bartlett-PHP-CompatInfo-dev.spec b/php-bartlett-PHP-CompatInfo-dev.spec
index e313266..6036725 100644
--- a/php-bartlett-PHP-CompatInfo-dev.spec
+++ b/php-bartlett-PHP-CompatInfo-dev.spec
@@ -6,15 +6,15 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6cd2777f2c9f035810f51e8ade838c0698cf5874
+%global gh_commit 442d25d486511e4a8e2ed15d1841529ae12e76e7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20150204
+%global gh_date 20150220
%global gh_owner llaville
%global gh_project php-compat-info
Name: php-bartlett-PHP-CompatInfo
Version: 4.0.0
-%global specrel 3
+%global specrel 4
Release: %{?gh_short:0.%{specrel}.%{?gh_date}git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -92,8 +92,6 @@ Documentation: http://php5.laurent-laville.org/compatinfo/manual/current/en/
sed -e 's/@package_version@/%{version}/' \
-i $(find src -name \*.php)
-mv data/compatinfo.sqlite data/compatinfo.sqlite.upstream
-
%build
: Generate the references database
@@ -140,6 +138,9 @@ fi
%changelog
+* Sun Feb 22 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-0.4.20150220git442d25d
+- update to 4.0.0beta2
+
* Wed Feb 4 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-0.3.20150204git6cd2777
- update to 4.0.0beta1