summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-06 07:38:10 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-06 07:38:10 +0200
commitbba10a21efacc7719fe610375280667087201c4b (patch)
tree15439d42aae49e7690cc2d3717a58a867359dde4
parented675fd0ba2bccf5aab634c7964ec247151340e1 (diff)
php-bartlett-PHP-CompatInfo: 5.0.1
-rw-r--r--composer.json72
-rw-r--r--php-bartlett-PHP-CompatInfo.spec33
2 files changed, 93 insertions, 12 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..7bb77fa
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,72 @@
+{
+ "name": "bartlett/php-compatinfo",
+ "description": "Find out the minimum version and the extensions required for a piece of code to run",
+ "keywords": ["compatibility", "version"],
+ "type": "library",
+ "license": "BSD-3-Clause",
+ "homepage": "http://php5.laurent-laville.org/compatinfo/",
+ "support": {
+ "source": "https://github.com/llaville/php-compat-info",
+ "issues": "https://github.com/llaville/php-compat-info/issues"
+ },
+ "repositories": [
+ {
+ "type": "pear",
+ "url": "https://pear.php.net"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.0",
+ "ext-libxml": "*",
+ "ext-pcre": "*",
+ "ext-spl": "*",
+ "ext-json": "*",
+ "ext-pdo_sqlite": "*",
+ "bartlett/php-reflect": "~4.0",
+ "bartlett/php-compatinfo-db": "~1.0"
+ },
+ "require-dev": {
+ "doctrine/cache": "~1.3",
+ "psr/log": "~1.0",
+ "monolog/monolog": "~1.10",
+ "bartlett/monolog-callbackfilterhandler": "~1.0",
+ "bartlett/monolog-growlhandler": "~1.0",
+ "bartlett/phpunit-loggertestlistener": "~1.5",
+ "bartlett/umlwriter": "~1.0"
+ },
+ "suggest": {
+ "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
+ "psr/log": "Allow logging events with the LogPlugin",
+ "monolog/monolog": "Allow logging events with the LogPlugin",
+ "bartlett/monolog-callbackfilterhandler": "Advanced filtering strategies for Monolog",
+ "bartlett/monolog-growlhandler": "Sends notifications to Growl for Monolog",
+ "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface",
+ "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
+ },
+ "authors": [
+ {
+ "name": "Laurent Laville",
+ "email": "pear@laurent-laville.org",
+ "homepage": "https://github.com/llaville",
+ "role": "Lead"
+ },
+ {
+ "name": "Remi Collet",
+ "homepage": "https://github.com/remicollet",
+ "role": "Contributor"
+ }
+ ],
+ "bin": [
+ "bin/phpcompatinfo"
+ ],
+ "autoload": {
+ "psr-4": {
+ "Bartlett\\": "src/Bartlett"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Bartlett\\Tests\\CompatInfo\\": "tests/"
+ }
+ }
+}
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 18a6498..a2d6202 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 1b65ee36ac475e2ce3a20fae612659ea933338c6
+%global gh_commit 300a1689891aa97a6733ef496081ec394f53486b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -16,8 +16,8 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-bartlett-PHP-CompatInfo
-Version: 5.0.0
-%global specrel 2
+Version: 5.0.1
+%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -90,7 +90,6 @@ Requires: php-composer(symfony/console) < 3
# "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
# Required by autoloader
Requires: php-composer(symfony/class-loader)
-Requires: php-bartlett-PHP-Reflect >= 3.1.1-3
Provides: phpcompatinfo = %{version}
Provides: php-composer(bartlett/php-compatinfo) = %{version}
@@ -140,15 +139,22 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
mkdir vendor
ln -s %{buildroot}%{_datadir}/php/Bartlett/CompatInfo/autoload.php vendor/
-%{_bindir}/phpunit \
- --include-path %{buildroot}%{_datadir}/php \
- -d memory_limit=1G
-
-if which php70; then
- php70 %{_bindir}/phpunit \
- --include-path %{buildroot}%{_datadir}/php \
- -d memory_limit=1G
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit || ret=1
+ run=1
fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path %{buildroot}%{_datadir}/php --verbose
+# remirepo:2
+fi
+exit $ret
%endif
@@ -171,6 +177,9 @@ fi
%changelog
+* Wed Jul 6 2016 Remi Collet <remi@fedoraproject.org> - 5.0.1-1
+- update to 5.0.1
+
* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 5.0.0-2
- display DB version instead of build date