summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-06 15:36:40 +0100
committerRemi Collet <remi@remirepo.net>2017-12-06 15:36:40 +0100
commit53221319d8c7b35c39f505e6d45308537959df36 (patch)
tree68abcd1b8b6f0cb47a3d5539765b6c96da47d8b8
parent9720ed619f9a2f96b22358ef0d42812f110b4701 (diff)
v5.0.9
-rw-r--r--composer.json18
-rw-r--r--php-bartlett-PHP-CompatInfo.spec25
2 files changed, 23 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 11bc430..6a39b82 100644
--- a/composer.json
+++ b/composer.json
@@ -22,17 +22,17 @@
"ext-spl": "*",
"ext-json": "*",
"ext-pdo_sqlite": "*",
- "bartlett/php-reflect": "~4.0",
- "bartlett/php-compatinfo-db": "~1.23"
+ "bartlett/php-reflect": "^4.0",
+ "bartlett/php-compatinfo-db": "^1.23"
},
"require-dev": {
- "doctrine/cache": "~1.3",
- "psr/log": "~1.0",
- "monolog/monolog": "~1.10",
- "bartlett/monolog-callbackfilterhandler": "~1.0",
- "bartlett/monolog-growlhandler": "~1.0",
- "bartlett/phpunit-loggertestlistener": "~1.5",
- "bartlett/umlwriter": "~1.0"
+ "doctrine/cache": "^1.3",
+ "psr/log": "^1.0",
+ "monolog/monolog": "^1.10",
+ "bartlett/monolog-callbackfilterhandler": "^1.0",
+ "bartlett/monolog-growlhandler": "^1.0",
+ "bartlett/phpunit-loggertestlistener": "^1.5",
+ "bartlett/umlwriter": "^1.0"
},
"suggest": {
"doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 1a98fc0..8962fc7 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 18913e8807d2ab02dea89b60e006ec395a131f0c
+%global gh_commit 23db55a1c8f8a078e691bc66524fcb73eabbcb2c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -16,7 +16,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-bartlett-PHP-CompatInfo
-Version: 5.0.8
+Version: 5.0.9
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -55,8 +55,8 @@ BuildRequires: php-composer(fedora/autoloader)
# "ext-json": "*",
# "ext-pdo_sqlite": "*",
# "symfony/console": "~2.5",
-# "bartlett/php-reflect": "~4.0",
-# "bartlett/php-compatinfo-db": "~1.23"
+# "bartlett/php-reflect": "^4.0",
+# "bartlett/php-compatinfo-db": "^1.23"
Requires: php(language) >= 5.4.0
Requires: php-cli
Requires: php-json
@@ -71,13 +71,13 @@ Requires: php-composer(bartlett/php-compatinfo-db) < 2
Requires: php-composer(symfony/console) >= 2.5
Requires: php-composer(symfony/console) < 3
# From composer.json, "require-dev": {
-# "doctrine/cache": "~1.3",
-# "psr/log": "~1.0",
-# "monolog/monolog": "~1.10",
-# "bartlett/monolog-callbackfilterhandler": "~1.0",
-# "bartlett/monolog-growlhandler": "~1.0",
-# "bartlett/phpunit-loggertestlistener": "~1.5",
-# "bartlett/umlwriter": "~1.0"
+# "doctrine/cache": "^1.3",
+# "psr/log": "^1.0",
+# "monolog/monolog": "^1.10",
+# "bartlett/monolog-callbackfilterhandler": "^1.0",
+# "bartlett/monolog-growlhandler": "^1.0",
+# "bartlett/phpunit-loggertestlistener": "^1.5",
+# "bartlett/umlwriter": "^1.0"
# From composer.json, "suggest"
# "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
# "psr/log": "Allow logging events with the LogPlugin",
@@ -169,6 +169,9 @@ fi
%changelog
+* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 5.0.9-1
+- Update to 5.0.9
+
* Mon Jul 17 2017 Remi Collet <remi@remirepo.net> - 5.0.8-1
- Update to 5.0.8