summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-04 15:39:42 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-04 15:39:42 +0200
commit28791aceee2e9923d3864bb6baa6f80e7466e3f7 (patch)
tree7898aaa79c3b09a2b3caff52a263c18e56b2f1db
parent14aef1f6199226af39eabbe1d8d8ee61b39264e1 (diff)
php-bartlett-PHP-CompatInfo: add cache plugin in default configuration
-rw-r--r--php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch45
-rw-r--r--php-bartlett-PHP-CompatInfo.spec16
2 files changed, 50 insertions, 11 deletions
diff --git a/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch b/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
index a3703b6..03a20e2 100644
--- a/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
+++ b/php-bartlett-PHP-CompatInfo-4.0.0-rpm.patch
@@ -1,13 +1,36 @@
+diff -up ./bin/phpcompatinfo.json.dist.rpm ./bin/phpcompatinfo.json.dist
+--- ./bin/phpcompatinfo.json.dist.rpm 2015-04-04 15:32:17.536201524 +0200
++++ ./bin/phpcompatinfo.json.dist 2015-04-04 15:32:37.776282296 +0200
+@@ -6,6 +6,19 @@
+ }
+ ],
+ "plugins": [
++ {
++ "name": "Cache",
++ "class": "Bartlett\\Reflect\\Plugin\\CachePlugin",
++ "options": {
++ "adapter": "DoctrineCacheAdapter",
++ "backend": {
++ "class": "Doctrine\\Common\\Cache\\FilesystemCache",
++ "args": [
++ "%{HOME}/.cache/php-reflect"
++ ]
++ }
++ }
++ }
+ ],
+ "analysers" : [
+ ],
diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
---- ./bin/phpcompatinfo.rpm 2015-02-20 10:59:04.000000000 +0100
-+++ ./bin/phpcompatinfo 2015-02-22 11:42:38.671479626 +0100
+--- ./bin/phpcompatinfo.rpm 2015-04-04 08:52:23.000000000 +0200
++++ ./bin/phpcompatinfo 2015-04-04 15:33:59.668609143 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
$appName = 'phpCompatInfo';
-@@ -16,8 +16,28 @@ if (\Phar::running()) {
+@@ -16,8 +16,30 @@ if (\Phar::running()) {
putenv("BARTLETTRC=" . strtolower($appName) . '.json');
}
}
@@ -32,13 +55,15 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
+ 'phpDocumentor\\Reflection' => $vendorDir,
+ 'Seld\\JsonLint' => $vendorDir,
+ 'JsonSchema' => $vendorDir,
++ 'Psr\\Log' => $vendorDir,
++ 'Monolog' => $vendorDir,
+ 'Bartlett' => $vendorDir,
+));
+$loader->register();
if (PHP_SAPI !== 'cli') {
return;
-@@ -28,5 +48,5 @@ use Bartlett\CompatInfo\Console\Applicat
+@@ -28,5 +50,5 @@ use Bartlett\CompatInfo\Console\Applicat
Environment::setScanDir();
@@ -46,8 +71,8 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
+$application = new Application($appName, '@package_version@');
$application->run();
diff -up ./data/handleDB.php.rpm ./data/handleDB.php
---- ./data/handleDB.php.rpm 2015-02-20 10:59:04.000000000 +0100
-+++ ./data/handleDB.php 2015-02-22 11:42:15.277385330 +0100
+--- ./data/handleDB.php.rpm 2015-04-04 08:52:23.000000000 +0200
++++ ./data/handleDB.php 2015-04-04 15:31:55.188112331 +0200
@@ -11,7 +11,18 @@
* @since Release 4.0.0alpha3
*/
@@ -69,8 +94,8 @@ diff -up ./data/handleDB.php.rpm ./data/handleDB.php
use Bartlett\CompatInfo\Reference\ExtensionFactory;
diff -up ./src/Bartlett/CompatInfo/Environment.php.rpm ./src/Bartlett/CompatInfo/Environment.php
---- ./src/Bartlett/CompatInfo/Environment.php.rpm 2015-02-20 10:59:04.000000000 +0100
-+++ ./src/Bartlett/CompatInfo/Environment.php 2015-02-22 11:42:15.277385330 +0100
+--- ./src/Bartlett/CompatInfo/Environment.php.rpm 2015-04-04 08:52:23.000000000 +0200
++++ ./src/Bartlett/CompatInfo/Environment.php 2015-04-04 15:31:55.188112331 +0200
@@ -34,6 +34,10 @@ class Environment
*/
public static function initRefDb()
@@ -83,8 +108,8 @@ diff -up ./src/Bartlett/CompatInfo/Environment.php.rpm ./src/Bartlett/CompatInfo
$tempDir = sys_get_temp_dir() . '/bartlett';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2015-02-20 10:59:04.000000000 +0100
-+++ ./tests/bootstrap.php 2015-02-22 11:42:15.277385330 +0100
+--- ./tests/bootstrap.php.rpm 2015-04-04 08:52:23.000000000 +0200
++++ ./tests/bootstrap.php 2015-04-04 15:31:55.188112331 +0200
@@ -1,8 +1,31 @@
<?php
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index f9f8a56..95d4faf 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -16,7 +16,7 @@
Name: php-bartlett-PHP-CompatInfo
Version: 4.0.0
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -60,7 +60,18 @@ Requires: php-composer(bartlett/php-reflect) >= 3.0.0
Requires: php-composer(bartlett/php-reflect) < 4
Requires: php-composer(symfony/console) >= 2.5
Requires: php-composer(symfony/console) < 3
+# From composer.json, "require-dev": {
+# "doctrine/cache": "~1.3",
+# "psr/log": "~1.0",
+# "monolog/monolog": "~1.10",
+# "bartlett/phpunit-loggertestlistener": "~1.1",
+# "bartlett/umlwriter": "~1.0"
# From composer.json, "suggest"
+# "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
+# "psr/log": "Allow logging events with the LogPlugin",
+# "monolog/monolog": "Allow logging events with the LogPlugin",
+# "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface",
+# "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
# "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2"
# "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
Requires: php-composer(doctrine/cache)
@@ -154,6 +165,9 @@ fi
%changelog
+* Sat Apr 4 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-2
+- add cache plugin in default configuration
+
* Sat Apr 4 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-1
- update to 4.0.0