summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-12 14:20:25 +0100
committerRemi Collet <remi@remirepo.net>2017-12-12 14:20:25 +0100
commit1a7ab8c841e1a47203428127ef9cf5e8b1010d9b (patch)
tree16a2d37c50ea803f3f1001b95d636bd2d06ead20
parentb9b596173d6fd8074120bfc2d72e6426cd8ac5e2 (diff)
Update to 5.0.11 (no change)
raise dependency on PHP 5.5
-rw-r--r--composer.json10
-rw-r--r--php-bartlett-PHP-CompatInfo.spec18
2 files changed, 19 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 6a39b82..76baccf 100644
--- a/composer.json
+++ b/composer.json
@@ -16,13 +16,13 @@
}
],
"require": {
- "php": ">=5.4.0",
+ "php": ">=5.5",
"ext-libxml": "*",
"ext-pcre": "*",
"ext-spl": "*",
"ext-json": "*",
"ext-pdo_sqlite": "*",
- "bartlett/php-reflect": "^4.0",
+ "bartlett/php-reflect": "^4.2",
"bartlett/php-compatinfo-db": "^1.23"
},
"require-dev": {
@@ -68,5 +68,11 @@
"psr-4": {
"Bartlett\\Tests\\CompatInfo\\": "tests/"
}
+ },
+ "config": {
+ "platform": {
+ "php": "5.5.0"
+ },
+ "optimize-autoloader": true
}
}
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 3cb22d1..868ce77 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit c2ba1eca8ec7927e01f0178095a63b7982326893
+%global gh_commit 56a9f8bcfa63651d5752659447d6145cfa296a3e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -22,7 +22,7 @@
%endif
Name: php-bartlett-PHP-CompatInfo
-Version: 5.0.10
+Version: 5.0.11
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -30,7 +30,7 @@ Summary: Find out version and the extensions required for a piece of code
Group: Development/Libraries
License: BSD
URL: http://php5.laurent-laville.org/compatinfo/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}%{?prever}-%{gh_short}.tar.gz
# Script for fedora-review
Source1: fedora-review-check
@@ -42,7 +42,7 @@ Source2: %{name}-5.0.0-autoload.php
Patch0: %{name}-5.0.0-rpm.patch
BuildArch: noarch
-BuildRequires: php(language) >= 5.4.0
+BuildRequires: php(language) >= 5.5
%if %{with_tests}
# to run test suite
BuildRequires: %{_bindir}/phpunit
@@ -54,16 +54,16 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require"
-# "php": ">=5.4.0",
+# "php": ">=5.5",
# "ext-libxml": "*",
# "ext-pcre": "*",
# "ext-spl": "*",
# "ext-json": "*",
# "ext-pdo_sqlite": "*",
# "symfony/console": "~2.5",
-# "bartlett/php-reflect": "^4.0",
+# "bartlett/php-reflect": "^4.2",
# "bartlett/php-compatinfo-db": "^1.23"
-Requires: php(language) >= 5.4.0
+Requires: php(language) >= 5.5
Requires: php-cli
Requires: php-json
Requires: php-libxml
@@ -174,6 +174,10 @@ fi
%changelog
+* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 5.0.11-1
+- Update to 5.0.11 (no change)
+- raise dependency on PHP 5.5
+
* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 5.0.10-1
- Update to 5.0.10 (no change)
- raise dependency on bartlett/php-reflect 4.2