summaryrefslogtreecommitdiffstats
path: root/php-alcaeus-mongo-php-adapter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-alcaeus-mongo-php-adapter.spec')
-rw-r--r--php-alcaeus-mongo-php-adapter.spec16
1 files changed, 3 insertions, 13 deletions
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 5d091ea..4f2e8be 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -43,12 +43,7 @@ BuildRequires: php-spl
# from composer.json, require-dev": {
# "phpunit/phpunit": "^5.7 || ^6.0"
BuildRequires: mongodb-server >= 3.4
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
+BuildRequires: phpunit6
%endif
# From composer.json, "require": {
@@ -132,16 +127,11 @@ if [ ! -s server.pid ] ; then
fi
: Run the test suite
-ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit6" "php72 %{_bindir}/phpunit"; do
- if which $cmd; then
- set $cmd
- $1 $2 --bootstrap bs.php || ret=1
- fi
-done
+%{_bindir}/phpunit6 --bootstrap bs.php || ret=1
: Cleanup
kill $(cat server.pid)
+sleep 1
exit $ret
%else