summaryrefslogtreecommitdiffstats
path: root/php-alcaeus-mongo-php-adapter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-alcaeus-mongo-php-adapter.spec')
-rw-r--r--php-alcaeus-mongo-php-adapter.spec11
1 files changed, 4 insertions, 7 deletions
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 3b8364f..5a9a728 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -13,8 +13,10 @@
# Upstream only support 64bits, see https://jira.mongodb.org/browse/CDRIVER-1186
# Server only available on LE arch (ExcludeArch: ppc ppc64 %{sparc} s390 s390x)
%global with_tests 0%{?_with_tests:1}
-# remirepo:3
-%if 0%{?fedora} >= 24
+# remirepo:5
+# Test suite rely on MongoDB server 3.2
+# https://github.com/alcaeus/mongo-php-adapter/issues/164
+%if 0%{?fedora} >= 24 && 0%{?fedora} <= 25
%global with_tests 0%{!?_without_tests:1}
%endif
%global ns_vendor Alcaeus
@@ -110,11 +112,6 @@ cp -pr lib/%{ns_vendor} %{buildroot}%{_datadir}/php/%{ns_vendor}
%if %{with_tests}
RET=0
-# ignore know to fail tests (different error code)
-sed -e 's/testDeleteIndexUsingIndexName/SKIP_testDeleteIndexUsingIndexName/' \
- -e 's/testDeleteIndexesForNonExistingCollection/SKIP_testDeleteIndexesForNonExistingCollection/' \
- -i tests/%{ns_vendor}/MongoDbAdapter/Mongo/MongoCollectionTest.php
-
cat << 'EOF' | tee bs.php
<?php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/MongoDbAdapter/autoload.php';