summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-alcaeus-mongo-php-adapter.spec37
1 files changed, 11 insertions, 26 deletions
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 955606e..c60785a 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a85069eb0d1b8c3dc7b24572e91f158f8a3c9e77
+%global gh_commit d3545f94ac76bdfbeb75b329e57ff2a0626aa429
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alcaeus
%global gh_project mongo-php-adapter
@@ -21,8 +21,8 @@
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.10
-Release: 2%{?dist}
+Version: 1.0.11
+Release: 1%{?dist}
Summary: Mongo PHP Adapter
Group: Development/Libraries
@@ -32,7 +32,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: 167.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php(language) >= 5.5
@@ -103,15 +102,12 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{_datadir}/php
cp -pr lib/%{ns_vendor} %{buildroot}%{_datadir}/php/%{ns_vendor}
%check
%if %{with_tests}
-RET=0
-
cat << 'EOF' | tee bs.php
<?php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/MongoDbAdapter/autoload.php';
@@ -133,20 +129,11 @@ fi
: Run the test suite
ret=0
-# remirepo:10
-run=0
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap bs.php || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --bootstrap bs.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --bootstrap bs.php || ret=1
-# remirepo:1
-fi
+for cmd in php php56 php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --bootstrap bs.php || ret=1
+ fi
+done
: Cleanup
kill $(cat server.pid)
@@ -157,12 +144,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -171,6 +153,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 27 2017 Remi Collet <remi@remirepo.net> - 1.0.11-1
+- Update to 1.0.11
+
* Wed Apr 12 2017 Remi Collet <remi@remirepo.net> - 1.0.10-2
- add patch from https://github.com/alcaeus/mongo-php-adapter/pull/167
- enable test suite with mongodb 3.1 (F26)