summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-alcaeus-mongo-php-adapter.spec16
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 86af9c5..3b71238 100644
--- a/composer.json
+++ b/composer.json
@@ -15,7 +15,7 @@
"mongodb/mongodb": "^1.0.1"
},
"require-dev": {
- "phpunit/phpunit": "^5.7 || ^6.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.0 || ^7.0",
"squizlabs/php_codesniffer": "^3.2"
},
"provide": {
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 4660fe9..b70b894 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 45ba115e448c735cb0dbed5ebe857971aa4d43f5
+%global gh_commit 4f21e1fdc21eee0e35bdaf854ecc3c58179d1ef7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alcaeus
%global gh_project mongo-php-adapter
@@ -14,14 +14,14 @@
# Server only available on LE arch (ExcludeArch: ppc ppc64 %%{sparc} s390 s390x)
%global with_tests 0%{?_with_tests:1}
# remirepo:3
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} == 27
%global with_tests 0%{!?_without_tests:1}
%endif
%global ns_vendor Alcaeus
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.1.4
+Version: 1.1.5
Release: 1%{?dist}
Summary: Mongo PHP Adapter
@@ -41,10 +41,10 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, require-dev": {
-# "phpunit/phpunit": "^5.7 || ^6.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.0 || ^7.0",
# "squizlabs/php_codesniffer": "^3.2"
BuildRequires: mongodb-server >= 3.4
-BuildRequires: phpunit6
+BuildRequires: phpunit7
%endif
# From composer.json, "require": {
@@ -128,7 +128,7 @@ if [ ! -s server.pid ] ; then
fi
: Run the test suite
-%{_bindir}/phpunit6 --bootstrap bs.php || ret=1
+%{_bindir}/phpunit7 --bootstrap bs.php || ret=1
: Cleanup
kill $(cat server.pid)
@@ -149,6 +149,10 @@ exit $ret
%changelog
+* Tue Mar 6 2018 Remi Collet <remi@remirepo.net> - 1.1.5-1
+- Update to 1.1.5
+- switch to phpunit7
+
* Thu Jan 25 2018 Remi Collet <remi@remirepo.net> - 1.1.4-1
- Update to 1.1.4