summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--composer.json11
-rw-r--r--php-alcaeus-mongo-php-adapter.spec68
3 files changed, 66 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
index 95b26a9..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
+clog
+package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 3b71238..dcc3041 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,7 @@
{
"name": "alcaeus/mongo-php-adapter",
"type": "library",
- "description": "Adapter to provide ext-mongo interface on top of mongo-php-libary",
+ "description": "Adapter to provide ext-mongo interface on top of mongo-php-library",
"keywords": ["mongodb", "database"],
"license": "MIT",
"authors": [
@@ -9,13 +9,14 @@
{ "name": "Olivier Lechevalier", "email": "olivier.lechevalier@gmail.com" }
],
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^5.6 || ^7.0 || ^8.0",
+ "ext-ctype": "*",
"ext-hash": "*",
"ext-mongodb": "^1.2.0",
"mongodb/mongodb": "^1.0.1"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.0 || ^7.0",
+ "symfony/phpunit-bridge": "^4.4.16 || ^5.2",
"squizlabs/php_codesniffer": "^3.2"
},
"provide": {
@@ -34,8 +35,6 @@
"psr-4": { "Alcaeus\\MongoDbAdapter\\Tests\\": "tests/Alcaeus/MongoDbAdapter" }
},
"extra": {
- "branch-alias": {
- "dev-master": "1.1.x-dev"
- }
+ "branch-version": "1.x"
}
}
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 738ca75..584dfba 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -1,22 +1,24 @@
# remirepo/fedora spec file for php-alcaeus-mongo-php-adapter
#
-# Copyright (c) 2016-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 6111fb94e2e67b24b19681715f9caee4309e1eb5
+
+# disabled for https://fedoraproject.org/wiki/Changes/MongoDB_Removal
+%bcond_with tests
+
+%global gh_commit 561496fca4989dc728ed3dda50331aacae62ee9c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alcaeus
%global gh_project mongo-php-adapter
-# disabled for https://fedoraproject.org/wiki/Changes/MongoDB_Removal
-%global with_tests 0%{?_with_tests:1}
%global ns_vendor Alcaeus
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.1.6
+Version: 1.2.5
Release: 1%{?dist}
Summary: Mongo PHP Adapter
@@ -27,10 +29,13 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php(language) >= 5.6
-%if %{with_tests}
+%if %{with tests}
+BuildRequires: php-ctype
BuildRequires: php-hash
BuildRequires: php-composer(mongodb/mongodb) >= 1.0.1
+BuildRequires: php-reflection
BuildRequires: php-date
+BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -42,16 +47,20 @@ BuildRequires: phpunit7
%endif
# From composer.json, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^5.6 || ^7.0 || ^8.0",
+# "ext-ctype": "*",
# "ext-hash": "*",
# "ext-mongodb": "^1.2.0",
# "mongodb/mongodb": "^1.0.1"
Requires: php(language) >= 5.6
+Requires: php-ctype
Requires: php-hash
Requires: php-pecl(mongodb) >= 1.2.0
Requires: php-composer(mongodb/mongodb) >= 1.0.1
-# From phpcompatinfo report for 1.0.3
+# From phpcompatinfo report for 1.1.7
+Requires: php-reflection
Requires: php-date
+Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
@@ -101,7 +110,7 @@ cp -pr lib/%{ns_vendor} %{buildroot}%{_datadir}/php/%{ns_vendor}
%check
-%if %{with_tests}
+%if %{with tests}
cat << 'EOF' | tee bs.php
<?php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/MongoDbAdapter/autoload.php';
@@ -143,6 +152,45 @@ exit $ret
%changelog
+* Wed Nov 29 2023 Remi Collet <remi@remirepo.net> - 1.2.5-1
+- update to 1.2.5
+
+* Wed Oct 4 2023 Remi Collet <remi@remirepo.net> - 1.2.4-1
+- update to 1.2.4
+
+* Fri Jul 21 2023 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+
+* Mon Feb 7 2022 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
+* Fri Jul 9 2021 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+
+* Thu Nov 12 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 1.1.13-1
+- update to 1.1.13
+
+* Mon Oct 19 2020 Remi Collet <remi@remirepo.net> - 1.1.12-1
+- update to 1.1.12
+
+* Tue Nov 12 2019 Remi Collet <remi@remirepo.net> - 1.1.11-1
+- update to 1.1.11
+
+* Thu Nov 7 2019 Remi Collet <remi@remirepo.net> - 1.1.10-1
+- update to 1.1.10
+
+* Thu Aug 8 2019 Remi Collet <remi@remirepo.net> - 1.1.9-1
+- update to 1.1.9
+
+* Mon Jul 15 2019 Remi Collet <remi@remirepo.net> - 1.1.8-1
+- update to 1.1.8
+
+* Mon Apr 8 2019 Remi Collet <remi@remirepo.net> - 1.1.7-1
+- update to 1.1.7
+
* Fri Feb 8 2019 Remi Collet <remi@remirepo.net> - 1.1.6-1
- update to 1.1.6
- drop patch merged upstream