summaryrefslogtreecommitdiffstats
path: root/php-alcaeus-mongo-php-adapter.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-14 18:57:41 +0200
committerRemi Collet <remi@remirepo.net>2017-05-14 18:57:41 +0200
commit703c24113ec12bba71289837751cd762d3eaee56 (patch)
tree46e730bc6c69583df3546f23bcbab95264325377 /php-alcaeus-mongo-php-adapter.spec
parentcafd633bb869aa98f8dd01619f178cf8abd8099a (diff)
v1.1.0
Diffstat (limited to 'php-alcaeus-mongo-php-adapter.spec')
-rw-r--r--php-alcaeus-mongo-php-adapter.spec39
1 files changed, 25 insertions, 14 deletions
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 0cbc092..5d091ea 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d3545f94ac76bdfbeb75b329e57ff2a0626aa429
+%global gh_commit 72870346ae8bf53f8238593dc1dfe73efdc1c77a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alcaeus
%global gh_project mongo-php-adapter
@@ -14,14 +14,14 @@
# Server only available on LE arch (ExcludeArch: ppc ppc64 %{sparc} s390 s390x)
%global with_tests 0%{?_with_tests:1}
# remirepo:3
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 26
%global with_tests 0%{!?_without_tests:1}
%endif
%global ns_vendor Alcaeus
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.11
+Version: 1.1.0
Release: 1%{?dist}
Summary: Mongo PHP Adapter
@@ -30,11 +30,9 @@ License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{?gh_short}.tar.gz
-Patch0: 167.patch
-
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
%if %{with_tests}
BuildRequires: php-hash
BuildRequires: php-composer(mongodb/mongodb) >= 1.0.1
@@ -43,17 +41,24 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, require-dev": {
-# "phpunit/phpunit": "^4.8 || ^5.0"
-BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: mongodb-server >= 3.2
+# "phpunit/phpunit": "^5.7 || ^6.0"
+BuildRequires: mongodb-server >= 3.4
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
%endif
# From composer.json, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "ext-hash": "*",
+# "ext-mongodb": "^1.2.0",
# "mongodb/mongodb": "^1.0.1"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
Requires: php-hash
+Requires: php-pecl(mongodb) >= 1.2.0
Requires: php-composer(mongodb/mongodb) >= 1.0.1
# From phpcompatinfo report for 1.0.3
Requires: php-date
@@ -81,7 +86,6 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/MongoDbAdapter/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv lib/Mongo lib/%{ns_vendor}/Mongo
@@ -129,9 +133,10 @@ fi
: Run the test suite
ret=0
-for cmd in php php56 php70 php71; do
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit6" "php72 %{_bindir}/phpunit"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --bootstrap bs.php || ret=1
+ set $cmd
+ $1 $2 --bootstrap bs.php || ret=1
fi
done
@@ -153,6 +158,12 @@ exit $ret
%changelog
+* Sun May 14 2017 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- Update to 1.1.0
+- raise dependency on PHP >= 5.6
+- add dependency on pecl/mongodb >= 1.2.0
+- only run test with MongoDB 3.4
+
* Thu Apr 27 2017 Remi Collet <remi@remirepo.net> - 1.0.11-1
- Update to 1.0.11