summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-08 10:18:47 +0200
committerRemi Collet <remi@remirepo.net>2019-04-08 10:18:47 +0200
commit29b6273e295c053473e8b3be9712d80ad374c3d5 (patch)
tree2aed72faf583971e00beff79c12c30239c01e0d5
parent69d2e578bdae64a93ad5ea733908955bf7af50d0 (diff)
-rw-r--r--composer.json1
-rw-r--r--php-alcaeus-mongo-php-adapter.spec16
2 files changed, 14 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index 3b71238..85c0c05 100644
--- a/composer.json
+++ b/composer.json
@@ -10,6 +10,7 @@
],
"require": {
"php": "^5.6 || ^7.0",
+ "ext-ctype": "*",
"ext-hash": "*",
"ext-mongodb": "^1.2.0",
"mongodb/mongodb": "^1.0.1"
diff --git a/php-alcaeus-mongo-php-adapter.spec b/php-alcaeus-mongo-php-adapter.spec
index 738ca75..77db508 100644
--- a/php-alcaeus-mongo-php-adapter.spec
+++ b/php-alcaeus-mongo-php-adapter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6111fb94e2e67b24b19681715f9caee4309e1eb5
+%global gh_commit b4c2f0d30dbddd624d3bc2a27175e6eb602241d4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alcaeus
%global gh_project mongo-php-adapter
@@ -16,7 +16,7 @@
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.1.6
+Version: 1.1.7
Release: 1%{?dist}
Summary: Mongo PHP Adapter
@@ -28,9 +28,12 @@ BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php(language) >= 5.6
%if %{with_tests}
+BuildRequires: php-ctype
BuildRequires: php-hash
BuildRequires: php-composer(mongodb/mongodb) >= 1.0.1
+BuildRequires: php-reflection
BuildRequires: php-date
+BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -43,15 +46,19 @@ BuildRequires: phpunit7
# From composer.json, "require": {
# "php": "^5.6 || ^7.0",
+# "ext-ctype": "*",
# "ext-hash": "*",
# "ext-mongodb": "^1.2.0",
# "mongodb/mongodb": "^1.0.1"
Requires: php(language) >= 5.6
+Requires: php-ctype
Requires: php-hash
Requires: php-pecl(mongodb) >= 1.2.0
Requires: php-composer(mongodb/mongodb) >= 1.0.1
-# From phpcompatinfo report for 1.0.3
+# From phpcompatinfo report for 1.1.7
+Requires: php-reflection
Requires: php-date
+Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
@@ -143,6 +150,9 @@ exit $ret
%changelog
+* Mon Apr 8 2019 Remi Collet <remi@remirepo.net> - 1.1.7-1
+- update to 1.1.7
+
* Fri Feb 8 2019 Remi Collet <remi@remirepo.net> - 1.1.6-1
- update to 1.1.6
- drop patch merged upstream