summaryrefslogtreecommitdiffstats
path: root/php-phar-io-manifest2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phar-io-manifest2.spec')
-rw-r--r--php-phar-io-manifest2.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/php-phar-io-manifest2.spec b/php-phar-io-manifest2.spec
index 1e59eb5..37074b2 100644
--- a/php-phar-io-manifest2.spec
+++ b/php-phar-io-manifest2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 549a9ec52cf97f20d375fca417a9eefd25f05fd5
+%global gh_commit 85265efd3af7ba3ca4b2a2c34dbfc5788dd29133
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phar-io
%global gh_project manifest
@@ -18,19 +18,20 @@
%global major 2
%global php_home %{_datadir}/php
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Component for reading phar.io manifest information
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -49,12 +50,12 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-xmlwriter
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
-%if %{with_tests}
+%if %{with tests}
BuildRequires: phpunit8
%endif
# from composer.json
-# "php": "^7.2",
+# "php": "^7.2 || ^8.0",
# "ext-dom": "*",
# "ext-phar": "*",
# "ext-xmlwriter": "*",
@@ -109,7 +110,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
touch vendor/autoload.php
@@ -135,6 +136,10 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1 (no change)
+- sources from git snapshot
+
* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- rename to php-phar-io-manifest2