summaryrefslogtreecommitdiffstats
path: root/phinx.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phinx.spec')
-rw-r--r--phinx.spec63
1 files changed, 40 insertions, 23 deletions
diff --git a/phinx.spec b/phinx.spec
index 5f6982e..500a168 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 1960e93169707096fdfde04904a204970077f4be
+%global gh_commit a6cced878695d26396b26dfd62ce300aea07de05
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.10.8
+Version: 0.11.1
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -34,20 +34,24 @@ Patch0: %{name}-version.patch
BuildArch: noarch
%if %{with_tests}
-# Because we use PHPUnit 6
-BuildRequires: php(language) >= 7.0
+# Because we use PHPUnit 7
+BuildRequires: php(language) >= 7.1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
+BuildRequires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
BuildRequires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
-BuildRequires: (php-composer(symfony/console) >= 2.8 with php-composer(symfony/console) < 5)
-BuildRequires: (php-composer(symfony/config) >= 2.8 with php-composer(symfony/config) < 5)
-BuildRequires: (php-composer(symfony/yaml) >= 2.8 with php-composer(symfony/yaml) < 5)
+BuildRequires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
+BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
+BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 5)
+BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 5)
%else
BuildRequires: php-cakephp-collection >= 3.6
+BuildRequires: php-cakephp-core >= 3.6
BuildRequires: php-cakephp-database >= 3.6
-BuildRequires: php-symfony3-console
-BuildRequires: php-symfony3-config
-BuildRequires: php-symfony3-yaml
+BuildRequires: php-cakephp-datasource >= 3.6
+BuildRequires: php-symfony3-console >= 3.4
+BuildRequires: php-symfony3-config >= 3.4
+BuildRequires: php-symfony3-yaml >= 3.4
%endif
BuildRequires: php-pdo
BuildRequires: php-date
@@ -55,10 +59,10 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": ">=5.7,<7.0",
+# "phpunit/phpunit": ">=5.7,<8.0",
# "sebastian/comparator": ">=1.2.3",
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -66,23 +70,29 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=5.6",
# "cakephp/collection": "^3.6",
+# "cakephp/core": "^3.6",
# "cakephp/database": "^3.6",
-# "symfony/console": "~2.8|~3.0|^4.0",
-# "symfony/config": "~2.8|~3.0|^4.0",
-# "symfony/yaml": "~2.8|~3.0|^4.0"
+# "cakephp/datasource": "^3.6",
+# "symfony/console": "^3.4|^4.0",
+# "symfony/config": "^3.4|^4.0",
+# "symfony/yaml": "^3.4|^4.0"
Requires: php(language) >= 5.6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
+Requires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
Requires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
-Requires: (php-composer(symfony/console) >= 2.8 with php-composer(symfony/console) < 5)
-Requires: (php-composer(symfony/config) >= 2.8 with php-composer(symfony/config) < 5)
-Requires: (php-composer(symfony/yaml) >= 2.8 with php-composer(symfony/yaml) < 5)
+Requires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
+Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
+Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 5)
+Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 5)
%else
Requires: php-cakephp-collection >= 3.6
+Requires: php-cakephp-core >= 3.6
Requires: php-cakephp-database >= 3.6
-Requires: php-symfony3-console
-Requires: php-symfony3-config
-Requires: php-symfony3-yaml
+Requires: php-cakephp-datasource >= 3.6
+Requires: php-symfony3-console >= 3.4
+Requires: php-symfony3-config >= 3.4
+Requires: php-symfony3-yaml >= 3.4
%endif
# From phpcompatinfo report for 0.6.4
Requires: php-pdo
@@ -164,7 +174,9 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php71 php72 php73 php74; do
+
+#TODO: 7.4 Trying to access array offset on value of type bool
+for cmd in "php %{phpunit}" php71 php72 php73; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \
@@ -191,6 +203,11 @@ exit $ret
%changelog
+* Wed Aug 28 2019 Remi Collet <remi@remirepo.net> - 0.11.1-1
+- update to 0.11.1
+- raise dependency on symfony 3.4
+- use phpunit 7
+
* Tue Jul 9 2019 Remi Collet <remi@remirepo.net> - 0.10.8-1
- update to 0.10.8