summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--1603.patch24
-rw-r--r--phinx.spec12
2 files changed, 31 insertions, 5 deletions
diff --git a/1603.patch b/1603.patch
new file mode 100644
index 0000000..edc0221
--- /dev/null
+++ b/1603.patch
@@ -0,0 +1,24 @@
+From 5843afa20a3e9d39580d710dd927736c747ad47b Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 29 Aug 2019 13:39:59 +0200
+Subject: [PATCH] Fix: Trying to access array offset on value of type bool
+
+---
+ src/Phinx/Migration/Manager.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Phinx/Migration/Manager.php b/src/Phinx/Migration/Manager.php
+index 8b7040a05..9cea06674 100644
+--- a/src/Phinx/Migration/Manager.php
++++ b/src/Phinx/Migration/Manager.php
+@@ -206,8 +206,8 @@ public function printStatus($environment, $format = null)
+ '%s %14.0f %19s %19s <comment>%s</comment>',
+ $status,
+ $migration->getVersion(),
+- $version['start_time'],
+- $version['end_time'],
++ ($version ? $version['start_time'] : ''),
++ ($version ? $version['end_time'] : ''),
+ $migration->getName()
+ ));
+
diff --git a/phinx.spec b/phinx.spec
index 500a168..1dbfbf4 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -20,7 +20,7 @@
Name: %{gh_project}
Version: 0.11.1
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
License: MIT
@@ -31,6 +31,7 @@ Source2: makesrc.sh
# hardcode version instead of read it from composer.json
Patch0: %{name}-version.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/cakephp/phinx/pull/1603.patch
BuildArch: noarch
%if %{with_tests}
@@ -123,6 +124,7 @@ Documentation: http://docs.phinx.org
%patch0 -p0
sed -e 's/@VERSION@/%{version}/' \
-i src/Phinx/Console/PhinxApplication.php
+%patch1 -p1
cp %{SOURCE1} src/%{psr0}/autoload.php
@@ -175,14 +177,10 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-#TODO: 7.4 Trying to access array offset on value of type bool
for cmd in "php %{phpunit}" php71 php72 php73; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
- --filter '^((?!(testChangeColumnWithCommasInCommentsOrDefaultValue)).)*$' \
-%endif
--no-coverage || ret=1
fi
done
@@ -203,6 +201,10 @@ exit $ret
%changelog
+* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 0.11.1-2
+- add patch for PHP 7.4 from
+ https://github.com/cakephp/phinx/pull/1603
+
* Wed Aug 28 2019 Remi Collet <remi@remirepo.net> - 0.11.1-1
- update to 0.11.1
- raise dependency on symfony 3.4