summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--phinx.spec14
2 files changed, 10 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index b480052..e1021ff 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"keywords": ["phinx", "migrations", "database", "db", "database migrations"],
"homepage": "https://phinx.org",
"license": "MIT",
- "version": "0.10.6",
+ "version": "0.10.7",
"authors": [{
"name": "Rob Morgan",
"email": "robbym@gmail.com",
@@ -33,7 +33,7 @@
"symfony/yaml": "^2.8|^3.0|^4.0"
},
"require-dev": {
- "phpunit/phpunit": ">=5.7",
+ "phpunit/phpunit": ">=5.7,<7.0",
"sebastian/comparator": ">=1.2.3",
"cakephp/cakephp-codesniffer": "^3.0"
},
diff --git a/phinx.spec b/phinx.spec
index 86723ad..4704bf4 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phinx
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit f28a1c6ab1fa1f0295cddade9aea05eeb303bd2b
+%global gh_commit ba2dae98bb69d39531311e8fd72dd51e8e06ff32
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,11 +19,10 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.10.6
-Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 0.10.7
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
-Group: Development/Libraries
License: MIT
URL: https://phinx.org
Source0: %{name}-%{version}-%{?gh_short}.tgz
@@ -55,7 +54,7 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": ">=5.7",
+# "phpunit/phpunit": ">=5.7,<7.0",
# "sebastian/comparator": ">=1.2.3",
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
@@ -196,6 +195,9 @@ exit $ret
%changelog
+* Thu Apr 25 2019 Remi Collet <remi@remirepo.net> - 0.10.7-1
+- update to 0.10.7
+
* Thu Dec 13 2018 Remi Collet <remi@remirepo.net> - 0.10.6-2
- cleanup for EL-8