summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phinx.spec19
2 files changed, 10 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index e1021ff..8fedd79 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"keywords": ["phinx", "migrations", "database", "db", "database migrations"],
"homepage": "https://phinx.org",
"license": "MIT",
- "version": "0.10.7",
+ "version": "0.10.8",
"authors": [{
"name": "Rob Morgan",
"email": "robbym@gmail.com",
diff --git a/phinx.spec b/phinx.spec
index 4704bf4..5f6982e 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ba2dae98bb69d39531311e8fd72dd51e8e06ff32
+%global gh_commit 1960e93169707096fdfde04904a204970077f4be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.10.7
+Version: 0.10.8
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -34,7 +34,8 @@ Patch0: %{name}-version.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+# Because we use PHPUnit 6
+BuildRequires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
BuildRequires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
@@ -56,13 +57,8 @@ BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
# "phpunit/phpunit": ">=5.7,<7.0",
# "sebastian/comparator": ">=1.2.3",
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 5.7
-%endif
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -157,7 +153,7 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Test\\Phinx\\', dirname(__DIR__).'/tests/Phinx');
EOF
-%if 0%{?rhel} == 6
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
: SQLite is too old
sed -e '/_ENABLED/s/true/false/' \
phpunit.xml.dist >phpunit.xml
@@ -168,7 +164,7 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php71 php72 php73; do
+for cmd in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \
@@ -195,6 +191,9 @@ exit $ret
%changelog
+* Tue Jul 9 2019 Remi Collet <remi@remirepo.net> - 0.10.8-1
+- update to 0.10.8
+
* Thu Apr 25 2019 Remi Collet <remi@remirepo.net> - 0.10.7-1
- update to 0.10.7