summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--composer.json74
-rw-r--r--phinx.spec88
3 files changed, 114 insertions, 50 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 8923623..18b07b3 100644
--- a/composer.json
+++ b/composer.json
@@ -2,41 +2,52 @@
"name": "robmorgan/phinx",
"type": "library",
"description": "Phinx makes it ridiculously easy to manage the database migrations for your PHP app.",
- "keywords": ["phinx", "migrations", "database", "db", "database migrations"],
+ "keywords": [
+ "phinx",
+ "migrations",
+ "database",
+ "db",
+ "database migrations"
+ ],
"homepage": "https://phinx.org",
"license": "MIT",
- "authors": [{
- "name": "Rob Morgan",
- "email": "robbym@gmail.com",
- "homepage": "https://robmorgan.id.au",
- "role": "Lead Developer"
- }, {
- "name": "Woody Gilk",
- "email": "woody.gilk@gmail.com",
- "homepage": "https://shadowhand.me",
- "role": "Developer"
- }, {
- "name": "Richard Quadling",
- "email": "rquadling@gmail.com",
- "role": "Developer"
- }, {
- "name": "CakePHP Community",
- "role": "Developer",
- "homepage": "https://github.com/cakephp/phinx/graphs/contributors"
- }],
+ "authors": [
+ {
+ "name": "Rob Morgan",
+ "email": "robbym@gmail.com",
+ "homepage": "https://robmorgan.id.au",
+ "role": "Lead Developer"
+ },
+ {
+ "name": "Woody Gilk",
+ "email": "woody.gilk@gmail.com",
+ "homepage": "https://shadowhand.me",
+ "role": "Developer"
+ },
+ {
+ "name": "Richard Quadling",
+ "email": "rquadling@gmail.com",
+ "role": "Developer"
+ },
+ {
+ "name": "CakePHP Community",
+ "role": "Developer",
+ "homepage": "https://github.com/cakephp/phinx/graphs/contributors"
+ }
+ ],
"require": {
"php": ">=7.2",
"cakephp/database": "^4.0",
- "psr/container": "^1.0",
- "symfony/console": "^3.4|^4.0|^5.0",
- "symfony/config": "^3.4|^4.0|^5.0"
+ "psr/container": "^1.0 || ^2.0",
+ "symfony/console": "^3.4|^4.0|^5.0|^6.0",
+ "symfony/config": "^3.4|^4.0|^5.0|^6.0"
},
"require-dev": {
"ext-json": "*",
"ext-pdo": "*",
- "phpunit/phpunit": "^8.5",
+ "phpunit/phpunit": "^8.5|^9.3",
"sebastian/comparator": ">=1.2.3",
- "cakephp/cakephp-codesniffer": "^3.0",
+ "cakephp/cakephp-codesniffer": "^4.0",
"symfony/yaml": "^3.4|^4.0|^5.0"
},
"autoload": {
@@ -61,9 +72,16 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
- "stan": "phpstan analyse src/",
- "stan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:^0.12 && mv composer.backup composer.json",
+ "stan": "phpstan analyse",
+ "stan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:~1.9.0 && mv composer.backup composer.json",
"test": "phpunit --colors=always"
},
- "bin": ["bin/phinx"]
+ "bin": [
+ "bin/phinx"
+ ],
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
+ }
}
diff --git a/phinx.spec b/phinx.spec
index b35382c..1254f1b 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phinx
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 05902f4a90790ce9db195954e608d5a43d4d6a7d
+%global gh_commit 18e06e4a2b18947663438afd2f467e17c62e867d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%bcond_without tests
Name: %{gh_project}
-Version: 0.12.4
+Version: 0.13.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -44,9 +44,9 @@ BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symf
%else
BuildRequires: php-cakephp4-database
BuildRequires: php-psr-container
-BuildRequires: php-symfony3-console >= 3.4
-BuildRequires: php-symfony3-config >= 3.4
-BuildRequires: php-symfony3-yaml >= 3.4
+BuildRequires: php-symfony4-console
+BuildRequires: php-symfony4-config
+BuildRequires: php-symfony4-yaml
%endif
BuildRequires: php-pdo
BuildRequires: php-date
@@ -56,22 +56,27 @@ BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
# "ext-json": "*",
# "ext-pdo": "*",
-# "phpunit/phpunit": ^8.5",
+# "phpunit/phpunit": ^8.5|^9.3",
# "sebastian/comparator": ">=1.2.3",
-# "cakephp/cakephp-codesniffer": "^3.0",
+# "cakephp/cakephp-codesniffer": "^4.0",
# "symfony/yaml": "^3.4|^4.0|^5.0"
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+%else
%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit8
%endif
+%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=7.2",
# "cakephp/database": "^4.0",
-# "psr/container": "^1.0",
-# "symfony/console": "^3.4|^4.0|^5.0",
-# "symfony/config": "^3.4|^4.0|^5.0"
+# "psr/container": "^1.0 || ^2.0",
+# "symfony/console": "^3.4|^4.0|^5.0|^6.0",
+# "symfony/config": "^3.4|^4.0|^5.0|^6.0"
# From composer.json, "suggest": {
# "ext-json": "Install if using JSON configuration format",
# "ext-pdo": "PDO extension is needed",
@@ -86,9 +91,9 @@ Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symf
%else
Requires: php-cakephp4-database
Requires: php-psr-container
-Requires: php-symfony3-console >= 3.4
-Requires: php-symfony3-config >= 3.4
-Requires: php-symfony3-yaml >= 3.4
+Requires: php-symfony4-console
+Requires: php-symfony4-config
+Requires: php-symfony4-yaml
%endif
# From phpcompatinfo report for 0.6.4
Requires: php-pdo
@@ -159,22 +164,18 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Test\\Phinx\\', dirname(__DIR__).'/tests/Phinx');
EOF
-%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+%if 0%{?rhel} == 7
: SQLite is too old
-sed -e '/_ENABLED/s/true/false/' \
- phpunit.xml.dist >phpunit.xml
-%else
-sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
- phpunit.xml.dist >phpunit.xml
+rm tests/Phinx/Db/Adapter/SQLiteAdapterTest.php
%endif
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74; do
+for cmd in "php %{phpunit}" php80 php81 php82; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit8} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--no-coverage || ret=1
fi
done
@@ -195,6 +196,49 @@ exit $ret
%changelog
+* Mon Jan 9 2023 Remi Collet <remi@remirepo.net> - 0.13.4-1
+- update to 0.13.4
+
+* Fri Dec 9 2022 Remi Collet <remi@remirepo.net> - 0.13.3-1
+- update to 0.13.3
+
+* Mon Dec 5 2022 Remi Collet <remi@remirepo.net> - 0.13.2-1
+- update to 0.13.2
+
+* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 0.13.1-1
+- update to 0.13.1
+
+* Fri Oct 7 2022 Remi Collet <remi@remirepo.net> - 0.13.0-1
+- update to 0.13.0
+
+* Mon Oct 3 2022 Remi Collet <remi@remirepo.net> - 0.12.13-1
+- update to 0.12.13
+
+* Mon Jul 18 2022 Remi Collet <remi@remirepo.net> - 0.12.12-1
+- update to 0.12.12
+
+* Mon Jul 4 2022 Remi Collet <remi@remirepo.net> - 0.12.11-1
+- update to 0.12.11
+
+* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 0.12.10-1
+- update to 0.12.10
+
+* Tue Oct 12 2021 Remi Collet <remi@remirepo.net> - 0.12.9-1
+- update to 0.12.9
+
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 0.12.8-1
+- update to 0.12.8
+
+* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 0.12.7-1
+- update to 0.12.7
+
+* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 0.12.6-1
+- update to 0.12.6
+
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 0.12.5-1
+- update to 0.12.5
+- switch to phpunit9
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 0.12.4-1
- update to 0.12.4
- drop dependency on cakephp/collection