summaryrefslogtreecommitdiffstats
path: root/phan.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phan.spec')
-rw-r--r--phan.spec56
1 files changed, 31 insertions, 25 deletions
diff --git a/phan.spec b/phan.spec
index f5979a2..67dea5c 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5f12a3cfbae585618f5b02992c8810c7679457d0
+%global gh_commit 9dbe813f09122c7799e1c197c5a70d3c279867a2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner etsy
#global gh_date 20150820
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.8.3
+Version: 0.8.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -32,33 +32,43 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 7.0
BuildRequires: php-ast
+BuildRequires: php-composer(symfony/console) < 4
BuildRequires: php-composer(symfony/console) >= 2.8
BuildRequires: php-reflection
+BuildRequires: php-dom
+BuildRequires: php-filter
+BuildRequires: php-json
BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
+# for some tests
+BuildRequires: php-date
+BuildRequires: php-intl
+BuildRequires: php-soap
# For tests, from composer.json "require-dev": {
-# "phpdocumentor/phpdocumentor": "^2.9.0",
-# "phpunit/phpunit": "^5.7.2",
-# "squizlabs/php_codesniffer": "^2.7.1"
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7.2
+# "phpunit/phpunit": "^6.2.1",
+BuildRequires: phpunit6 >= 6.2.1
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "~7.0.0",
-# "ext-ast": "*",
+# "php": "~7.0.0 || ~7.1.0",
+# "ext-ast": "^0.1.4",
# "symfony/console": "~2.3|~3.0"
Requires: php(language) >= 7.0
Requires: php-ast
+Requires: php-composer(symfony/console) < 4
Requires: php-composer(symfony/console) >= 2.3
-# From phpcompatinfo report for 0.8.0
+# From phpcompatinfo report for 0.8.4
Requires: php-cli
Requires: php-reflection
+Requires: php-dom
+Requires: php-filter
+Requires: php-json
Requires: php-pcntl
Requires: php-pcre
Requires: php-posix
@@ -83,9 +93,11 @@ and narrow types based on conditionals.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
+%patch0 -p1 -b .rpm
cp %{SOURCE1} src/%{psr0}/autoload.php
+find . -name \*.rpm -delete
+
%build
: Nothing to build
@@ -115,16 +127,8 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/Bootstrap.php';
\Fedora\Autoloader\Autoload::addPsr4('Phan\\Tests\\', __DIR__ . '/Phan');
EOF
-# remirepo:6
-run=0
-ret=0
-if which php71; then
- php71 %{_bindir}/phpunit -d memory_limit=1G --bootstrap tests/autoload.php
- run=1
-fi
-%{_bindir}/phpunit -d memory_limit=1G --bootstrap tests/autoload.php --verbose
-# remirepo:1
-exit $ret
+# Notice request and grpc must be disabled
+%{_bindir}/phpunit6 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
%else
@@ -132,12 +136,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -147,6 +146,13 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 14 2017 Remi Collet <remi@remirepo.net> - 0.8.4-1
+- Update to 0.8.4
+- allow Symfony 3
+- open https://github.com/etsy/phan/issues/888 issue with request ext.
+- open https://github.com/etsy/phan/issues/889 issue with grpc ext.
+- open https://github.com/nikic/php-ast/issues/59 segfault with mysql_xdevapi
+
* Fri Jan 27 2017 Remi Collet <remi@remirepo.net> - 0.8.3-1
- update to 0.8.3