summaryrefslogtreecommitdiffstats
path: root/phan.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phan.spec')
-rw-r--r--phan.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/phan.spec b/phan.spec
index abdbac3..bb59372 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit af93901dba4cb00f7d6a2cd4c2a862d774a8b3b4
+%global gh_commit 2520ce1292974b274017570cffaa8454018baee7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.8.9
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 0.8.10
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}.7.0
Summary: A static analyzer for PHP
Group: Development/Libraries
@@ -29,8 +29,9 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
+BuildRequires: php(language) < 7.1
BuildRequires: php(language) >= 7.0
-BuildRequires: php-ast
+BuildRequires: php-ast >= 0.1.5
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 3
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
BuildRequires: php-composer(nikic/php-parser) < 4
@@ -62,13 +63,13 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "~7.0.0 || ~7.1.0 || ~7.2.0",
-# "ext-ast": "^0.1.4",
+# "ext-ast": "^0.1.5",
# "felixfbecker/advanced-json-rpc": "^2.0",
# "nikic/PHP-Parser": "~3.1.1",
# "sabre/event": "^5.0",
# "symfony/console": "~2.3|~3.0"
Requires: php(language) >= 7.0
-Requires: php-ast
+Requires: php-ast >= 0.1.5
Requires: php-composer(felixfbecker/advanced-json-rpc) < 3
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
Requires: php-composer(nikic/php-parser) < 4
@@ -173,6 +174,9 @@ EOF
%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 0.8.10-1
+- Update to 0.8.10
+
* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 0.8.9-1
- Update to 0.8.9
- add dependency on felixfbecker/advanced-json-rpc 2.0