summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phan-autoload.patch30
-rw-r--r--phan.spec7
2 files changed, 20 insertions, 17 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index eed0e93..b07aee3 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,17 +1,17 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2018-10-23 10:37:31.657768196 +0200
-+++ ./src/codebase.php 2018-10-23 10:38:09.371967988 +0200
+--- ./src/codebase.php.rpm 2018-11-28 08:26:01.448459434 +0100
++++ ./src/codebase.php 2018-11-28 08:26:30.948615865 +0100
@@ -6,15 +6,8 @@ $internal_interface_name_list = get_decl
$internal_trait_name_list = get_declared_traits();
$internal_function_name_list = get_defined_functions()['internal'];
+-
+-// @phan-file-suppress PhanMissingRequireFile one of these will be missing
-if (file_exists(__DIR__ . '/../vendor/autoload.php')) {
- // This is the path to autoload.php when Phan is installed globally.
-- // @phan-suppress-next-line PhanMissingRequireFile
- require_once __DIR__ . '/../vendor/autoload.php';
-} else {
- // This is the normal path when Phan is installed only in the scope of a project.
-- // @phan-suppress-next-line PhanMissingRequireFile
- require_once __DIR__ . '/../../../autoload.php';
-}
+// Use the fedora autoloader
@@ -20,8 +20,8 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Composer\XdebugHandler\XdebugHandler;
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2018-10-23 10:27:56.000000000 +0200
-+++ ./src/Phan/Bootstrap.php 2018-10-23 10:37:31.657768196 +0200
+--- ./src/Phan/Bootstrap.php.rpm 2018-11-28 08:22:11.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2018-11-28 08:22:18.140291232 +0100
@@ -13,16 +13,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
@@ -42,17 +42,17 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2018-10-23 10:27:56.000000000 +0200
-+++ ./src/phan.php 2018-10-23 10:37:31.657768196 +0200
+--- ./src/phan.php.rpm 2018-11-28 08:22:11.000000000 +0100
++++ ./src/phan.php 2018-11-28 08:22:18.140291232 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2018-10-23 10:27:56.000000000 +0200
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2018-10-23 10:37:31.657768196 +0200
-@@ -702,7 +702,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2018-11-28 08:22:11.000000000 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2018-11-28 08:22:18.141291237 +0100
+@@ -724,7 +724,7 @@ final class ConfigPluginSet extends Plug
// E.g. 'AlwaysReturnPlugin' becomes /path/to/phan/.phan/plugins/AlwaysReturnPlugin.php
// (Useful when using phan.phar, etc.)
if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
@@ -62,16 +62,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
try {
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2018-10-23 10:27:56.000000000 +0200
-+++ ./src/prep.php 2018-10-23 10:37:31.657768196 +0200
+--- ./src/prep.php.rpm 2018-11-28 08:22:11.000000000 +0100
++++ ./src/prep.php 2018-11-28 08:22:18.141291237 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2018-10-23 10:37:31.657768196 +0200
-+++ ./src/requirements.php 2018-10-23 10:38:38.126120310 +0200
+--- ./src/requirements.php.rpm 2018-11-28 08:22:11.000000000 +0100
++++ ./src/requirements.php 2018-11-28 08:22:18.141291237 +0100
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index 7f3b43a..70f752a 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4bb4743d39c36f15f71cdfe2eb206502b46d3900
+%global gh_commit d57698bb8a944e9576711215ee90cd87528c5b7c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.1.3
+Version: 1.1.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -221,6 +221,9 @@ EOF
%changelog
+* Wed Nov 28 2018 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- update to 1.1.4
+
* Wed Nov 21 2018 Remi Collet <remi@remirepo.net> - 1.1.3-1
- update to 1.1.3