summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phan-autoload.patch26
-rw-r--r--phan.spec7
2 files changed, 18 insertions, 15 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 4ea6d9e..3389f80 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,6 +1,6 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2019-02-19 07:22:34.639868164 +0100
-+++ ./src/Phan/Bootstrap.php 2019-02-19 07:25:01.412126803 +0100
+--- ./src/Phan/Bootstrap.php.rpm 2019-03-10 08:36:46.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2019-03-10 08:37:07.174854315 +0100
@@ -14,21 +14,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
@@ -26,36 +26,36 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2019-02-19 07:20:58.000000000 +0100
-+++ ./src/phan.php 2019-02-19 07:22:34.639868164 +0100
+--- ./src/phan.php.rpm 2019-03-10 08:36:46.000000000 +0100
++++ ./src/phan.php 2019-03-10 08:37:07.174854315 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-02-19 07:20:58.000000000 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-02-19 07:22:34.640868166 +0100
-@@ -739,7 +739,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-03-10 08:37:07.174854315 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-03-10 08:37:59.464133748 +0100
+@@ -752,7 +752,7 @@ final class ConfigPluginSet extends Plug
public static function normalizePluginPath(string $plugin_file_name) : string
{
if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
-- return dirname(__DIR__, 3) . '/.phan/plugins/' . $plugin_file_name . '.php';
-+ return dirname(__DIR__, 2) . '/plugins/' . $plugin_file_name . '.php';
+- return \dirname(__DIR__, 3) . '/.phan/plugins/' . $plugin_file_name . '.php';
++ return \dirname(__DIR__, 2) . '/plugins/' . $plugin_file_name . '.php';
}
return $plugin_file_name;
}
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2019-02-19 07:20:58.000000000 +0100
-+++ ./src/prep.php 2019-02-19 07:22:34.640868166 +0100
+--- ./src/prep.php.rpm 2019-03-10 08:36:46.000000000 +0100
++++ ./src/prep.php 2019-03-10 08:37:07.175854321 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2019-02-19 07:20:58.000000000 +0100
-+++ ./src/requirements.php 2019-02-19 07:22:34.640868166 +0100
+--- ./src/requirements.php.rpm 2019-03-10 08:36:46.000000000 +0100
++++ ./src/requirements.php 2019-03-10 08:37:07.175854321 +0100
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index d5d8aa7..62d0f58 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c987c6621a8b7595320c851bd8553115e49436b1
+%global gh_commit 78b8f2bdab9dab2146872bf130a9265a3f1f9a27
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.2.5
+Version: 1.2.6
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -225,6 +225,9 @@ EOF
%changelog
+* Sun Mar 10 2019 Remi Collet <remi@remirepo.net> - 1.2.6-1
+- update to 1.2.6
+
* Wed Feb 27 2019 Remi Collet <remi@remirepo.net> - 1.2.5-1
- update to 1.2.5
- add dependecy on mbstring