summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rw-r--r--phan.spec96
2 files changed, 70 insertions, 38 deletions
diff --git a/composer.json b/composer.json
index eef7e68..a3fa781 100644
--- a/composer.json
+++ b/composer.json
@@ -29,19 +29,21 @@
"composer/semver": "^1.4|^2.0|^3.0",
"composer/xdebug-handler": "^1.3.2|^2.0.0",
"felixfbecker/advanced-json-rpc": "^3.0.4",
- "microsoft/tolerant-php-parser": "0.0.23",
- "netresearch/jsonmapper": "^1.6.0|^2.0|^3.0",
+ "microsoft/tolerant-php-parser": "^0.1.0",
+ "netresearch/jsonmapper": "^1.6.0|^2.0|^3.0|^4.0",
"sabre/event": "^5.0.3",
"symfony/console": "^3.2|^4.0|^5.0",
"symfony/polyfill-mbstring": "^1.11.0",
- "symfony/polyfill-php80": "^1.20.0"
+ "symfony/polyfill-php80": "^1.20.0",
+ "tysonandre/var_representation_polyfill": "^0.0.2|^0.1.0"
},
"suggest": {
- "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
+ "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.14+ is recommended.",
"ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
"ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
"ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
- "ext-tokenizer": "Needed for fallback/polyfill parser support and file/line-based suppressions."
+ "ext-tokenizer": "Needed for fallback/polyfill parser support and file/line-based suppressions.",
+ "ext-var_representation": "Suggested for converting values to strings in issue messages"
},
"require-dev": {
"phpunit/phpunit": "^8.5.0"
diff --git a/phan.spec b/phan.spec
index dca65be..b423fc1 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,15 +10,15 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4caaa97195dcea549021cb773a5dc30bb46d1fab
+%global gh_commit d724bbb8fc3ba89179868bb5220ecdf6a9c1636b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%bcond_without tests
-%global upstream_version 4.0.6
-#global upstream_prever RC2
+%global upstream_version 5.2.1
+#global upstream_prever a4
Name: %{gh_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -36,26 +36,27 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.2
-BuildRequires: php-ast >= 1.0.10
+BuildRequires: php-ast >= 1.0.14
+BuildRequires: php-var_representation
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
-BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0.0 with php-composer(composer/xdebug-handler) < 3)
-BuildRequires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4 with php-composer(felixfbecker/advanced-json-rpc) < 4)
-BuildRequires: (php-composer(microsoft/tolerant-php-parser) >= 0.0.23 with php-composer(microsoft/tolerant-php-parser) < 0.1)
-BuildRequires: (php-composer(netresearch/jsonmapper) >= 1.6 with php-composer(netresearch/jsonmapper) < 4)
-BuildRequires: (php-composer(sabre/event) >= 5.0.3 with php-composer(sabre/event) < 6)
-BuildRequires: (php-composer(symfony/console) >= 3.2 with php-composer(symfony/console) < 6)
-BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
+BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
+BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0.0 with php-composer(composer/xdebug-handler) < 3)
+BuildRequires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4 with php-composer(felixfbecker/advanced-json-rpc) < 4)
+BuildRequires: (php-composer(microsoft/tolerant-php-parser) >= 0.1 with php-composer(microsoft/tolerant-php-parser) < 0.2)
+BuildRequires: (php-composer(netresearch/jsonmapper) >= 1.6 with php-composer(netresearch/jsonmapper) < 5)
+BuildRequires: (php-composer(sabre/event) >= 5.0.3 with php-composer(sabre/event) < 6)
+BuildRequires: (php-composer(symfony/console) >= 3.2 with php-composer(symfony/console) < 6)
+BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
# remirepo:13
%else
BuildRequires: php-composer(composer/semver) < 4
BuildRequires: php-composer(composer/semver) >= 1.4
BuildRequires: php-composer-xdebug-handler2
-BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 4
+BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 5
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4
-BuildRequires: php-composer(microsoft/tolerant-php-parser) < 0.1
-BuildRequires: php-composer(microsoft/tolerant-php-parser) >= 0.0.23
+BuildRequires: php-composer(microsoft/tolerant-php-parser) < 0.2
+BuildRequires: php-composer(microsoft/tolerant-php-parser) >= 0.1
BuildRequires: php-netresearch-jsonmapper >= 1.6
BuildRequires: php-sabre-event5 >= 5.0.3
BuildRequires: php-symfony3-console >= 3.2
@@ -91,46 +92,50 @@ BuildRequires: php-composer(fedora/autoloader)
# "composer/semver": "^1.4|^2.0|^3.0",
# "composer/xdebug-handler": "^1.3.2|^2.0.0",
# "felixfbecker/advanced-json-rpc": "^3.0.4",
-# "microsoft/tolerant-php-parser": "0.0.23",
-# "netresearch/jsonmapper": "^1.6.0|^2.0|^3.0",
+# "microsoft/tolerant-php-parser": "^0.1",
+# "netresearch/jsonmapper": "^1.6.0|^2.0|^3.0|^4.0",
# "sabre/event": "^5.0.3",
# "symfony/console": "^3.2|^4.0|^5.",
# "symfony/polyfill-mbstring": "^1.11.0",
-# "symfony/polyfill-php80": "^1.20.0"
+# "symfony/polyfill-php80": "^1.20.0",
+# ignore and use the ext instead
+# "tysonandre/var_representation_polyfill": "^0.0.2|^0.1.0"
Requires: php(language) >= 7.2
Requires: php-filter
Requires: php-tokenizer
Requires: php-json
+Requires: php-var_representation
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer.json, "suggest": {
-# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
+# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.14+ is recommended.",
# "ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
# "ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
-Recommends: php-ast >= 1.0.10
+Recommends: php-ast >= 1.0.14
Suggests: php-igbinary
Suggests: php-iconv
-Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
-Requires: (php-composer(composer/xdebug-handler) >= 2.0.0 with php-composer(composer/xdebug-handler) < 3)
-Requires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4 with php-composer(felixfbecker/advanced-json-rpc) < 4)
-Requires: (php-composer(nikic/php-parser) >= 3.1.1 with php-composer(nikic/php-parser) < 4)
-Requires: (php-composer(microsoft/tolerant-php-parser) >= 0.0.23 with php-composer(microsoft/tolerant-php-parser) < 0.1)
-Requires: (php-composer(netresearch/jsonmapper) >= 1.6 with php-composer(netresearch/jsonmapper) < 4)
-Requires: (php-composer(sabre/event) >= 5.0.3 with php-composer(sabre/event) < 6)
-Requires: (php-composer(symfony/console) >= 3.2 with php-composer(symfony/console) < 6)
-Requires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
-# remirepo:14
+Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
+Requires: (php-composer(composer/xdebug-handler) >= 2.0.0 with php-composer(composer/xdebug-handler) < 3)
+Requires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4 with php-composer(felixfbecker/advanced-json-rpc) < 4)
+Requires: (php-composer(nikic/php-parser) >= 3.1.1 with php-composer(nikic/php-parser) < 4)
+Requires: (php-composer(microsoft/tolerant-php-parser) >= 0.1 with php-composer(microsoft/tolerant-php-parser) < 0.2)
+Requires: (php-composer(netresearch/jsonmapper) >= 1.6 with php-composer(netresearch/jsonmapper) < 5)
+Requires: (php-composer(sabre/event) >= 5.0.3 with php-composer(sabre/event) < 6)
+Requires: (php-composer(symfony/console) >= 3.2 with php-composer(symfony/console) < 6)
+Requires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
+# remirepo:15
%else
Requires: php-ast >= 1.0.10
+Requires: php-var_representation
Requires: php-composer(composer/semver) < 4
Requires: php-composer(composer/semver) >= 1.4
Requires: php-composer-xdebug-handler2
Requires: php-composer(felixfbecker/advanced-json-rpc) < 4
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 3.0.4
-Requires: php-composer(microsoft/tolerant-php-parser) < 0.1
-Requires: php-composer(microsoft/tolerant-php-parser) >= 0.0.23
+Requires: php-composer(microsoft/tolerant-php-parser) < 0.2
+Requires: php-composer(microsoft/tolerant-php-parser) >= 0.1
Requires: php-netresearch-jsonmapper >= 1.6
Requires: php-sabre-event5 >= 5.0.3
Requires: php-symfony3-console >= 3.2
@@ -153,7 +158,6 @@ Requires: php-sysvsem
Requires: php-composer(fedora/autoloader)
# Composer
-Provides: php-composer(etsy/%{gh_project}) = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
@@ -249,6 +253,32 @@ EOF
%changelog
+* Mon Sep 20 2021 Remi Collet <remi@remirepo.net> - 5.2.1-1
+- update to 5.2.1
+
+* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 5.2.0-1
+- update to 5.2.0
+
+* Mon Aug 9 2021 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+
+* Mon Aug 2 2021 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+
+* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a4-1
+- update to 5.0.0a4
+
+* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a3-1
+- update to 5.0.0a3
+
+* Mon Jun 28 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a2-1
+- update to 5.0.0a2
+- raise dependency on microsoft/tolerant-php-parser 0.1
+- add dependency on var_representation extension
+
+* Mon May 31 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a1-1
+- update to 5.0.0a1
+
* Thu May 20 2021 Remi Collet <remi@remirepo.net> - 4.0.6-1
- update to 4.0.6