summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phan-autoload.patch28
-rw-r--r--phan.spec9
3 files changed, 21 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 7f74d62..eef7e68 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"ext-json": "*",
"ext-tokenizer": "*",
"composer/semver": "^1.4|^2.0|^3.0",
- "composer/xdebug-handler": "^2.0.0",
+ "composer/xdebug-handler": "^1.3.2|^2.0.0",
"felixfbecker/advanced-json-rpc": "^3.0.4",
"microsoft/tolerant-php-parser": "0.0.23",
"netresearch/jsonmapper": "^1.6.0|^2.0|^3.0",
diff --git a/phan-autoload.patch b/phan-autoload.patch
index cf14683..2894344 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2021-01-05 09:16:26.831115023 +0100
-+++ ./src/Phan/Bootstrap.php 2021-01-05 09:17:54.795753041 +0100
-@@ -102,20 +102,6 @@ EOT
+--- ./src/Phan/Bootstrap.php.rpm 2021-05-20 08:05:36.000000000 +0200
++++ ./src/Phan/Bootstrap.php 2021-05-20 08:08:31.358343779 +0200
+@@ -104,20 +104,6 @@ EOT
fwrite(STDERR, "For more information, see https://github.com/phan/phan/wiki/Getting-Started#installing-dependencies" . PHP_EOL);
}
@@ -22,8 +22,8 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
if (extension_loaded('ast')) {
// Warn if the php-ast version is too low.
$ast_version = (string)phpversion('ast');
-@@ -162,11 +148,9 @@ if (extension_loaded('ast')) {
- unset($did_warn);
+@@ -169,11 +155,9 @@ if (extension_loaded('ast')) {
+ }
unset($ast_version);
}
-unset($file);
@@ -38,17 +38,17 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2021-01-05 09:15:30.000000000 +0100
-+++ ./src/phan.php 2021-01-05 09:16:26.832115019 +0100
+--- ./src/phan.php.rpm 2021-05-20 08:05:36.000000000 +0200
++++ ./src/phan.php 2021-05-20 08:06:58.598558870 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2021-01-05 09:15:30.000000000 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2021-01-05 09:16:26.832115019 +0100
-@@ -904,7 +904,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2021-05-20 08:05:36.000000000 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2021-05-20 08:06:58.598558870 +0200
+@@ -907,7 +907,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory(): string
{
@@ -58,16 +58,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2021-01-05 09:15:30.000000000 +0100
-+++ ./src/prep.php 2021-01-05 09:16:26.832115019 +0100
+--- ./src/prep.php.rpm 2021-05-20 08:05:36.000000000 +0200
++++ ./src/prep.php 2021-05-20 08:06:58.598558870 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2021-01-05 09:15:30.000000000 +0100
-+++ ./src/requirements.php 2021-01-05 09:16:26.832115019 +0100
+--- ./src/requirements.php.rpm 2021-05-20 08:05:36.000000000 +0200
++++ ./src/requirements.php 2021-05-20 08:06:58.598558870 +0200
@@ -2,11 +2,11 @@
declare(strict_types=1);
diff --git a/phan.spec b/phan.spec
index 87cdf45..dca65be 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e1800772a91d5791baf805a32227dfb5f720b0cd
+%global gh_commit 4caaa97195dcea549021cb773a5dc30bb46d1fab
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%bcond_without tests
-%global upstream_version 4.0.5
+%global upstream_version 4.0.6
#global upstream_prever RC2
Name: %{gh_project}
@@ -89,7 +89,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "ext-json": "*",
# "ext-tokenizer": "*",
# "composer/semver": "^1.4|^2.0|^3.0",
-# "composer/xdebug-handler": "^2.0.0",
+# "composer/xdebug-handler": "^1.3.2|^2.0.0",
# "felixfbecker/advanced-json-rpc": "^3.0.4",
# "microsoft/tolerant-php-parser": "0.0.23",
# "netresearch/jsonmapper": "^1.6.0|^2.0|^3.0",
@@ -249,6 +249,9 @@ EOF
%changelog
+* Thu May 20 2021 Remi Collet <remi@remirepo.net> - 4.0.6-1
+- update to 4.0.6
+
* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 4.0.5-1
- update to 4.0.5