summaryrefslogtreecommitdiffstats
path: root/phan.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-04 10:33:39 +0200
committerRemi Collet <remi@remirepo.net>2020-05-04 10:33:39 +0200
commitbca2e88e9e99a31d6a313e297be40f8939068249 (patch)
treec4bab77a3166db575e97325c7506c68461dbd973 /phan.spec
parentfce55e6bfad2f559c2106dfa2d80cbe1e2238288 (diff)
update to 3.0.0-RC2
raise dependency on PHP 7.2 switch to phpunit8
Diffstat (limited to 'phan.spec')
-rw-r--r--phan.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/phan.spec b/phan.spec
index 8504d00..5bab044 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,15 +10,15 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit df79f6def6cb7643955af14aa4b97acdd3495ad6
+%global gh_commit c0e12bb592fe16ff09acfcebca149cde578db248
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.7.2
-#global upstream_prever RC2
+%global upstream_version 3.0.0
+%global upstream_prever RC2
Name: %{gh_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -76,8 +76,8 @@ BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
# For tests, from composer.json "require-dev": {
# "brianium/paratest": "^4.0.0",
-# "phpunit/phpunit": "^7.5.0"
-BuildRequires: phpunit7 >= 7.5
+# "phpunit/phpunit": "^8.5.0"
+BuildRequires: phpunit8 >= 8.5
BuildRequires: php-date
BuildRequires: php-intl
BuildRequires: php-soap
@@ -86,7 +86,7 @@ BuildRequires: php-soap
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "^7.1.0",
+# "php": "^7.2.0",
# "ext-filter": "*",
# "ext-json": "*",
# "ext-tokenizer": "*",
@@ -97,8 +97,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "netresearch/jsonmapper": "^1.6.0|^2.0",
# "sabre/event": "^5.0",
# "symfony/console": "^2.3|^3.0|~4.0|^5.0",
-# "symfony/polyfill-mbstring": "^1.11.0",
-# "symfony/polyfill-php72": "^1.15"
+# "symfony/polyfill-mbstring": "^1.11.0"
Requires: php(language) >= 7.2
Requires: php-filter
Requires: php-tokenizer
@@ -228,7 +227,7 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/Phan/Bootstrap.php';
EOF
# NOTICE mosquitto, request and grpc must be disabled
-%{_bindir}/phpunit7 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
+%{_bindir}/phpunit8 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
%else
@@ -247,6 +246,11 @@ EOF
%changelog
+* Mon May 4 2020 Remi Collet <remi@remirepo.net> - 3.0.0~RC2-1
+- update to 3.0.0-RC2
+- raise dependency on PHP 7.2
+- switch to phpunit8
+
* Mon May 4 2020 Remi Collet <remi@remirepo.net> - 2.7.2-1
- update to 2.7.2
- allow composer/semver version 2