summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-29 09:38:45 +0200
committerRemi Collet <remi@remirepo.net>2019-04-29 09:38:45 +0200
commit20d778c597058afcc6dc681514a5610fa04b4909 (patch)
tree37098ffdefd7ec8a8b478e7c93c6a893ef589e6a
parenta1cad7aec369e37518f8206024b25ec4e64dfc89 (diff)
v1.3.2
-rw-r--r--phan-autoload.patch34
-rw-r--r--phan.spec7
2 files changed, 22 insertions, 19 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 3389f80..ca305ed 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,6 +1,6 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2019-03-10 08:36:46.000000000 +0100
-+++ ./src/Phan/Bootstrap.php 2019-03-10 08:37:07.174854315 +0100
+--- ./src/Phan/Bootstrap.php.rpm 2019-04-29 09:34:09.000000000 +0200
++++ ./src/Phan/Bootstrap.php 2019-04-29 09:34:21.823734920 +0200
@@ -14,21 +14,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
@@ -26,36 +26,36 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2019-03-10 08:36:46.000000000 +0100
-+++ ./src/phan.php 2019-03-10 08:37:07.174854315 +0100
+--- ./src/phan.php.rpm 2019-04-29 09:34:09.000000000 +0200
++++ ./src/phan.php 2019-04-29 09:34:21.824734926 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-03-10 08:37:07.174854315 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-03-10 08:37:59.464133748 +0100
-@@ -752,7 +752,7 @@ final class ConfigPluginSet extends Plug
- public static function normalizePluginPath(string $plugin_file_name) : string
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-04-29 09:34:21.824734926 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-04-29 09:35:40.107198375 +0200
+@@ -760,7 +760,7 @@ final class ConfigPluginSet extends Plug
+ */
+ public static function getBuiltinPluginDirectory() : string
{
- if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
-- return \dirname(__DIR__, 3) . '/.phan/plugins/' . $plugin_file_name . '.php';
-+ return \dirname(__DIR__, 2) . '/plugins/' . $plugin_file_name . '.php';
- }
- return $plugin_file_name;
+- return \dirname(__DIR__, 3) . '/.phan/plugins';
++ return \dirname(__DIR__, 2) . '/plugins/';
}
+
+ /**
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2019-03-10 08:36:46.000000000 +0100
-+++ ./src/prep.php 2019-03-10 08:37:07.175854321 +0100
+--- ./src/prep.php.rpm 2019-04-29 09:34:09.000000000 +0200
++++ ./src/prep.php 2019-04-29 09:34:21.824734926 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2019-03-10 08:36:46.000000000 +0100
-+++ ./src/requirements.php 2019-03-10 08:37:07.175854321 +0100
+--- ./src/requirements.php.rpm 2019-04-29 09:34:09.000000000 +0200
++++ ./src/requirements.php 2019-04-29 09:34:21.824734926 +0200
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index 74cdb71..d5fcb27 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit afbcf1ab162df39dbfd96672ba29a0208a49efff
+%global gh_commit ff4487fc62b2b3aa950460129799665ce904d780
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.3.1
+Version: 1.3.2
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -227,6 +227,9 @@ EOF
%changelog
+* Mon Apr 29 2019 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- update to 1.3.2
+
* Tue Apr 23 2019 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1