summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-02 11:16:25 +0100
committerRemi Collet <remi@remirepo.net>2020-01-02 11:16:25 +0100
commit0fc7ac37fe996328ac9d04102e904c92b73f99d4 (patch)
treebdd4572daf76f3a5773a512dc18241d02dd673d8
parentd09b2d932418105318d56e743df853133cf6dd3b (diff)
v2.4.6
-rw-r--r--phan-autoload.patch24
-rw-r--r--phan.spec7
2 files changed, 17 insertions, 14 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index dc5fc92..6c9be57 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2019-11-25 07:24:07.197111533 +0100
-+++ ./src/Phan/Bootstrap.php 2019-11-25 07:25:17.914851384 +0100
-@@ -109,21 +109,9 @@ if (extension_loaded('ast')) {
+--- ./src/Phan/Bootstrap.php.rpm 2020-01-02 11:12:56.778690430 +0100
++++ ./src/Phan/Bootstrap.php 2020-01-02 11:14:31.162289774 +0100
+@@ -118,22 +118,8 @@ if (extension_loaded('ast')) {
phan_output_ast_installation_instructions();
}
}
@@ -10,6 +10,7 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
-foreach ([
- dirname(__DIR__, 2) . '/vendor/autoload.php', // autoloader is in this project (we're in src/Phan and want vendor/autoload.php)
- dirname(__DIR__, 5) . '/vendor/autoload.php', // autoloader is in parent project (we're in vendor/phan/phan/src/Phan/Bootstrap.php and want autoload.php
+- dirname(__DIR__, 4) . '/autoload.php', // autoloader is in parent project (we're in non-standard-vendor/phan/phan/src/Phan/Bootstrap.php and want non-standard-vendor/autoload.php
- ] as $file) {
- if (file_exists($file)) {
- require_once($file);
@@ -20,23 +21,22 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
-if (!$found_autoloader) {
- fwrite(STDERR, "Could not locate the autoloader\n");
-}
-+
+// Use the fedora autoloader
+require_once __DIR__ . '/../autoload.php';
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2019-11-25 07:23:25.000000000 +0100
-+++ ./src/phan.php 2019-11-25 07:24:07.197111533 +0100
+--- ./src/phan.php.rpm 2020-01-02 11:12:48.000000000 +0100
++++ ./src/phan.php 2020-01-02 11:12:56.778690430 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-11-25 07:23:25.000000000 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-11-25 07:24:07.197111533 +0100
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-01-02 11:12:48.000000000 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-01-02 11:12:56.778690430 +0100
@@ -767,7 +767,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory() : string
@@ -47,16 +47,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist() : void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2019-11-25 07:23:25.000000000 +0100
-+++ ./src/prep.php 2019-11-25 07:24:07.197111533 +0100
+--- ./src/prep.php.rpm 2020-01-02 11:12:48.000000000 +0100
++++ ./src/prep.php 2020-01-02 11:12:56.778690430 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2019-11-25 07:23:25.000000000 +0100
-+++ ./src/requirements.php 2019-11-25 07:24:07.197111533 +0100
+--- ./src/requirements.php.rpm 2020-01-02 11:12:48.000000000 +0100
++++ ./src/requirements.php 2020-01-02 11:12:56.778690430 +0100
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index c20e25c..b3c0168 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 12f64e878084244ca92d1ac83e58a668640f6f1d
+%global gh_commit 85f142379813cf0a24a19237e9fbe6f77f0251db
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.4.5
+%global upstream_version 2.4.6
#global upstream_prever RC2
Name: %{gh_project}
@@ -243,6 +243,9 @@ EOF
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.4.6-1
+- update to 2.4.6
+
* Wed Dec 11 2019 Remi Collet <remi@remirepo.net> - 2.4.5-1
- update to 2.4.5
- allow Symfony 5