summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-23 08:28:54 +0100
committerRemi Collet <remi@remirepo.net>2020-01-23 08:28:54 +0100
commit02b1896069cf878d3e5278750820e94c4e05aee9 (patch)
tree4b8afdb36f61cc5121661c9725174a5d4cba3c3a
parent0fc7ac37fe996328ac9d04102e904c92b73f99d4 (diff)
v2.4.7
-rw-r--r--composer.json2
-rw-r--r--phan-autoload.patch38
-rw-r--r--phan.spec9
3 files changed, 26 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 4c2be2b..2863137 100644
--- a/composer.json
+++ b/composer.json
@@ -43,7 +43,7 @@
"ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
},
"require-dev": {
- "brianium/paratest": "^2.2.0",
+ "brianium/paratest": "^3.1.2",
"phpunit/phpunit": "^7.5.0"
},
"autoload": {
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 6c9be57..27c22e9 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2020-01-02 11:12:56.778690430 +0100
-+++ ./src/Phan/Bootstrap.php 2020-01-02 11:14:31.162289774 +0100
-@@ -118,22 +118,8 @@ if (extension_loaded('ast')) {
+--- ./src/Phan/Bootstrap.php.rpm 2020-01-23 08:24:27.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2020-01-23 08:24:56.789339699 +0100
+@@ -124,22 +124,8 @@ if (extension_loaded('ast')) {
phan_output_ast_installation_instructions();
}
}
@@ -27,37 +27,37 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2020-01-02 11:12:48.000000000 +0100
-+++ ./src/phan.php 2020-01-02 11:12:56.778690430 +0100
+--- ./src/phan.php.rpm 2020-01-23 08:24:56.790339693 +0100
++++ ./src/phan.php 2020-01-23 08:25:29.007139671 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
- <?php declare(strict_types=1);
+ <?php
- // Phan does a ton of GC and this offers a major speed
+ declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-01-02 11:12:48.000000000 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-01-02 11:12:56.778690430 +0100
-@@ -767,7 +767,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-01-23 08:24:56.790339693 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-01-23 08:26:02.086934309 +0100
+@@ -771,7 +771,7 @@ final class ConfigPluginSet extends Plug
*/
- public static function getBuiltinPluginDirectory() : string
+ public static function getBuiltinPluginDirectory(): string
{
- return \dirname(__DIR__, 3) . '/.phan/plugins';
+ return \dirname(__DIR__, 2) . '/plugins/';
}
- private function ensurePluginsExist() : void
+ private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2020-01-02 11:12:48.000000000 +0100
-+++ ./src/prep.php 2020-01-02 11:12:56.778690430 +0100
+--- ./src/prep.php.rpm 2020-01-23 08:24:56.790339693 +0100
++++ ./src/prep.php 2020-01-23 08:26:22.637806720 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
- <?php declare(strict_types=1);
+ <?php
- // Phan does a ton of GC and this offers a major speed
+ declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2020-01-02 11:12:48.000000000 +0100
-+++ ./src/requirements.php 2020-01-02 11:12:56.778690430 +0100
-@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
+--- ./src/requirements.php.rpm 2020-01-23 08:24:27.000000000 +0100
++++ ./src/requirements.php 2020-01-23 08:24:56.790339693 +0100
+@@ -10,10 +10,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index b3c0168..161f6b2 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 85f142379813cf0a24a19237e9fbe6f77f0251db
+%global gh_commit a300b0331269bbdc77ba03f36176740579dbb457
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.4.6
+%global upstream_version 2.4.7
#global upstream_prever RC2
Name: %{gh_project}
@@ -75,7 +75,7 @@ BuildRequires: php-spl
BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
# For tests, from composer.json "require-dev": {
-# "brianium/paratest": "^2.2.0",
+# "brianium/paratest": "^3.1.2",
# "phpunit/phpunit": "^7.5.0"
BuildRequires: phpunit7 >= 7.5
BuildRequires: php-date
@@ -243,6 +243,9 @@ EOF
%changelog
+* Thu Jan 23 2020 Remi Collet <remi@remirepo.net> - 2.4.7-1
+- update to 2.4.7
+
* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.4.6-1
- update to 2.4.6