summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-04 10:33:39 +0200
committerRemi Collet <remi@remirepo.net>2020-05-04 10:33:39 +0200
commitbca2e88e9e99a31d6a313e297be40f8939068249 (patch)
treec4bab77a3166db575e97325c7506c68461dbd973
parentfce55e6bfad2f559c2106dfa2d80cbe1e2238288 (diff)
update to 3.0.0-RC2
raise dependency on PHP 7.2 switch to phpunit8
-rw-r--r--composer.json9
-rw-r--r--phan-autoload.patch24
-rw-r--r--phan.spec22
3 files changed, 29 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index bbe2aa5..1efd2aa 100644
--- a/composer.json
+++ b/composer.json
@@ -18,11 +18,11 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.1.22"
+ "php": "7.2.24"
}
},
"require": {
- "php": "^7.1.0",
+ "php": "^7.2.0",
"ext-filter": "*",
"ext-json": "*",
"ext-tokenizer": "*",
@@ -33,8 +33,7 @@
"netresearch/jsonmapper": "^1.6.0|^2.0",
"sabre/event": "^5.0",
"symfony/console": "^2.3|^3.0|^4.0|^5.0",
- "symfony/polyfill-mbstring": "^1.11.0",
- "symfony/polyfill-php72": "^1.15"
+ "symfony/polyfill-mbstring": "^1.11.0"
},
"suggest": {
"ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.6+ is recommended.",
@@ -45,7 +44,7 @@
},
"require-dev": {
"brianium/paratest": "^4.0.0",
- "phpunit/phpunit": "^7.5.0"
+ "phpunit/phpunit": "^8.5.0"
},
"autoload": {
"psr-4": {"Phan\\": "src/Phan"}
diff --git a/phan-autoload.patch b/phan-autoload.patch
index a6704a8..719ab99 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,8 +1,8 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2020-04-13 08:23:03.774426918 +0200
-+++ ./src/Phan/Bootstrap.php 2020-04-13 08:24:38.961073489 +0200
-@@ -132,22 +132,8 @@ if (!function_exists('spl_object_id')) {
- require_once dirname(__DIR__) . '/spl_object_id.php';
+--- ./src/Phan/Bootstrap.php.rpm 2020-05-04 10:28:21.581423051 +0200
++++ ./src/Phan/Bootstrap.php 2020-05-04 10:30:07.345999193 +0200
+@@ -135,22 +135,8 @@ if (extension_loaded('ast')) {
+ }
}
-// Use the composer autoloader
@@ -27,16 +27,16 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2020-04-13 08:22:56.000000000 +0200
-+++ ./src/phan.php 2020-04-13 08:23:03.774426918 +0200
+--- ./src/phan.php.rpm 2020-05-04 10:26:34.000000000 +0200
++++ ./src/phan.php 2020-05-04 10:28:21.581423051 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-04-13 08:22:56.000000000 +0200
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-04-13 08:23:03.774426918 +0200
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-05-04 10:26:34.000000000 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-05-04 10:28:21.581423051 +0200
@@ -820,7 +820,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory(): string
@@ -47,16 +47,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2020-04-13 08:22:56.000000000 +0200
-+++ ./src/prep.php 2020-04-13 08:23:03.774426918 +0200
+--- ./src/prep.php.rpm 2020-05-04 10:26:34.000000000 +0200
++++ ./src/prep.php 2020-05-04 10:28:21.581423051 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2020-04-13 08:22:56.000000000 +0200
-+++ ./src/requirements.php 2020-04-13 08:23:03.774426918 +0200
+--- ./src/requirements.php.rpm 2020-05-04 10:26:34.000000000 +0200
++++ ./src/requirements.php 2020-05-04 10:28:21.581423051 +0200
@@ -10,10 +10,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index 8504d00..5bab044 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,15 +10,15 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit df79f6def6cb7643955af14aa4b97acdd3495ad6
+%global gh_commit c0e12bb592fe16ff09acfcebca149cde578db248
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.7.2
-#global upstream_prever RC2
+%global upstream_version 3.0.0
+%global upstream_prever RC2
Name: %{gh_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -76,8 +76,8 @@ BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
# For tests, from composer.json "require-dev": {
# "brianium/paratest": "^4.0.0",
-# "phpunit/phpunit": "^7.5.0"
-BuildRequires: phpunit7 >= 7.5
+# "phpunit/phpunit": "^8.5.0"
+BuildRequires: phpunit8 >= 8.5
BuildRequires: php-date
BuildRequires: php-intl
BuildRequires: php-soap
@@ -86,7 +86,7 @@ BuildRequires: php-soap
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "^7.1.0",
+# "php": "^7.2.0",
# "ext-filter": "*",
# "ext-json": "*",
# "ext-tokenizer": "*",
@@ -97,8 +97,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "netresearch/jsonmapper": "^1.6.0|^2.0",
# "sabre/event": "^5.0",
# "symfony/console": "^2.3|^3.0|~4.0|^5.0",
-# "symfony/polyfill-mbstring": "^1.11.0",
-# "symfony/polyfill-php72": "^1.15"
+# "symfony/polyfill-mbstring": "^1.11.0"
Requires: php(language) >= 7.2
Requires: php-filter
Requires: php-tokenizer
@@ -228,7 +227,7 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/Phan/Bootstrap.php';
EOF
# NOTICE mosquitto, request and grpc must be disabled
-%{_bindir}/phpunit7 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
+%{_bindir}/phpunit8 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
%else
@@ -247,6 +246,11 @@ EOF
%changelog
+* Mon May 4 2020 Remi Collet <remi@remirepo.net> - 3.0.0~RC2-1
+- update to 3.0.0-RC2
+- raise dependency on PHP 7.2
+- switch to phpunit8
+
* Mon May 4 2020 Remi Collet <remi@remirepo.net> - 2.7.2-1
- update to 2.7.2
- allow composer/semver version 2