summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-13 08:26:50 +0200
committerRemi Collet <remi@remirepo.net>2020-04-13 08:26:50 +0200
commit14e47b8bf48cf04a4e3e0b2cdd42c038e47a1372 (patch)
tree51693addf1eea2dffe7c4cbc98d10039a97f46cb
parente5436c1cc22e74fd3fca86c8ccfc8444acdaf3ac (diff)
v2.7.1
-rw-r--r--phan-autoload.patch28
-rw-r--r--phan.spec7
2 files changed, 19 insertions, 16 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 27c22e9..a6704a8 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,10 +1,10 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2020-01-23 08:24:27.000000000 +0100
-+++ ./src/Phan/Bootstrap.php 2020-01-23 08:24:56.789339699 +0100
-@@ -124,22 +124,8 @@ if (extension_loaded('ast')) {
- phan_output_ast_installation_instructions();
- }
+--- ./src/Phan/Bootstrap.php.rpm 2020-04-13 08:23:03.774426918 +0200
++++ ./src/Phan/Bootstrap.php 2020-04-13 08:24:38.961073489 +0200
+@@ -132,22 +132,8 @@ if (!function_exists('spl_object_id')) {
+ require_once dirname(__DIR__) . '/spl_object_id.php';
}
+
-// Use the composer autoloader
-$found_autoloader = false;
-foreach ([
@@ -27,17 +27,17 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2020-01-23 08:24:56.790339693 +0100
-+++ ./src/phan.php 2020-01-23 08:25:29.007139671 +0100
+--- ./src/phan.php.rpm 2020-04-13 08:22:56.000000000 +0200
++++ ./src/phan.php 2020-04-13 08:23:03.774426918 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-01-23 08:24:56.790339693 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-01-23 08:26:02.086934309 +0100
-@@ -771,7 +771,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-04-13 08:22:56.000000000 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-04-13 08:23:03.774426918 +0200
+@@ -820,7 +820,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory(): string
{
@@ -47,16 +47,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2020-01-23 08:24:56.790339693 +0100
-+++ ./src/prep.php 2020-01-23 08:26:22.637806720 +0100
+--- ./src/prep.php.rpm 2020-04-13 08:22:56.000000000 +0200
++++ ./src/prep.php 2020-04-13 08:23:03.774426918 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2020-01-23 08:24:27.000000000 +0100
-+++ ./src/requirements.php 2020-01-23 08:24:56.790339693 +0100
+--- ./src/requirements.php.rpm 2020-04-13 08:22:56.000000000 +0200
++++ ./src/requirements.php 2020-04-13 08:23:03.774426918 +0200
@@ -10,10 +10,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index e0eaf91..f4f0237 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c1694f08654e0cd534d1ecda10f242c77a44f235
+%global gh_commit 67c51bb1593e5c30271fc16d691b82e318b90b77
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.7.0
+%global upstream_version 2.7.1
#global upstream_prever RC2
Name: %{gh_project}
@@ -244,6 +244,9 @@ EOF
%changelog
+* Mon Apr 13 2020 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
* Thu Apr 2 2020 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0
- raise dependency on PHP 7.2