summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-18 09:35:06 +0100
committerRemi Collet <remi@remirepo.net>2017-11-18 09:35:06 +0100
commitb2ec40be6c72916226c4e7d2fe50015f17d8cbbe (patch)
tree00c639c6074f06e7f0273b093fef4810198c5d38
parentf1027ffd1fa27063abe658d4fe7527df645a74eb (diff)
v0.10.2 for PHP 7.1
-rw-r--r--phan-autoload.patch31
-rw-r--r--phan.spec14
2 files changed, 24 insertions, 21 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 3931483..cca1b77 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,17 +1,16 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2017-10-21 03:57:26.000000000 +0200
-+++ ./src/codebase.php 2017-10-21 09:10:09.657338342 +0200
-@@ -11,14 +11,8 @@ $internal_const_name_list = array_keys(a
+--- ./src/codebase.php.rpm 2017-11-18 09:30:04.518656417 +0100
++++ ./src/codebase.php 2017-11-18 09:30:26.764775627 +0100
+@@ -6,13 +6,8 @@ $internal_interface_name_list = get_decl
+ $internal_trait_name_list = get_declared_traits();
$internal_function_name_list = get_defined_functions()['internal'];
-
-if (file_exists(__DIR__ . '/../vendor/autoload.php')) {
- // This is the normal path when Phan is installed only in the scope of a project.
-- require_once __DIR__ . '/../vendor/autoload.php';
--}
--else {
+- require_once __DIR__ . '/../vendor/autoload.php';
+-} else {
- // This is the path to autoload.php when Phan is installed globally.
-- require_once __DIR__ . '/../../../autoload.php';
+- require_once __DIR__ . '/../../../autoload.php';
-}
+// Use the fedora autoloader
+require_once __DIR__ . '/autoload.php';
@@ -19,8 +18,8 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2017-10-21 03:57:26.000000000 +0200
-+++ ./src/Phan/Bootstrap.php 2017-10-21 09:10:09.658338347 +0200
+--- ./src/Phan/Bootstrap.php.rpm 2017-11-18 06:29:19.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2017-11-18 09:30:04.519656422 +0100
@@ -10,16 +10,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path().PATH_SEPARATOR.CLASS_DIR);
@@ -41,24 +40,24 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2017-10-21 03:57:26.000000000 +0200
-+++ ./src/phan.php 2017-10-21 09:10:09.658338347 +0200
+--- ./src/phan.php.rpm 2017-11-18 06:29:19.000000000 +0100
++++ ./src/phan.php 2017-11-18 09:30:04.519656422 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2017-10-21 03:57:26.000000000 +0200
-+++ ./src/prep.php 2017-10-21 09:10:09.658338347 +0200
+--- ./src/prep.php.rpm 2017-11-18 06:29:19.000000000 +0100
++++ ./src/prep.php 2017-11-18 09:30:04.519656422 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2017-10-21 09:10:09.658338347 +0200
-+++ ./src/requirements.php 2017-10-21 09:10:41.040503645 +0200
+--- ./src/requirements.php.rpm 2017-11-18 06:29:19.000000000 +0100
++++ ./src/requirements.php 2017-11-18 09:30:04.519656422 +0100
@@ -11,8 +11,8 @@ assert(
);
diff --git a/phan.spec b/phan.spec
index 9e815b7..657ef8e 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2085277ba7b96a00e1351c52012ffc9b103ec769
+%global gh_commit 53d9a6163ab7f9de1fd89b48e56bb5df985950aa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.10.1
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 0.10.2
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}.7.1
Summary: A static analyzer for PHP
Group: Development/Libraries
@@ -29,8 +29,9 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
+BuildRequires: php(language) < 7.2
BuildRequires: php(language) >= 7.1
-BuildRequires: php-ast >= 0.1.4
+BuildRequires: php-ast >= 0.1.5
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 3
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
BuildRequires: php-composer(nikic/php-parser) < 4
@@ -67,7 +68,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "sabre/event": "^5.0",
# "symfony/console": "~2.3|~3.0"
Requires: php(language) >= 7.1
-Requires: php-ast >= 0.1.4
+Requires: php-ast >= 0.1.5
Requires: php-composer(felixfbecker/advanced-json-rpc) < 3
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
Requires: php-composer(nikic/php-parser) < 4
@@ -177,6 +178,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 0.10.2-1
+- Update to 0.10.2
+
* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 0.10.1-1
- Update to 0.10.1
- add dependency on felixfbecker/advanced-json-rpc 2.0