summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-16 11:52:35 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-16 11:52:35 +0100
commit82ecedbdeed0d15c836a0790723a312e76331ca1 (patch)
treedf6d1da9bd3737333ef52d94992621b495ce7ea1
parent8c9e4ef4111316ac19596f084eaa9ecaab34c944 (diff)
phan: 0.9.1
-rw-r--r--composer.json8
-rw-r--r--phan-autoload.patch9
-rw-r--r--phan.spec34
3 files changed, 21 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index 7c11a43..eed872f 100644
--- a/composer.json
+++ b/composer.json
@@ -16,14 +16,12 @@
"sort-packages": true
},
"require": {
- "php": "~7.0.0",
- "ext-ast": "*",
+ "php": "~7.1.0",
+ "ext-ast": "^0.1.4",
"symfony/console": "~2.3|~3.0"
},
"require-dev": {
- "phpdocumentor/phpdocumentor": "^2.9.0",
- "phpunit/phpunit": "^5.7.2",
- "squizlabs/php_codesniffer": "^2.7.1"
+ "phpunit/phpunit": "^5.7.2"
},
"autoload": {
"psr-4": {"Phan\\": "src/Phan"}
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 4eb8753..d391ccb 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -21,7 +21,7 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
--- ./src/Phan/Bootstrap.php.rpm 2016-11-24 16:12:00.366054438 +0100
+++ ./src/Phan/Bootstrap.php 2016-11-24 16:16:28.316479122 +0100
-@@ -11,16 +11,8 @@ ini_set("memory_limit", '-1');
+@@ -10,16 +10,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path().PATH_SEPARATOR.CLASS_DIR);
@@ -75,9 +75,9 @@ diff -up ./src/prep.php.rpm ./src/prep.php
use Phan\CLI;
use Phan\Prep;
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2016-11-24 16:15:45.623252123 +0100
-+++ ./src/requirements.php 2016-11-24 16:16:13.253399032 +0100
-@@ -11,7 +11,7 @@ assert(
+--- ./src/requirements.php.rpm 2017-03-16 11:48:32.604583610 +0100
++++ ./src/requirements.php 2017-03-16 11:48:37.237605505 +0100
+@@ -11,6 +11,6 @@ assert(
);
assert(
@@ -85,4 +85,3 @@ diff -up ./src/requirements.php.rpm ./src/requirements.php
+ file_exists(__DIR__ . '/autoload.php'),
'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/etsy/phan#getting-it-running for more details.'
);
-
diff --git a/phan.spec b/phan.spec
index f5979a2..64a5eea 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5f12a3cfbae585618f5b02992c8810c7679457d0
+%global gh_commit eadb20b627f97a7ce5bf3353e86f9820e34fa61c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner etsy
#global gh_date 20150820
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.8.3
+Version: 0.9.1
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -30,8 +30,8 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
-BuildRequires: php-ast
+BuildRequires: php(language) >= 7.1
+BuildRequires: php-ast >= 0.1.4
BuildRequires: php-composer(symfony/console) >= 2.8
BuildRequires: php-reflection
BuildRequires: php-pcntl
@@ -41,20 +41,18 @@ BuildRequires: php-spl
BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
# For tests, from composer.json "require-dev": {
-# "phpdocumentor/phpdocumentor": "^2.9.0",
-# "phpunit/phpunit": "^5.7.2",
-# "squizlabs/php_codesniffer": "^2.7.1"
+# "phpunit/phpunit": "^5.7.2"
BuildRequires: php-composer(phpunit/phpunit) >= 5.7.2
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "~7.0.0",
-# "ext-ast": "*",
+# "php": "~7.1.0",
+# "ext-ast": "^0.1.4",
# "symfony/console": "~2.3|~3.0"
-Requires: php(language) >= 7.0
-Requires: php-ast
+Requires: php(language) >= 7.1
+Requires: php-ast >= 0.1.4
Requires: php-composer(symfony/console) >= 2.3
# From phpcompatinfo report for 0.8.0
Requires: php-cli
@@ -115,16 +113,7 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/Bootstrap.php';
\Fedora\Autoloader\Autoload::addPsr4('Phan\\Tests\\', __DIR__ . '/Phan');
EOF
-# remirepo:6
-run=0
-ret=0
-if which php71; then
- php71 %{_bindir}/phpunit -d memory_limit=1G --bootstrap tests/autoload.php
- run=1
-fi
%{_bindir}/phpunit -d memory_limit=1G --bootstrap tests/autoload.php --verbose
-# remirepo:1
-exit $ret
%else
@@ -147,6 +136,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 16 2017 Remi Collet <remi@remirepo.net> - 0.9.1-1
+- Update to 0.9.1
+- raise dependency on PHP 7.1
+- raise dependency on ast 0.1.4
+
* Fri Jan 27 2017 Remi Collet <remi@remirepo.net> - 0.8.3-1
- update to 0.8.3