summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-14 09:28:55 +0200
committerRemi Collet <remi@remirepo.net>2017-06-14 09:28:55 +0200
commit233e8f5a9bce7d1f4aff1ba302f8788a196a0697 (patch)
tree6f6e9fc7ffd178d1f4a7ce38ac019c813be206ed
parent82ecedbdeed0d15c836a0790723a312e76331ca1 (diff)
v0.9.2
-rw-r--r--.gitignore7
-rw-r--r--composer.json4
-rw-r--r--phan-autoload.php9
-rw-r--r--phan.spec26
4 files changed, 36 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index eed872f..47a7581 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,7 @@
"symfony/console": "~2.3|~3.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.2"
+ "phpunit/phpunit": "^6.2.1"
},
"autoload": {
"psr-4": {"Phan\\": "src/Phan"}
@@ -29,5 +29,5 @@
"autoload-dev": {
"psr-4": {"Phan\\Tests\\": "tests/Phan"}
},
- "bin": ["phan", "tocheckstyle"]
+ "bin": ["phan", "phan_client", "tocheckstyle"]
}
diff --git a/phan-autoload.php b/phan-autoload.php
index 323e5b1..b40a5bf 100644
--- a/phan-autoload.php
+++ b/phan-autoload.php
@@ -4,6 +4,9 @@
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Phan\\', __DIR__);
-\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/Symfony/Component/Console/autoload.php',
-));
+\Fedora\Autoloader\Dependencies::required([
+ [
+ '/usr/share/php/Symfony3/Component/Console/autoload.php',
+ '/usr/share/php/Symfony/Component/Console/autoload.php',
+ ],
+]);
diff --git a/phan.spec b/phan.spec
index 64a5eea..2f4da2b 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit eadb20b627f97a7ce5bf3353e86f9820e34fa61c
+%global gh_commit 6757938c1f18e245fec5ebdf629fe8b0f3d1e41d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner etsy
#global gh_date 20150820
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.9.1
+Version: 0.9.2
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -32,8 +32,12 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 7.1
BuildRequires: php-ast >= 0.1.4
+BuildRequires: php-composer(symfony/console) < 4
BuildRequires: php-composer(symfony/console) >= 2.8
BuildRequires: php-reflection
+BuildRequires: php-dom
+BuildRequires: php-filter
+BuildRequires: php-json
BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-posix
@@ -41,8 +45,11 @@ BuildRequires: php-spl
BuildRequires: php-sysvmsg
BuildRequires: php-sysvsem
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^5.7.2"
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7.2
+# "phpunit/phpunit": "^6.2.1"
+BuildRequires: phpunit6 >= 6.2.1
+BuildRequires: php-date
+BuildRequires: php-intl
+BuildRequires: php-soap
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -53,9 +60,13 @@ BuildRequires: php-composer(fedora/autoloader)
# "symfony/console": "~2.3|~3.0"
Requires: php(language) >= 7.1
Requires: php-ast >= 0.1.4
+Requires: php-composer(symfony/console) < 4
Requires: php-composer(symfony/console) >= 2.3
# From phpcompatinfo report for 0.8.0
Requires: php-cli
+Requires: php-dom
+Requires: php-filter
+Requires: php-json
Requires: php-reflection
Requires: php-pcntl
Requires: php-pcre
@@ -113,7 +124,7 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/Bootstrap.php';
\Fedora\Autoloader\Autoload::addPsr4('Phan\\Tests\\', __DIR__ . '/Phan');
EOF
-%{_bindir}/phpunit -d memory_limit=1G --bootstrap tests/autoload.php --verbose
+%{_bindir}/phpunit6 -d memory_limit=1G --bootstrap tests/autoload.php --verbose
%else
@@ -136,6 +147,11 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 14 2017 Remi Collet <remi@remirepo.net> - 0.9.2-1
+- Update to 0.9.2
+- allow Symfony 3
+- use phpunit 6
+
* Thu Mar 16 2017 Remi Collet <remi@remirepo.net> - 0.9.1-1
- Update to 0.9.1
- raise dependency on PHP 7.1