summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-18 09:28:06 +0100
committerRemi Collet <remi@remirepo.net>2017-11-18 09:28:06 +0100
commitbe77e8fe52300bb33a6b6a323a1c5c57e482bef7 (patch)
treef52dd74c17751c005fe708bb835c5b0756f900d3
parentfcc01d1555bfe40fdfcc238b8999068a3d024a10 (diff)
v0.8.10 for PHP 7.0
-rw-r--r--composer.json2
-rw-r--r--phan-autoload.patch31
-rw-r--r--phan.spec16
3 files changed, 26 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index daf6f91..88ae65c 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
},
"require": {
"php": "~7.0.0 || ~7.1.0 || ~7.2.0",
- "ext-ast": "^0.1.4",
+ "ext-ast": "^0.1.5",
"felixfbecker/advanced-json-rpc": "^2.0",
"nikic/PHP-Parser": "~3.1.1",
"sabre/event": "^5.0",
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 2d8e88d..e6a4833 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,17 +1,16 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2017-10-21 04:26:51.000000000 +0200
-+++ ./src/codebase.php 2017-10-21 08:59:16.643898735 +0200
-@@ -11,14 +11,8 @@ $internal_const_name_list = array_keys(a
+--- ./src/codebase.php.rpm 2017-11-18 09:18:36.902966888 +0100
++++ ./src/codebase.php 2017-11-18 09:20:25.066548571 +0100
+@@ -6,13 +6,8 @@ $internal_interface_name_list = get_decl
+ $internal_trait_name_list = get_declared_traits();
$internal_function_name_list = get_defined_functions()['internal'];
-
-if (file_exists(__DIR__ . '/../vendor/autoload.php')) {
- // This is the normal path when Phan is installed only in the scope of a project.
-- require_once __DIR__ . '/../vendor/autoload.php';
--}
--else {
+- require_once __DIR__ . '/../vendor/autoload.php';
+-} else {
- // This is the path to autoload.php when Phan is installed globally.
-- require_once __DIR__ . '/../../../autoload.php';
+- require_once __DIR__ . '/../../../autoload.php';
-}
+// Use the fedora autoloader
+require_once __DIR__ . '/autoload.php';
@@ -19,8 +18,8 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2017-10-21 04:26:51.000000000 +0200
-+++ ./src/Phan/Bootstrap.php 2017-10-21 08:59:16.643898735 +0200
+--- ./src/Phan/Bootstrap.php.rpm 2017-11-18 06:39:49.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2017-11-18 09:18:36.903966894 +0100
@@ -10,16 +10,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path().PATH_SEPARATOR.CLASS_DIR);
@@ -41,24 +40,24 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2017-10-21 04:26:51.000000000 +0200
-+++ ./src/phan.php 2017-10-21 08:59:16.643898735 +0200
+--- ./src/phan.php.rpm 2017-11-18 06:39:49.000000000 +0100
++++ ./src/phan.php 2017-11-18 09:18:36.903966894 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2017-10-21 04:26:51.000000000 +0200
-+++ ./src/prep.php 2017-10-21 08:59:16.643898735 +0200
+--- ./src/prep.php.rpm 2017-11-18 06:39:49.000000000 +0100
++++ ./src/prep.php 2017-11-18 09:18:36.903966894 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2017-10-21 08:59:16.643898735 +0200
-+++ ./src/requirements.php 2017-10-21 09:00:37.774326072 +0200
+--- ./src/requirements.php.rpm 2017-11-18 06:39:49.000000000 +0100
++++ ./src/requirements.php 2017-11-18 09:18:36.903966894 +0100
@@ -11,8 +11,8 @@ assert(
);
diff --git a/phan.spec b/phan.spec
index abdbac3..bb59372 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit af93901dba4cb00f7d6a2cd4c2a862d774a8b3b4
+%global gh_commit 2520ce1292974b274017570cffaa8454018baee7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.8.9
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 0.8.10
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}.7.0
Summary: A static analyzer for PHP
Group: Development/Libraries
@@ -29,8 +29,9 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
+BuildRequires: php(language) < 7.1
BuildRequires: php(language) >= 7.0
-BuildRequires: php-ast
+BuildRequires: php-ast >= 0.1.5
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 3
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
BuildRequires: php-composer(nikic/php-parser) < 4
@@ -62,13 +63,13 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "~7.0.0 || ~7.1.0 || ~7.2.0",
-# "ext-ast": "^0.1.4",
+# "ext-ast": "^0.1.5",
# "felixfbecker/advanced-json-rpc": "^2.0",
# "nikic/PHP-Parser": "~3.1.1",
# "sabre/event": "^5.0",
# "symfony/console": "~2.3|~3.0"
Requires: php(language) >= 7.0
-Requires: php-ast
+Requires: php-ast >= 0.1.5
Requires: php-composer(felixfbecker/advanced-json-rpc) < 3
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
Requires: php-composer(nikic/php-parser) < 4
@@ -173,6 +174,9 @@ EOF
%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 0.8.10-1
+- Update to 0.8.10
+
* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 0.8.9-1
- Update to 0.8.9
- add dependency on felixfbecker/advanced-json-rpc 2.0