summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-25 09:39:40 +0200
committerRemi Collet <remi@remirepo.net>2017-09-25 09:39:40 +0200
commit07cd6d4645e01ff11b0eb05d822f0f18d4ca96b3 (patch)
tree142edd64f8481853fb4a20b24978ef8d91df0d34
parentb70554727341e560c12a3534c069dd59ecaf8886 (diff)
v0.8.8
-rw-r--r--phan-autoload.patch23
-rw-r--r--phan.spec7
2 files changed, 17 insertions, 13 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 753f06d..c10a2d7 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,6 +1,6 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2017-06-13 17:53:57.000000000 +0200
-+++ ./src/codebase.php 2017-06-14 06:15:48.238648972 +0200
+--- ./src/codebase.php.rpm 2017-09-24 22:02:32.000000000 +0200
++++ ./src/codebase.php 2017-09-25 09:30:54.398808581 +0200
@@ -11,14 +11,8 @@ $internal_const_name_list = array_keys(a
$internal_function_name_list = get_defined_functions()['internal'];
@@ -19,8 +19,8 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2017-06-13 17:53:57.000000000 +0200
-+++ ./src/Phan/Bootstrap.php 2017-06-14 06:15:48.238648972 +0200
+--- ./src/Phan/Bootstrap.php.rpm 2017-09-24 22:02:32.000000000 +0200
++++ ./src/Phan/Bootstrap.php 2017-09-25 09:30:54.398808581 +0200
@@ -10,16 +10,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path().PATH_SEPARATOR.CLASS_DIR);
@@ -41,29 +41,30 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2017-06-13 17:53:57.000000000 +0200
-+++ ./src/phan.php 2017-06-14 06:15:48.238648972 +0200
+--- ./src/phan.php.rpm 2017-09-24 22:02:32.000000000 +0200
++++ ./src/phan.php 2017-09-25 09:30:54.398808581 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2017-06-13 17:53:57.000000000 +0200
-+++ ./src/prep.php 2017-06-14 06:15:48.238648972 +0200
+--- ./src/prep.php.rpm 2017-09-24 22:02:32.000000000 +0200
++++ ./src/prep.php 2017-09-25 09:30:54.399808587 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2017-06-14 06:15:48.239648977 +0200
-+++ ./src/requirements.php 2017-06-14 06:16:26.179834206 +0200
+--- ./src/requirements.php.rpm 2017-09-25 09:30:54.399808587 +0200
++++ ./src/requirements.php 2017-09-25 09:31:59.525193144 +0200
@@ -11,6 +11,6 @@ assert(
);
assert(
- file_exists(__DIR__ . '/../vendor/autoload.php') || file_exists(__DIR__ . '/../../../autoload.php'),
+- 'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/phan/phan#getting-it-running for more details.'
+ file_exists(__DIR__ . '/autoload.php'),
- 'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/etsy/phan#getting-it-running for more details.'
++ 'Autoloader not found.'
);
diff --git a/phan.spec b/phan.spec
index fdae027..c3a0050 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e6ee68b7bf97a22acec2cb5a8d441153ab54b3bd
+%global gh_commit 9a559221a31526ff2f09947800cd6cc4ba592ac9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner etsy
#global gh_date 20150820
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.8.6
+Version: 0.8.8
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -154,6 +154,9 @@ EOF
%changelog
+* Mon Sep 25 2017 Remi Collet <remi@remirepo.net> - 0.8.8-1
+- Update to 0.8.8
+
* Wed Aug 16 2017 Remi Collet <remi@remirepo.net> - 0.8.6-1
- Update to 0.8.6