From c98e203eb454aa0baacb2eecac7da01cd40d2a64 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Tue, 21 Sep 2010 18:28:17 +0200
Subject: mysql-workbench 5.2.28 - last fixes

---
 mysql-workbench-5.2.22-python.patch | 33 ---------------------
 mysql-workbench-5.2.28-python.patch | 58 +++++++++++++++++++++++++++++++++++++
 mysql-workbench.spec                | 11 +++++--
 3 files changed, 67 insertions(+), 35 deletions(-)
 delete mode 100644 mysql-workbench-5.2.22-python.patch
 create mode 100644 mysql-workbench-5.2.28-python.patch

diff --git a/mysql-workbench-5.2.22-python.patch b/mysql-workbench-5.2.22-python.patch
deleted file mode 100644
index 9a3bfbc..0000000
--- a/mysql-workbench-5.2.22-python.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- mysql-workbench-oss-5.2.22/res/scripts/snippets/shell_snippets.py.orig	2010-06-04 21:38:58.639945233 +0200
-+++ mysql-workbench-oss-5.2.22/res/scripts/snippets/shell_snippets.py	2010-06-04 21:39:15.835195627 +0200
-@@ -1,19 +1,19 @@
-- # iterate through all schemas
-- for schema in grt.root.wb.doc.physicalModels[0].catalog.schemata:
-+# iterate through all schemas
-+for schema in grt.root.wb.doc.physicalModels[0].catalog.schemata:
-      print schema.name
- 
-- # iterate through all tables from schema
-- schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
-- for table in schema.tables:
-+# iterate through all tables from schema
-+schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
-+for table in schema.tables:
-      print table.name
- 
-- # iterate through columns from schema
-- schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
-- for table in schema.tables:
-+# iterate through columns from schema
-+schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
-+for table in schema.tables:
-      for column in table.columns:
-          print table.name, column.name
- 
-- # iterate through all figures of a diagram
-- diagram = grt.root.wb.doc.physicalModels[0].diagram
-- for figure in diagram.figures:
-+# iterate through all figures of a diagram
-+diagram = grt.root.wb.doc.physicalModels[0].diagram
-+for figure in diagram.figures:
-      print figure.__grtclassname__, figure.left, figure.top
diff --git a/mysql-workbench-5.2.28-python.patch b/mysql-workbench-5.2.28-python.patch
new file mode 100644
index 0000000..1e872d2
--- /dev/null
+++ b/mysql-workbench-5.2.28-python.patch
@@ -0,0 +1,58 @@
+--- mysql-workbench-oss-5.2.22/res/scripts/snippets/shell_snippets.py.orig	2010-06-04 21:38:58.639945233 +0200
++++ mysql-workbench-oss-5.2.22/res/scripts/snippets/shell_snippets.py	2010-06-04 21:39:15.835195627 +0200
+@@ -1,19 +1,19 @@
+- # iterate through all schemas
+- for schema in grt.root.wb.doc.physicalModels[0].catalog.schemata:
++# iterate through all schemas
++for schema in grt.root.wb.doc.physicalModels[0].catalog.schemata:
+      print schema.name
+ 
+- # iterate through all tables from schema
+- schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
+- for table in schema.tables:
++# iterate through all tables from schema
++schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
++for table in schema.tables:
+      print table.name
+ 
+- # iterate through columns from schema
+- schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
+- for table in schema.tables:
++# iterate through columns from schema
++schema = grt.root.wb.doc.physicalModels[0].catalog.schemata[0]
++for table in schema.tables:
+      for column in table.columns:
+          print table.name, column.name
+ 
+- # iterate through all figures of a diagram
+- diagram = grt.root.wb.doc.physicalModels[0].diagram
+- for figure in diagram.figures:
++# iterate through all figures of a diagram
++diagram = grt.root.wb.doc.physicalModels[0].diagram
++for figure in diagram.figures:
+      print figure.__grtclassname__, figure.left, figure.top
+--- mysql-workbench-gpl-5.2.28-src/res/scripts/snippets/shell_snippets.py.orig	2010-09-21 17:38:45.243356701 +0200
++++ mysql-workbench-gpl-5.2.28-src/res/scripts/snippets/shell_snippets.py	2010-09-21 17:38:59.850746929 +0200
+@@ -18,14 +18,14 @@
+ for figure in diagram.figures:
+      print figure.__grtclassname__, figure.left, figure.top
+ 
+- # iterate through all resultset rows
+- resultset = grt.root.wb.sqlEditors[0].activeResultset
+- flag = resultset.goToFirst()
+- while flag:
++# iterate through all resultset rows
++resultset = grt.root.wb.sqlEditors[0].activeResultset
++flag = resultset.goToFirst()
++while flag:
+    print resultset.stringFieldValue(0)
+    flag = resultset.nextRow()
+ 
+- # replace sql editor contents
+- editor = grt.root.wb.sqlEditors[0].activeQueryBuffer
+- new_text = editor.sql
+- editor.replaceContents(new_text)
++# replace sql editor contents
++editor = grt.root.wb.sqlEditors[0].activeQueryBuffer
++new_text = editor.sql
++editor.replaceContents(new_text)
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
index 7f81a5c..41635be 100644
--- a/mysql-workbench.spec
+++ b/mysql-workbench.spec
@@ -2,6 +2,9 @@
 %global tartype gpl
 %global cppconnver 1.1.0-0.3.bzr895
 
+# Temporary workaround for "script_templates" which shouldn't be compiled
+%global _python_bytecompile_errors_terminate_build 0
+
 Summary:   A MySQL visual database modeling, administration and querying tool
 Name:      mysql-workbench
 Version:   5.2.28
@@ -16,9 +19,9 @@ URL:       http://wb.mysql.com
 Source:    %{name}-%{tartype}-%{version}%{?postver}.tar.gz
 
 # don't build extension, use system one
-# !!! This patch use versioned soname !!!
+# !!! This patch use versioned soname (libmysqlcppconn.so.5) !!!
 Patch1:    %{name}-5.2.28-cppconn.patch
-Patch2:    %{name}-5.2.22-python.patch
+Patch2:    %{name}-5.2.28-python.patch
 Patch3:    %{name}-5.2.27-ctemplate.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -149,6 +152,10 @@ update-desktop-database &> /dev/null || :
 %changelog
 * Mon Sep 20 2010 Remi Collet <Fedora@famillecollet.com> 5.2.28-1
 - update to 5.2.28 Community (OSS) Edition (GPL)
+  http://dev.mysql.com/doc/workbench/en/wb-news-5-2-28.html
+- build against mysql-connector-c++ 1.1.0 (bzr895)
+- improve cppconn patch
+- temporary disable  _python_bytecompile_errors_terminate_build
 
 * Sat Sep 18 2010 Remi Collet <Fedora@famillecollet.com> 5.2.27-2
 - remove obsoleted configure options
-- 
cgit