summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec51
1 files changed, 39 insertions, 12 deletions
diff --git a/vips.spec b/vips.spec
index 99133b7..ad0200c 100644
--- a/vips.spec
+++ b/vips.spec
@@ -8,12 +8,17 @@
# Please preserve changelog entries
#
%global vips_version_base 8.7
-%global vips_version %{vips_version_base}.0
+%global vips_version %{vips_version_base}.2
%global vips_soname_major 42
#global vips_prever rc3
%global vips_tarver %{vips_version}%{?vips_prever:-%{vips_prever}}
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%global with_python2 0
+%else
%global with_python2 1
+%endif
+
%if 0%{?fedora} || 0%{?rhel} >= 8
%global with_python3 1
%global with_doc 1
@@ -24,7 +29,7 @@
Name: vips
Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: C/C++ library for processing large images
License: LGPLv2+
@@ -94,28 +99,39 @@ The %{name}-tools package contains command-line tools for working with VIPS.
%if %{with_python2}
-%package python
+%package -n python2-vips
Summary: Python 2 support for %{name}
BuildRequires: python2-devel
Requires: vips%{?_isa} = %{version}-%{release}
Requires: pygobject3-base >= 3.12.0
-Provides: python2-vipsCC = %{version}-%{release}
+Provides: python2-vipsCC = %{version}-%{release}
+Provides: python2-vipsCC%{?_isa} = %{version}-%{release}
+Obsoletes: vips-python < 8.7.2
+Provides: vips-python = %{version}-%{release}
+Provides: vips-python%{?_isa} = %{version}-%{release}
+
+%{?python_provide:%python_provide python2-vips}
%{?python_provide:%python_provide python2-vipsCC}
-%description python
+%description -n python2-vips
The %{name}-python package contains Python 2 support for VIPS.
%endif
%if %{with_python3}
-%package python3
+%package -n python3-vips
Summary: Python 3 support for %{name}
BuildRequires: python3-devel
Requires: vips%{?_isa} = %{version}-%{release}
Requires: python3-gobject >= 3.12.0
+Obsoletes: vips-python3 < 8.7.2
+Provides: vips-python3 = %{version}-%{release}
+Provides: vips-python3%{?_isa} = %{version}-%{release}
+%{?python_provide:%python_provide python3-vips}
+
# No provide for python3-vipsCC, since we only have the gi overrides
-%description python3
+%description -n python3-vips
The %{name}-python3 package contains Python 3 support for VIPS.
%endif
@@ -153,12 +169,17 @@ export CFLAGS="%{optflags} -ftree-vectorize"
export CXXFLAGS="%{optflags} -ftree-vectorize"
%configure \
%if %{with_doc}
+ --disable-static \
--enable-gtk-doc \
%endif
--enable-cpp7 \
- --enable-pyvips7 \
--enable-pyvips8 \
- --disable-static
+%if %{with_python2}
+ --enable-pyvips7 \
+ PYTHON=%{_bindir}/python2
+%else
+ PYTHON=%{_bindir}/python3
+%endif
make %{?_smp_mflags}
@@ -172,7 +193,7 @@ rm -rf ${RPM_BUILD_ROOT}%{_datadir}/doc/vips
# locale stuff
%find_lang vips%{vips_version_base}
-%if %{with_python3}
+%if %{with_python2} && %{with_python3}
# Upstream supports the GI override module on Python 3, but doesn't install
# it into the Python 3 path
mkdir -p ${RPM_BUILD_ROOT}%{python3_sitearch}
@@ -210,14 +231,14 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%if %{with_python2}
-%files python
+%files -n python2-vips
%{python2_sitearch}/gi/overrides/*
%{python2_sitearch}/vipsCC/
%endif
%if %{with_python3}
-%files python3
+%files -n python3-vips
%{python3_sitearch}/gi/overrides/*.py
%{python3_sitearch}/gi/overrides/__pycache__/*
%endif
@@ -231,6 +252,12 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%changelog
+* Wed Dec 19 2018 Remi Collet <remi@remirepo.net> - 8.7.2-1
+- update to 8.7.2
+- rename vips-python to python2-vips
+- rename vips-python3 to python3-vips
+- drop python2 on F30 and EL8
+
* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 8.7.0-3
- fix URL and sources (from jcupitt to libvips)
- requires pkgconfig(libjpeg) instead of libjpeg-turbo-devel