summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec26
1 files changed, 10 insertions, 16 deletions
diff --git a/vips.spec b/vips.spec
index aaa9b7e..fd1505f 100644
--- a/vips.spec
+++ b/vips.spec
@@ -8,13 +8,13 @@
# Please preserve changelog entries
#
%global vips_version_base 8.6
-%global vips_version %{vips_version_base}.2
+%global vips_version %{vips_version_base}.3
%global vips_soname_major 42
#global vips_prever alpha5
%global vips_tarver %{vips_version}
%global with_python2 1
-%if 0%{?fedora}
+%if 0%{?fedora} || 0%{?rhel} >= 8
%global with_python3 1
%global with_doc 1
%else
@@ -27,7 +27,6 @@ Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
Release: 1%{?dist}
Summary: C/C++ library for processing large images
-Group: System Environment/Libraries
License: LGPLv2+
URL: http://jcupitt.github.io/libvips/
Source0: https://github.com/jcupitt/libvips/releases/download/v%{vips_version}%{?vips_prever:-%{vips_prever}}/vips-%{vips_tarver}.tar.gz
@@ -37,16 +36,12 @@ BuildRequires: pkgconfig(gobject-introspection-1.0)
BuildRequires: pkgconfig(pygobject-3.0)
BuildRequires: pkgconfig(expat)
BuildRequires: pkgconfig(fftw3)
-%if 0%{?fedora} >= 27
-BuildRequires: ImageMagick-devel >= 1:6
-%else
-%if 0%{?fedora} >= 25
-BuildRequires: ImageMagick-devel < 7
+%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
+BuildRequires: ImageMagick-devel
%else
# Ensure we use version 6 (same as imagick ext).
BuildRequires: ImageMagick6-devel
%endif
-%endif
BuildRequires: pkgconfig(orc-0.4)
BuildRequires: pkgconfig(lcms2)
BuildRequires: pkgconfig(OpenEXR)
@@ -81,7 +76,6 @@ against VIPS.
%package devel
Summary: Development files for %{name}
-Group: Development/Libraries
Requires: libjpeg-devel%{?_isa} libtiff-devel%{?_isa} zlib-devel%{?_isa}
Requires: vips%{?_isa} = %{version}-%{release}
@@ -93,7 +87,6 @@ contains a C++ API and development documentation.
%package tools
Summary: Command-line tools for %{name}
-Group: Applications/Multimedia
Requires: vips%{?_isa} = %{version}-%{release}
%description tools
@@ -103,7 +96,6 @@ The %{name}-tools package contains command-line tools for working with VIPS.
%if %{with_python2}
%package python
Summary: Python 2 support for %{name}
-Group: Development/Languages
BuildRequires: python2-devel
Requires: vips%{?_isa} = %{version}-%{release}
Requires: pygobject3-base >= 3.12.0
@@ -118,7 +110,6 @@ The %{name}-python package contains Python 2 support for VIPS.
%if %{with_python3}
%package python3
Summary: Python 3 support for %{name}
-Group: Development/Languages
BuildRequires: python3-devel
Requires: vips%{?_isa} = %{version}-%{release}
Requires: python3-gobject >= 3.12.0
@@ -132,7 +123,6 @@ The %{name}-python3 package contains Python 3 support for VIPS.
%if %{with_doc}
%package doc
Summary: Documentation for %{name}
-Group: Documentation
BuildRequires: swig gtk-doc
Conflicts: %{name} < %{version}-%{release}, %{name} > %{version}-%{release}
@@ -192,9 +182,10 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%endif
-%post -p /sbin/ldconfig
-
+%if 0%{?fedora} < 28 && 0%{?rhel} < 8
+%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
+%endif
%files -f vips%{vips_version_base}.lang
@@ -239,6 +230,9 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%changelog
+* Fri Mar 9 2018 Remi Collet <remi@remirepo.net> - 8.6.3-1
+- Update to 8.6.3
+
* Thu Feb 1 2018 Remi Collet <remi@remirepo.net> - 8.6.2-1
- Update to 8.6.2