summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec675
1 files changed, 557 insertions, 118 deletions
diff --git a/vips.spec b/vips.spec
index 5635951..258fc80 100644
--- a/vips.spec
+++ b/vips.spec
@@ -7,87 +7,161 @@
#
# Please preserve changelog entries
#
-%global vips_version_base 8.9
-%global vips_version %{vips_version_base}.1
+%global vips_version_base 8.15
+%global vips_version %{vips_version_base}.2
%global vips_soname_major 42
-#global vips_prever rc4
-%global vips_tarver %{vips_version}%{?vips_prever:-%{vips_prever}}
+#global vips_prever rc2
+%global vips_tagver %{vips_version}%{?vips_prever:-%{vips_prever}}a
%if 0%{?fedora} || 0%{?rhel} >= 8
-%global with_doc 1
+%bcond_without doc
%else
-%global with_doc 0
+%bcond_with doc
+%endif
+
+%if 0%{?fedora} || 0%{?rhel} >= 9
+%bcond_without highway
+%else
+%bcond_with highway
%endif
%if 0%{?fedora} || 0%{?rhel} >= 8
-%global with_libimagequant 1
+%bcond_without libimagequant
+%bcond_without libcgif
+%else
+%bcond_with libimagequant
+%bcond_with libcgif
+%endif
+
+%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
+%bcond_without openjpeg2
+%else
+# disabled by default
+# as vips pulls poppler (libopenjpeg) and IM (libopenjp2)
+# so vips segfaults in various place
+# also see https://github.com/libvips/libvips/pull/2305
+%bcond_with openjpeg2
+%endif
+
+%if 0%{?fedora}
+%bcond_without libspng
+%bcond_without niftic
%else
-%global with_libimagequant 0
+%bcond_with libspng
+%bcond_with niftic
%endif
-# from mock config, when rpmfusion enabled
-%global with_libheif 0%{?_with_rpmfusion:1}
+# 3 builds needed to get the full stack
+# NOTICE: for EL-7, epel-rpm-macros needed (clean root_cache before build with el7xr config)
+# --without heif --without im7 --with im6
+# --without heif --without im7 --with gm
+# --with heif --with im7
+%bcond_with im6
+%bcond_without im7
+%bcond_with gm
-%if %{with_libheif}
-Name: vips-full
-# Keep vips-full release > vips release
-Release: 4%{?dist}
+%bcond_without tests
+
+%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
+%bcond_without jxl
%else
-Name: vips
-Release: 3%{?dist}
+%bcond_with jxl
%endif
-Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
-Summary: C/C++ library for processing large images
-License: LGPLv2+
-URL: https://libvips.github.io/libvips/
-Source0: https://github.com/libvips/libvips/releases/download/v%{vips_version}%{?vips_prever:-%{vips_prever}}/vips-%{vips_tarver}.tar.gz
+# from fedora/epel repository, or from rpmfusion when enabled (from mock config)
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || 0%{?_with_rpmfusion:1}
+%bcond_without heif
+%else
+%bcond_with heif
+%endif
-BuildRequires: pkgconfig(glib-2.0)
-BuildRequires: pkgconfig(expat)
-BuildRequires: pkgconfig(fftw3)
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 7
-BuildRequires: ImageMagick-devel
+Name: vips
+Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
+Release: 1%{?dist}
+Summary: C/C++ library for processing large images
+
+License: LGPLv2+
+URL: https://libvips.github.io/libvips/
+Source0: https://github.com/libvips/libvips/releases/download/v%{vips_tagver}/vips-%{vips_version}.tar.xz
+
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: meson >= 0.55
+BuildRequires: pkgconfig
+BuildRequires: gettext
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(expat)
+BuildRequires: pkgconfig(fftw3)
+BuildRequires: pkgconfig(gobject-introspection-1.0)
+%if %{with highway}
+BuildRequires: pkgconfig(libhwy) >= 1.0.5
%else
-# Ensure we use version 6 (same as imagick ext).
-BuildRequires: ImageMagick6-devel
-%endif
-BuildRequires: pkgconfig(gobject-introspection-1.0)
-BuildRequires: pkgconfig(orc-0.4)
-BuildRequires: pkgconfig(lcms2)
-BuildRequires: pkgconfig(OpenEXR)
-BuildRequires: pkgconfig(matio)
-BuildRequires: pkgconfig(cfitsio)
-BuildRequires: pkgconfig(pangoft2)
-BuildRequires: pkgconfig(zlib)
-BuildRequires: pkgconfig(libpng) >= 1.2.9
-BuildRequires: pkgconfig(libtiff-4)
+BuildRequires: pkgconfig(orc-0.4) >= 0.4.11
+%endif
+BuildRequires: pkgconfig(lcms2)
+BuildRequires: pkgconfig(OpenEXR) >= 1.2.2
+%if 0%{?fedora} >= 35
+BuildRequires: pkgconfig(Imath)
+%endif
+# https://bugzilla.redhat.com/2034536 - missing in EPEL-9
+%if 0%{?rhel} < 9
+BuildRequires: pkgconfig(matio)
+%endif
+BuildRequires: pkgconfig(cfitsio)
+BuildRequires: pkgconfig(pangoft2)
+BuildRequires: pkgconfig(zlib)
+BuildRequires: pkgconfig(libtiff-4)
# Ensure we use libwebp7 on EL-7
# upstream requires 0.6
-BuildRequires: pkgconfig(libwebp) > 1
-BuildRequires: pkgconfig(libexif)
-BuildRequires: pkgconfig(openslide)
-BuildRequires: pkgconfig(libgsf-1)
-BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.3
-BuildRequires: pkgconfig(poppler-glib)
-BuildRequires: pkgconfig(libjpeg)
-%if %{with_libheif}
-BuildRequires: pkgconfig(libheif)
+BuildRequires: pkgconfig(libwebp) > 1
+BuildRequires: pkgconfig(libexif)
+BuildRequires: pkgconfig(libarchive) >= 3
+BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.3
+BuildRequires: pkgconfig(libjpeg)
+%if %{with libspng}
+BuildRequires: pkgconfig(spng) >= 0.7
+%else
+BuildRequires: pkgconfig(libpng) >= 1.2.9
+%endif
+%if %{with niftic}
+BuildRequires: nifticlib-devel
+%endif
+%if %{with openjpeg2}
+BuildRequires: pkgconfig(libopenjp2) >= 2.4
%endif
-%if %{with_libimagequant}
-#BuildRequires: pkgconfig(imagequant) TODO only in 2.12+
-BuildRequires: libimagequant-devel
+%if %{with libimagequant}
+#BuildRequires: pkgconfig(imagequant) TODO only in 2.12+
+BuildRequires: libimagequant-devel
+%endif
+%if %{with libcgif}
+BuildRequires: pkgconfig(cgif)
+%endif
+%if %{with tests}
+# bc command used in test suite
+BuildRequires: bc
%endif
-BuildRequires: giflib-devel
-BuildRequires: pkgconfig(gthread-2.0)
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig gettext
+# Not available as system library
+Provides: bundled(libnsgif)
-%if %{with_libheif}
-Conflicts: vips < %{version}-%{release}
-Provides: vips = %{version}-%{release}
-Provides: vips%{?_isa} = %{version}-%{release}
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+Recommends: %{name}-heif
+%else
+Suggests: %{name}-heif
+%endif
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+Recommends: %{name}-magick-im7
+%else
+# im6 is temporarily recommended for smooth upgrade from 8.10
+# user can remove / replace with alternative
+Recommends: %{name}-magick-im6
+%endif
+Recommends: %{name}-openslide
+Recommends: %{name}-poppler
+%else
+Requires: %{name}-openslide
+Requires: %{name}-poppler
%endif
@@ -99,21 +173,24 @@ with color.
This package should be installed if you want to use a program compiled
against VIPS.
+Additional image formats are supported in additional optional packages:
+%if %{with jxl}
+* %{name}-jxl
+%endif
+* %{name}-heif
+* %{name}-openslide
+* %{name}-poppler
+* %{name}-magick-im6 using ImageMagick version 6
+* %{name}-magick-im7 using ImageMagick version 7
+* %{name}-magick-gm using GraphicsMagick
+
+
%package devel
-Summary: Development files for %{name}
-Requires: libjpeg-devel%{?_isa} libtiff-devel%{?_isa} zlib-devel%{?_isa}
-Requires: %{name}%{?_isa} = %{version}-%{release}
-%if %{with_libheif}
-Conflicts: vips-devel < %{version}-%{release}
-%endif
-# for consistency, same version at buildtime and runtime
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 7
-Requires: ImageMagick-devel
-%else
-# Ensure we use version 6 (same as imagick ext).
-Requires: ImageMagick6-devel
-%endif
+Summary: Development files for %{name}
+Requires: libjpeg-devel%{?_isa} libtiff-devel%{?_isa} zlib-devel%{?_isa}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Obsoletes: vips-full-devel < 8.11
%description devel
The %{name}-devel package contains the header files and
@@ -122,78 +199,208 @@ contains a C++ API and development documentation.
%package tools
-Summary: Command-line tools for %{name}
-Requires: %{name}%{?_isa} = %{version}-%{release}
-%if %{with_libheif}
-Conflicts: vips-tools < %{version}-%{release}
-%endif
+Summary: Command-line tools for %{name}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Obsoletes: vips-full-tools < 8.11
%description tools
The %{name}-tools package contains command-line tools for working with VIPS.
-%if %{with_doc}
+%if %{with doc}
%package doc
-Summary: Documentation for %{name}
-BuildRequires: swig gtk-doc
-Conflicts: %{name} < %{version}-%{release}, %{name} > %{version}-%{release}
-%if %{with_libheif}
-Conflicts: vips-doc < %{version}-%{release}
-%endif
+Summary: Documentation for %{name}
+BuildRequires: gtk-doc
+BuildRequires: doxygen
+Conflicts: %{name} < %{version}-%{release}, %{name} > %{version}-%{release}
+Obsoletes: vips-full-doc < 8.11
%description doc
The %{name}-doc package contains extensive documentation about VIPS in both
HTML and PDF formats.
%endif
+%if %{with jxl}
+%package jxl
+Summary: JPEG-XL support for %{name}
+BuildRequires: pkgconfig(libjxl) >= 0.6
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Supplements: %{name}
-%prep
-%setup -q -n vips-%{vips_version}
+%description jxl
+The %{name}-jxl package contains the Jxl module for VIPS.
+%endif
-# make the version string consistent for multiarch
-export FAKE_BUILD_DATE=$(date -r %{SOURCE0})
-sed -i "s/\\(VIPS_VERSION_STRING=\\)\$VIPS_VERSION-\`date\`/\\1\"\$VIPS_VERSION-$FAKE_BUILD_DATE\"/g" \
- configure
-unset FAKE_BUILD_DATE
+%if %{with heif}
+%package heif
+Summary: Heif support for %{name}
+BuildRequires: pkgconfig(libheif) >= 1.4.0
+%if 0%{?rhel} == 7
+# ensure we use our on EL-7
+Requires: libheif%{?_isa} >= 1.4.0
+%endif
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+# x265 HEVC encoder from RPMFusion
+Recommends: libheif-freeworld%{?_isa}
+%endif
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Obsoletes: vips-full < 8.11
+
+%description heif
+The %{name}-heif package contains the Heif module for VIPS.
+%endif
+
+%package openslide
+Summary: OpenSlide support for %{name}
+BuildRequires: pkgconfig(openslide) >= 3.3.0
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description openslide
+The %{name}-openslide package contains the OpenSlide module for VIPS.
+
+%package poppler
+Summary: Poppler support for %{name}
+BuildRequires: pkgconfig(poppler-glib)
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description poppler
+The %{name}-poppler package contains the Poppler module for VIPS.
+
+%if %{with im6}
+%package magick-im6
+Summary: Magick support for %{name} using ImageMagick6
+BuildRequires: ImageMagick6-devel
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if 0%{?fedora} >= 34 && 0%{?fedora} < 38
+Obsoletes: %{name}-magick < %{version}-%{release}
+%endif
+Provides: %{name}-magick = %{version}-%{release}
+Provides: %{name}-magick%{?_isa} = %{version}-%{release}
+Conflicts: %{name}-magick-im7
+Conflicts: %{name}-magick-gm
+
+%description magick-im6
+The %{name}-magick-im6 package contains the Magick module for VIPS
+using ImageMagick version 6.
+%endif
+
+%if %{with im7}
+%package magick-im7
+Summary: Magick support for %{name} using ImageMagick7
+BuildRequires: ImageMagick7-devel
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+Obsoletes: %{name}-magick < %{version}-%{release}
+%endif
+Provides: %{name}-magick = %{version}-%{release}
+Provides: %{name}-magick%{?_isa} = %{version}-%{release}
+Conflicts: %{name}-magick-im6
+Conflicts: %{name}-magick-gm
+
+%description magick-im7
+The %{name}-magick-im7 package contains the Magick module for VIPS
+using ImageMagick version 7.
+%endif
+
+%if %{with gm}
+%package magick-gm
+Summary: Magick support for %{name} using GraphicsMagick
+BuildRequires: GraphicsMagick-devel
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Provides: %{name}-magick = %{version}-%{release}
+Provides: %{name}-magick%{?_isa} = %{version}-%{release}
+Conflicts: %{name}-magick-im6
+Conflicts: %{name}-magick-im7
+
+%description magick-gm
+The %{name}-magick-gm contains the Magick module for VIPS
+using GraphicsMagick.
+%endif
-# Avoid setting RPATH to /usr/lib64 on 64-bit builds
-# The DIE_RPATH_DIE trick breaks the build wrt gobject-introspection
-sed -i 's|sys_lib_dlsearch_path_spec="|sys_lib_dlsearch_path_spec="/%{_lib} %{_libdir} |' configure
+
+%prep
+%if %{with gm}
+%if %{with im7}
+: Cannot enable GraphicsMagick and ImageMagick7
+exit 1
+%endif
+%if %{with im6}
+: Cannot enable GraphicsMagick and ImageMagick6
+exit 1
+%endif
+%endif
+
+%setup -q -n vips-%{vips_version}
%build
# Upstream recommends enabling auto-vectorization of inner loops:
-# https://github.com/jcupitt/libvips/pull/212#issuecomment-68177930
+# https://github.com/libvips/libvips/pull/212#issuecomment-68177930
export CFLAGS="%{optflags} -ftree-vectorize"
export CXXFLAGS="%{optflags} -ftree-vectorize"
-%configure \
-%if %{with_libheif}
- --with-heif \
+# TODO remove `-Dnifti-prefix-dir=/usr`:
+# https://github.com/libvips/libvips/pull/2882#issuecomment-1165686117
+# https://bugzilla.redhat.com/2099283
+# TODO remove `-Dmatio=disabled`:
+# https://bugzilla.redhat.com/2034536
+%meson \
+%if 0%{?rhel} >= 9
+ -Dmatio=disabled \
+%endif
+%if %{without heif}
+ -Dheif=disabled \
+%endif
+%if %{without libimagequant}
+ -Dimagequant=disabled \
+ -Dquantizr=disabled \
+%endif
+%if %{without libcgif}
+ -Dcgif=disabled \
+%endif
+%if %{without openjpeg2}
+ -Dopenjpeg=disabled \
+%endif
+%if %{without libspng}
+ -Dspng=disabled \
+%endif
+%if %{without jxl}
+ -Djpeg-xl=disabled \
+%endif
+%if %{without niftic}
+ -Dnifti=disabled \
%else
- --without-heif \
+ -Dnifti-prefix-dir=/usr \
+%endif
+%if %{with doc}
+ -Ddoxygen=true \
+ -Dgtk_doc=true \
%endif
-%if %{with_doc}
- --enable-gtk-doc \
+%if %{with gm}
+ -Dmagick-package=GraphicsMagick \
%endif
- --disable-static
-make %{?_smp_mflags}
+%if %{with highway}
+ -Dhighway=enabled \
+%else
+ -Dhighway=disabled \
+%endif
+ -Dpdfium=disabled \
+ %{nil}
+%meson_build
%install
-make install DESTDIR=%{buildroot}
-find %{buildroot} \( -name '*.la' -o -name '*.a' \) -exec rm -f {} ';'
-
-# delete doc (we will get it later with %%doc)
-rm -rf %{buildroot}%{_datadir}/doc/vips
-
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipsprofile
-%endif
+%meson_install
# locale stuff
%find_lang vips%{vips_version_base}
+%if %{with tests}
+%check
+%meson_test
+%endif
+
+
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
@@ -201,10 +408,11 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%files -f vips%{vips_version_base}.lang
-%doc AUTHORS NEWS THANKS ChangeLog
-%license COPYING
+%doc ChangeLog README.md
+%license LICENSE
%{_libdir}/*.so.%{vips_soname_major}*
%{_libdir}/girepository-1.0
+%dir %{_libdir}/vips-modules-%{vips_version_base}
%files devel
@@ -212,7 +420,6 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%{_libdir}/*.so
%{_libdir}/pkgconfig/*
%{_datadir}/gir-1.0
-%{_datadir}/gtk-doc
%files tools
@@ -220,14 +427,246 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%{_mandir}/man1/*
-%if %{with_doc}
+%if %{with doc}
%files doc
-%doc doc/html
-%license COPYING
+%{_datadir}/gtk-doc
+%{_docdir}/vips-doc/html
+%license LICENSE
+%endif
+
+
+%files openslide
+%{_libdir}/vips-modules-%{vips_version_base}/vips-openslide.so
+
+%files poppler
+%{_libdir}/vips-modules-%{vips_version_base}/vips-poppler.so
+
+%if %{with jxl}
+%files jxl
+%{_libdir}/vips-modules-%{vips_version_base}/vips-jxl.so
+%endif
+
+%if %{with heif}
+%files heif
+%{_libdir}/vips-modules-%{vips_version_base}/vips-heif.so
+%endif
+
+%if %{with im6}
+%files magick-im6
+%{_libdir}/vips-modules-%{vips_version_base}/vips-magick.so
+%endif
+
+%if %{with im7}
+%files magick-im7
+%{_libdir}/vips-modules-%{vips_version_base}/vips-magick.so
+%endif
+
+%if %{with gm}
+%files magick-gm
+%{_libdir}/vips-modules-%{vips_version_base}/vips-magick.so
%endif
%changelog
+* Wed Mar 13 2024 Remi Collet <remi@remirepo.net> - 8.15.2-1
+- update to 8.15.2
+
+* Mon Jan 8 2024 Remi Collet <remi@remirepo.net> - 8.15.1-2
+- add weak dependency on libheif-freeworld from RPMFusion (Fedora and EL-9)
+
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 8.15.1-1
+- update to 8.15.1
+
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 8.15.0-1
+- update to 8.15.0
+
+* Mon Nov 6 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc2-1
+- update to 8.15.0rc2
+- drop patch merged upstream
+
+* Thu Oct 19 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc1-1
+- update to 8.15.0rc1
+- use libhwy instead of liborc on Fedora and EL-9
+- use libarchive instead of libgsf
+- open https://github.com/libvips/libvips/pull/3722
+ Revert "raise librsvg minver to 2.48
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 8.14.5-1
+- update to 8.14.5
+
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 8.14.4-1
+- update to 8.14.4
+
+* Fri Jul 21 2023 Remi Collet <remi@remirepo.net> - 8.14.3-1
+- update to 8.14.3
+
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 8.14.2-1
+- update to 8.14.2
+
+* Mon Jan 9 2023 Remi Collet <remi@remirepo.net> - 8.14.1-1
+- update to 8.14.1
+
+* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 8.14.0-1
+- update to 8.14.0
+- open https://github.com/libvips/libvips/issues/3254 ABI/API compat
+- open https://github.com/libvips/libvips/issues/3255 @VIPS_VERSION@ in doc
+- add https://github.com/libvips/libvips/issues/2879#issuecomment-1368742798
+ 8.14.0 is no more buildable on EL-7
+
+* Wed Dec 28 2022 Kleis Auke Wolthuizen <info@kleisauke.nl> - 8.14.0~rc1-1
+- Update to 8.14.0-rc1
+- Migrate build to Meson
+- Remove gtk-doc docs from vips-devel
+
+* Mon Nov 21 2022 Remi Collet <remi@remirepo.net> - 8.13.3-2
+- EL-9 rebuild for new libjxl
+
+* Wed Nov 2 2022 Remi Collet <remi@remirepo.net> - 8.13.3-1
+- update to 8.13.3
+
+* Thu Sep 29 2022 Remi Collet <remi@remirepo.net> - 8.13.2-1
+- update to 8.13.2
+
+* Sun Sep 4 2022 Remi Collet <remi@remirepo.net> - 8.13.1-1
+- update to 8.13.1
+
+* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 8.13.0-1
+- update to 8.13.0
+
+* Tue Jul 12 2022 Remi Collet <remi@remirepo.net> - 8.13.0~rc2-1
+- update to 8.13.0rc2
+
+* Mon Jun 20 2022 Remi Collet <remi@remirepo.net> - 8.13.0~rc1-2
+- fix EL-7 build using upstream fix
+ but see https://github.com/libvips/libvips/issues/2878#issuecomment-1160380569
+
+* Mon Jun 20 2022 Remi Collet <remi@remirepo.net> - 8.13.0~rc1-1
+- update to 8.13.0rc1
+- Enable openjpeg2 usage on RHEL >= 9
+- Increase minimum required version of libspng to 0.7 for PNG write support
+- Remove libpng in favor of libspng (if possible)
+- Remove dependency on deprecated gthread-2.0
+- open https://github.com/libvips/libvips/issues/2878 broken build on EL-7
+- open https://github.com/libvips/libvips/issues/2877 libniftiio detection
+- open https://github.com/libvips/libvips/issues/2876 unusable archive
+- open https://github.com/libvips/libvips/issues/2879 please keep autotools
+
+* Mon Apr 25 2022 Remi Collet <remi@remirepo.net> - 8.12.2-2
+- rebuild using libheif
+
+* Tue Jan 25 2022 Remi Collet <remi@remirepo.net> - 8.12.2-1
+- update to 8.12.2
+
+* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 8.12.1-2
+- rebuild for new libjxl
+
+* Thu Nov 25 2021 Remi Collet <remi@remirepo.net> - 8.12.1-1
+- update to 8.12.1
+
+* Sat Nov 20 2021 Remi Collet <remi@remirepo.net> - 8.12.0-1
+- update to 8.12.0
+- re-enable libjxl usage
+
+* Mon Nov 15 2021 Remi Collet <remi@remirepo.net> - 8.12.0~rc1-1
+- update to 8.12.0rc1
+- enable libcgif usage
+- disable libjxl usage
+- open https://github.com/libvips/libvips/pull/2538
+ fails if library is requested and missing
+- open https://github.com/libvips/libvips/pull/2539
+ allow libjxl 0.5
+
+* Fri Nov 5 2021 Remi Collet <remi@remirepo.net> - 8.11.4-2
+- EL-9 build
+
+* Fri Sep 24 2021 Remi Collet <remi@remirepo.net> - 8.11.4-1
+- update to 8.11.4
+
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 8.11.3-2
+- add Jxl support
+- build with ImageMagick7 by default
+
+* Wed Aug 25 2021 Remi Collet <remi@remirepo.net> - 8.11.3-1
+- update to 8.11.3
+
+* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 8.11.2-2
+- rebuild with latest changes from Fedora
+
+* Mon Jul 05 2021 Benjamin Gilbert <bgilbert@backtick.net> - 8.11.2-2
+- Add doxygen C++ docs to vips-devel
+- Use arch-specific Requires in plugin subpackages
+- Provide bundled(libnsgif)
+- Drop some redundant version restrictions
+
+* Sun Jul 4 2021 Remi Collet <remi@remirepo.net> - 8.11.2-1
+- update to 8.11.2
+- drop patch merged (and improved) upstream
+
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.11.1-1
+- update to 8.11.1
+
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.11.0-1.2
+- test build for fix for bad prefix guess from
+ https://github.com/libvips/libvips/pull/2308
+- only use openjpeg2 >= 2.4 (Fedora >= 34)
+
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.11.0-1.1
+- test build using openjpeg2 2.3
+- open https://github.com/libvips/libvips/pull/2305 allow libopenjp2 2.3
+- use nifticlib on Fedora
+
+* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 8.11.0-1
+- update to 8.11.0
+
+* Sat Jun 5 2021 Remi Collet <remi@remirepo.net> - 8.11.0~rc1-1
+- update to 8.11.0rc1
+- split modules in sub-packages
+
+* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 8.10.6-3
+- rebuild for new matio (Fedora 32 to 34)
+
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 8.10.6-1
+- update to 8.10.6
+
+* Tue Mar 9 2021 Remi Collet <remi@remirepo.net> - 8.10.6~beta2-1
+- update to 8.10.6-beta2
+
+* Mon Mar 8 2021 Remi Collet <remi@remirepo.net> - 8.10.6~beta-1
+- update to 8.10.6-beta
+
+* Mon Feb 22 2021 Remi Collet <remi@remirepo.net> - 8.10.5-3
+- build against ImageMagick6 and new soname
+
+* Sun Dec 20 2020 Remi Collet <remi@remirepo.net> - 8.10.5-1
+- update to 8.10.5
+
+* Mon Dec 14 2020 Remi Collet <remi@remirepo.net> - 8.10.4-3
+- enable libspng usage on Fedora
+
+* Mon Dec 14 2020 Remi Collet <remi@remirepo.net> - 8.10.4-1
+- update to 8.10.4
+
+* Sun Dec 13 2020 Remi Collet <remi@remirepo.net> - 8.10.3-1
+- update to 8.10.3
+
+* Tue Oct 13 2020 Remi Collet <remi@remirepo.net> - 8.10.2-1
+- update to 8.10.2
+
+* Fri Sep 4 2020 Remi Collet <remi@remirepo.net> - 8.10.1-1
+- update to 8.10.1
+
+* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 8.10.0-2
+- rebuild for matio 1.5.17 in EPEL-7
+
+* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 8.10.0-1
+- update to 8.10.0
+
+* Thu Jul 16 2020 Remi Collet <remi@remirepo.net> - 8.10.0~rc1-1
+- update to 8.10.0-rc1
+
+* Tue Apr 21 2020 Remi Collet <remi@remirepo.net> - 8.9.2-1
+- update to 8.9.2
+
* Tue Apr 21 2020 Remi Collet <remi@remirepo.net> - 8.9.1-3
- build against ImageMagick on EL-7