summaryrefslogtreecommitdiffstats
path: root/libzip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libzip.spec')
-rw-r--r--libzip.spec23
1 files changed, 19 insertions, 4 deletions
diff --git a/libzip.spec b/libzip.spec
index 8c4705c..7c7182d 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -17,7 +17,7 @@ Name: %{libname}
%else
Name: %{libname}%{soname}
%endif
-Version: 1.5.1
+Version: 1.5.2
Release: 1%{?dist}
Summary: C library for reading, creating, and modifying zip archives
@@ -118,10 +118,21 @@ rm INSTALL.md
# drop skipped test which make test suite fails (cmake issue ?)
sed -e '/clone-fs-/d' -i regress/CMakeLists.txt
sed -e 's/COMMAND cmake /COMMAND cmake3 /' -i CMakeLists.txt regress/CMakeLists.txt
-%cmake3 .
+%cmake3 \
%else
-%cmake .
+%cmake . \
%endif
+ -DENABLE_COMMONCRYPTO:BOOL=OFF \
+ -DENABLE_GNUTLS:BOOL=OFF \
+ -DENABLE_MBEDTLS:BOOL=OFF \
+ -DENABLE_OPENSSL:BOOL=ON \
+ -DENABLE_WINDOWS_CRYPTO:BOOL=OFF \
+ -DENABLE_BZIP2:BOOL=ON \
+ -DBUILD_TOOLS:BOOL=ON \
+ -DBUILD_REGRESS:BOOL=ON \
+ -DBUILD_EXAMPLES:BOOL=OFF \
+ -DBUILD_DOC:BOOL=ON \
+ .
make %{?_smp_mflags}
@@ -132,7 +143,6 @@ make install DESTDIR=%{buildroot} INSTALL='install -p'
%check
%if %{with_tests}
-
make check
%else
: Test suite disabled
@@ -168,6 +178,11 @@ make check
%changelog
+* Tue Mar 12 2019 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2
+- add all explicit cmake options to ensure openssl is used
+ even in local build with other lilbraries available
+
* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 1.5.1-1
- update to 1.5.1
- drop dependency on zlib-devel and bzip2-devel no more