summaryrefslogtreecommitdiffstats
path: root/librabbitmq.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 09:46:10 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 09:46:10 +0200
commit6ce173a8b929523535a956ef37e74a015eeef6dc (patch)
tree4061780e91272a2a020b70cfcf7715a7eb01c665 /librabbitmq.spec
parent42373308308961b2be4ea0ed1cb5429c3c86d240 (diff)
v0.9.0
Diffstat (limited to 'librabbitmq.spec')
-rw-r--r--librabbitmq.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/librabbitmq.spec b/librabbitmq.spec
index ac1dc95..73508b9 100644
--- a/librabbitmq.spec
+++ b/librabbitmq.spec
@@ -10,23 +10,23 @@
# Please, preserve the changelog entries
#
-%global gh_commit caad0ef1533783729c7644a226c989c79b4c497b
+%global gh_commit 77e3805d1662034339c3c19bcdaaa62a56c1fa7e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner alanxz
%global gh_project rabbitmq-c
%global libname librabbitmq
-# soname 4 since 0.6.0 (Fedora 23) 0.7.0/4.1, 0.8.0/4.2
+# soname 4 since 0.6.0 (Fedora 23 / EL-7) 0.7.0/4.1, 0.8.0/4.2, 0.9.0/4.3
# soname 1 up to 0.5.2
%global soname 4
-%if 0%{?fedora} < 23
+%if 0%{?fedora} < 23 && 0%{?rhel} <= 7
Name: %{libname}-last
%else
Name: %{libname}
%endif
Summary: Client library for AMQP
-Version: 0.8.0
-Release: 7%{?dist}
+Version: 0.9.0
+Release: 1%{?dist}
License: MIT
URL: https://github.com/alanxz/rabbitmq-c
@@ -34,7 +34,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{g
BuildRequires: gcc
BuildRequires: cmake > 2.8
-BuildRequires: popt-devel
+# https://github.com/alanxz/rabbitmq-c/issues/503
+BuildRequires: popt-devel > 1.14
BuildRequires: openssl-devel
# For man page
BuildRequires: xmlto
@@ -94,6 +95,9 @@ amqp-publish Publish a message on an AMQP server
# Copy sources to be included in -devel docs.
cp -pr examples Examples
+# This test requires a running server
+sed -e '/test_basic/d' -i tests/CMakeLists.txt
+
%build
# static lib required for tests
@@ -143,7 +147,12 @@ make test
%doc %{_mandir}/man7/librabbitmq-tools.7*
+## NOTICE: 0.8.0 available in RHEL 7.5
+
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 0.9.0-1
+- update to 0.9.0
+
* Tue Feb 20 2018 Remi Collet <remi@remirepo.net> - 0.8.0-7
- missing BR on C compiler
- drop ldconfig scriptlets