summaryrefslogtreecommitdiffstats
path: root/libmemcached-last.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libmemcached-last.spec')
-rw-r--r--libmemcached-last.spec56
1 files changed, 42 insertions, 14 deletions
diff --git a/libmemcached-last.spec b/libmemcached-last.spec
index 2b660c7..7480277 100644
--- a/libmemcached-last.spec
+++ b/libmemcached-last.spec
@@ -9,10 +9,10 @@
#
# Please, preserve the changelog entries
#
-# Lot of tests are broken making test suite unusable
-%bcond_with tests
-%global libname libmemcached
+%bcond_without tests
+
+%global libname libmemcached
# libmemcached >= 1.0.16 have soname 11
%if 0%{?rhel} == 7
@@ -25,13 +25,13 @@ Name: %{libname}-opt
Name: %{libname}
%endif
-%global gh_commit 2f275201aac9994f7694acb67f5dee62adcb0424
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner m6w6
-%global gh_project libmemcached
+%global gh_commit 2f275201aac9994f7694acb67f5dee62adcb0424
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner m6w6
+%global gh_project libmemcached
-%global upstream_version 1.1.0
-%global upstream_prever beta1
+%global upstream_version 1.1.0
+%global upstream_prever beta1
Summary: Client library and command line tools for memcached server
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -41,18 +41,23 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
Patch0: https://patch-diff.githubusercontent.com/raw/m6w6/libmemcached/pull/101.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/m6w6/libmemcached/pull/102.patch
+Patch2: https://patch-diff.githubusercontent.com/raw/m6w6/libmemcached/pull/104.patch
-BuildRequires: gcc
-BuildRequires: gcc-c++
%if 0%{?rhel} == 7
BuildRequires: cmake3 >= 3.9
+%global dtsenable source /opt/rh/devtoolset-7/enable
+BuildRequires: devtoolset-7-toolchain
+BuildRequires: python-sphinx
%else
BuildRequires: cmake >= 3.9
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: python3-sphinx
%endif
BuildRequires: cyrus-sasl-devel
BuildRequires: flex
BuildRequires: bison
-BuildRequires: python-sphinx
BuildRequires: memcached
BuildRequires: systemtap-sdt-devel
BuildRequires: libevent-devel > 2
@@ -95,6 +100,8 @@ This package contains the header files and development libraries
for %{name}. If you like to develop programs using %{name},
you will need to install %{name}-devel.
+Documentation: https://m6w6.github.io/libmemcached/
+
%package libs
Summary: %{libname} libraries
@@ -117,8 +124,18 @@ This package is designed to be installed beside %{libname}.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .pr101
+%patch1 -p1 -b .pr102
+%patch2 -p1 -b .pr104
+
+# drop test hanging in mock
+if [ "$(id -un)" != "remi" ]; then
+rm test/tests/memcached/sasl.cpp
+fi
+
%build
+%{?dtsenable}
+
%if 0%{?rhel} == 7
%cmake3 \
%else
@@ -126,6 +143,7 @@ This package is designed to be installed beside %{libname}.
%endif
-DBUILD_TESTING:BOOL=ON \
-DBUILD_DOCS_MAN:BOOL=ON \
+ -DBUILD_DOCS_MANGZ:BOOL=OFF \
-DENABLE_SASL:BOOL=ON \
-DENABLE_DTRACE:BOOL=ON \
-DENABLE_HASH_HSIEH:BOOL=ON \
@@ -142,6 +160,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
%if 0%{?cmake_install:1}
%cmake_install
%else
@@ -159,7 +179,11 @@ rm -r %{buildroot}%{_datadir}/doc/libmemcached/
%check
%if %{with tests}
: Run test suite
+%if 0%{?ctest:1}
+%ctest
+%else
make test
+%endif
%else
: Skip test suite
%endif
@@ -223,10 +247,14 @@ make test
%{_mandir}/man3/memcached*
%{_mandir}/man3/hashkit*
+
%changelog
* Wed Dec 23 2020 Remi Collet <remi@remirepo.net> - 1.1.0~beta1-2
-- add upstream patches and from
- https://github.com/m6w6/libmemcached/pull/101
+- add patches from upstream and from
+ https://github.com/m6w6/libmemcached/pull/101 fix so version
+ https://github.com/m6w6/libmemcached/pull/102 fix for old sphinx
+ https://github.com/m6w6/libmemcached/pull/104 fix 32-bit
+- enable test suite
* Tue Dec 22 2020 Remi Collet <remi@remirepo.net> - 1.1.0~beta1-1
- update to 1.1.0-beta1