summaryrefslogtreecommitdiffstats
path: root/icu-last.spec
diff options
context:
space:
mode:
Diffstat (limited to 'icu-last.spec')
-rw-r--r--icu-last.spec138
1 files changed, 105 insertions, 33 deletions
diff --git a/icu-last.spec b/icu-last.spec
index 21282a8..f2a2174 100644
--- a/icu-last.spec
+++ b/icu-last.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for icu62
+# remirepo spec file for icu73
# renamed for parallel installation, from:
#
# Fedora spec file for icu
@@ -10,41 +10,64 @@
#
%global srcname icu
-%global soname 62
+%global soname 73
+%global subver 2
-# Regression tests take a long time, you can skip 'em with this
-%{!?runselftest: %{expand: %%global runselftest 1}}
+%bcond_without tests
+
+# Set to 0 when upgrading to a new ICU release that contains up-to-date timezone data.
+# (or update the timezone data update..).
+%global use_tzdata_update 0
+# Adjust to version major; used in tzdata update.
+%global icu_major 73
+
+%if 0%{?fedora} == 34 || 0%{?rhel} == 9
+# rhbz#2003359 crash in umtx_initImplPreInit() from unorm_normalize()
+%global _lto_cflags %nil
+%endif
Name: icu%{soname}
-Version: %{soname}.1
-Release: 3%{?dist}
+Version: %{soname}.%{subver}
+Release: 1%{?dist}
Summary: International Components for Unicode
-License: MIT and UCD and Public Domain
+License: Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
URL: http://site.icu-project.org/
-Source0: http://download.icu-project.org/files/icu4c/%{soname}.1/icu4c-%{soname}_1-src.tgz
-Source1: icu-config.sh
+Source0: https://github.com/unicode-org/icu/releases/download/release-%{soname}-%{subver}/icu4c-%{soname}_%{subver}-src.tgz
+%if 0%{?use_tzdata_update}
+Source1: https://github.com/unicode-org/icu/releases/download/release-%{soname}-%{subver}/icu4c-%{soname}_%{subver}-data.zip
+Source2: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/metaZones.txt
+Source3: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/timezoneTypes.txt
+Source4: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/windowsZones.txt
+Source5: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/zoneinfo64.txt
+%endif
+Source10: icu-config.sh
-BuildRequires: doxygen, autoconf >= 2.69, python2
+BuildRequires: doxygen, autoconf >= 2.69, python3
+%if 0%{?rhel} == 7
+%global dtsenable source /opt/rh/devtoolset-10/enable
+BuildRequires: devtoolset-10-toolchain
+%else
BuildRequires: gcc
BuildRequires: gcc-c++
+%endif
+BuildRequires: make
-Requires: lib%{name}%{?_isa} = %{version}-%{release}
+Requires: lib%{name}%{?_isa} = %{version}-%{release}
Conflicts: %{srcname}-last < %{version}
+Conflicts: %{srcname}62 < %{version}
+Conflicts: %{srcname}65 < %{version}
Conflicts: %{srcname} < %{version}
Provides: %{srcname} = %{version}-%{release}
Provides: %{srcname}%{?_isa} = %{version}-%{release}
Patch4: gennorm2-man.patch
Patch5: icuinfo-man.patch
-Patch6: rhbz1646703-icu4c-ICU-20246-integer-overflow.patch
-Patch100: armv7hl-disable-tests.patch
%description
Tools and utilities for developing with icu.
%package -n lib%{name}
Summary: International Components for Unicode - libraries
-Group: System Environment/Libraries
%description -n lib%{name}
The International Components for Unicode (ICU) libraries provide
@@ -62,10 +85,11 @@ This package is designed to be installable beside lib%{srcname}.
%package -n lib%{name}-devel
Summary: Development files for International Components for Unicode
-Group: Development/Libraries
Requires: lib%{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
Conflicts: lib%{srcname}-last-devel < %{version}
+Conflicts: lib%{srcname}62-devel < %{version}
+Conflicts: lib%{srcname}65-devel < %{version}
Conflicts: lib%{srcname}-devel < %{version}
Provides: lib%{srcname}-devel = %{version}-%{release}
Provides: lib%{srcname}-devel%{?_isa} = %{version}-%{release}
@@ -75,35 +99,44 @@ Includes and definitions for developing with icu.
%package -n lib%{name}-doc
Summary: Documentation for International Components for Unicode
-Group: Documentation
BuildArch: noarch
Conflicts: lib%{srcname}-last-doc < %{version}
+Conflicts: lib%{srcname}62-doc < %{version}
+Conflicts: lib%{srcname}65-doc < %{version}
Conflicts: lib%{srcname}-doc < %{version}
Provides: lib%{srcname}-doc = %{version}-%{release}
%description -n lib%{name}-doc
%{summary}.
-%{!?endian: %global endian %(%{__python} -c "import sys;print (0 if sys.byteorder=='big' else 1)")}
-# " this line just fixes syntax highlighting for vim that is confused by the above and continues literal
-
%prep
%setup -q -n %{srcname}
-%patch4 -p1 -b .gennorm2-man.patch
-%patch5 -p1 -b .icuinfo-man.patch
-%patch6 -p2 -b .rhbz1646703-icu4c-ICU-20246-integer-overflow.patch
-%ifarch armv7hl
-%patch100 -p1 -b .armv7hl-disable-tests.patch
+%patch -P4 -p1 -b .gennorm2-man.patch
+%patch -P5 -p1 -b .icuinfo-man.patch
+
+%if 1
+sed -e '/SELFCHECK=1/d' -i source/Makefile.in
+%endif
+
+%if 0%{?use_tzdata_update}
+pushd source
+unzip -o %{SOURCE1}
+rm -f data/in/icudt%{icu_major}l.dat
+cp -v -f %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} data/misc
+popd
%endif
+
%build
+%{?dtsenable}
+gcc --version
+
pushd source
autoconf
CFLAGS='%optflags -fno-strict-aliasing'
CXXFLAGS='%optflags -fno-strict-aliasing'
-# Endian: BE=0 LE=1
-%if ! 0%{?endian}
+%if 0
CPPFLAGS='-DU_IS_BIG_ENDIAN=1'
%endif
@@ -132,6 +165,8 @@ make %{?_smp_mflags} VERBOSE=1
make %{?_smp_mflags} doc
%install
+%{?dtsenable}
+
rm -rf $RPM_BUILD_ROOT source/__docs
make %{?_smp_mflags} -C source install DESTDIR=$RPM_BUILD_ROOT
make %{?_smp_mflags} -C source install-doc docdir=__docs
@@ -140,23 +175,26 @@ chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
cd $RPM_BUILD_ROOT%{_bindir}
mv icu-config icu-config-%{__isa_bits}
)
-install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/icu-config
+install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/icu-config
+%if %{with tests}
%check
+%{?dtsenable}
+
+# ignore test
+sed -e '/TestHebrewCalendarInTemporalLeapYear/s:TESTCASE_AUTO://TESTCASE_AUTO:' \
+ -i source/test/intltest/caltest.cpp
+
# test to ensure that -j(X>1) didn't "break" man pages. b.f.u #2357
if grep -q @VERSION@ source/tools/*/*.8 source/tools/*/*.1 source/config/*.1; then
exit 1
fi
-%ifarch i686
-# F26 since the mass rebuild in 2017-Feb fails a check, ignore error. TODO: find cause / disable only one.
-make %{?_smp_mflags} -C source check ||:
-%else
make %{?_smp_mflags} -C source check
-%endif
# log available codes
pushd source
LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
+%endif
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
@@ -175,16 +213,18 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%{_bindir}/gencnval
%{_bindir}/gendict
%{_bindir}/genrb
+%{_bindir}/icuexportdata
%{_bindir}/makeconv
%{_bindir}/pkgdata
%{_bindir}/uconv
%{_sbindir}/*
%{_mandir}/man1/derb.1*
+%{_mandir}/man1/genbrk.1*
%{_mandir}/man1/gencfu.1*
%{_mandir}/man1/gencnval.1*
%{_mandir}/man1/gendict.1*
%{_mandir}/man1/genrb.1*
-%{_mandir}/man1/genbrk.1*
+%{_mandir}/man1/icuexportdata.1*
%{_mandir}/man1/makeconv.1*
%{_mandir}/man1/pkgdata.1*
%{_mandir}/man1/uconv.1*
@@ -219,6 +259,38 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%changelog
+* Mon Oct 30 2023 Remi Collet <remi@remirepo.net> - 73.2-1
+- update to 73.2 (from F39)
+
+* Fri Apr 14 2023 Remi Collet <remi@remirepo.net> - 72.1-1
+- update to 72.1 (from F38)
+
+* Fri Oct 21 2022 Remi Collet <remi@remirepo.net> - 71.1-2
+- Update timezone data to 2022b
+
+* Tue Aug 16 2022 Remi Collet <remi@remirepo.net> - 71.1-1
+- update to 71.1 (from F37)
+
+* Tue Jul 26 2022 Remi Collet <remi@remirepo.net> - 69.1-4
+- Update timezone data to 2022a
+
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 69.1-3
+- EL-9 build
+
+* Fri Oct 1 2021 Remi Collet <remi@remirepo.net> - 69.1-2
+- rebuild with GCC 10
+
+* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 69.1-1
+- update to 69.1
+
+* Wed Jul 1 2020 Remi Collet <remi@remirepo.net> - 65.1-1
+- update to 65.1
+ https://github.com/remicollet/remirepo/issues/153
+
+* Thu May 7 2020 Remi Collet <remi@remirepo.net> - 62.2-1
+- update to 62.2
+ https://github.com/remicollet/remirepo/issues/149
+
* Thu Feb 7 2019 Pavel Podkorytov <pod.pavel@gmail.com> - 62.1-3
- backport FEDORA-29 changes
- rename "libicu-last" to "libicu62"