From 074373e5090cbdff8096ee77735f3931a193defb Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Tue, 15 Nov 2016 17:12:31 +0100
Subject: glpi: drop runtime dep. on guzzle

---
 composer-dev.json          |  4 +++-
 glpi-dev.spec              | 13 +++++++++----
 glpi-fedora-autoloader.php |  2 --
 3 files changed, 12 insertions(+), 7 deletions(-)

diff --git a/composer-dev.json b/composer-dev.json
index 96732ab..2bce0b2 100644
--- a/composer-dev.json
+++ b/composer-dev.json
@@ -19,7 +19,6 @@
         "ext-gd": "*",
         "ext-zlib": "*",
         "ext-curl": "*",
-        "guzzlehttp/guzzle": "~5",
         "ircmaxell/password-compat": "~1.0.0",
         "jasig/phpcas": "~1.3.0",
         "iamcal/lib_autolink": "~1.7",
@@ -35,6 +34,9 @@
         "michelf/php-markdown": "^1.6",
         "true/punycode": "^2.1"
     },
+    "require-dev": {
+        "guzzlehttp/guzzle": "~5"
+    },
     "suggest": {
         "ext-ldap": "Used ot provide LDAP authentication and synchronization",
         "ext-imap": "Used for collection from IMAP"
diff --git a/glpi-dev.spec b/glpi-dev.spec
index 01e1d64..a5f9d6a 100644
--- a/glpi-dev.spec
+++ b/glpi-dev.spec
@@ -44,7 +44,7 @@
 Name:           %{gh_project}
 Version:        9.1.1
 %global schema  9.1.1
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        Free IT asset management software
 Summary(fr):    Gestion Libre de Parc Informatique
 
@@ -130,8 +130,6 @@ Requires:       php-htmLawed
 Requires:       php-composer(zendframework/zend-cache)  >= 2.4
 Requires:       php-composer(zendframework/zend-i18n)   >= 2.4
 Requires:       php-composer(zendframework/zend-loader) >= 2.4
-Requires:       php-composer(guzzlehttp/guzzle)         >= 5
-Requires:       php-composer(guzzlehttp/guzzle)         <  6
 Requires:       php-composer(jasig/phpcas)              >= 1.3
 Requires:       php-composer(iamcal/lib_autolink)       >= 1.7
 Requires:       php-composer(sabre/vobject)             >= 3.4
@@ -319,6 +317,12 @@ RET=0
 : Hack for vendor
 sed -e '/Development dependencies/s:^://:' -i tests/bootstrap.php
 
+: Add developement dependecies
+cat << 'EOF' | tee -a vendor/autoload.php
+//        "guzzlehttp/guzzle": "~5"
+require_once $vendor . '/GuzzleHttp/autoload.php';
+EOF
+
 : Running a PHP server
 sed -e 's/localhost:8088/127.0.0.1:8089/' phpunit.xml.dist >phpunit.xml
 
@@ -457,8 +461,9 @@ fi
 
 
 %changelog
-* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 9.1.1-1
+* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 9.1.1-2
 - update to 9.1.1
+- drop runtime dependency on guzzlehttp/guzzle
 
 * Wed Sep 28 2016 Remi Collet <remi@fedoraproject.org> - 9.1-2
 - missing API documentation
diff --git a/glpi-fedora-autoloader.php b/glpi-fedora-autoloader.php
index bcddd1f..6012b02 100644
--- a/glpi-fedora-autoloader.php
+++ b/glpi-fedora-autoloader.php
@@ -2,8 +2,6 @@
 $vendor = '##DATADIR##/php';
 
 // Dependencies from composer.json
-// "guzzlehttp/guzzle"
-require_once $vendor . '/GuzzleHttp/autoload.php';
 // "ircmaxell/password-compat"
 // => useless for php >= 5.5
 //require_once $vendor . '/password_compat/password.php';
-- 
cgit