summaryrefslogtreecommitdiffstats
path: root/glpi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'glpi.spec')
-rw-r--r--glpi.spec29
1 files changed, 9 insertions, 20 deletions
diff --git a/glpi.spec b/glpi.spec
index b09ae08..8a03079 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit d5017d7de5636bfe5a2f13e64c685423723f7f33
+%global gh_commit a9d1277b66cd614c656faf3fd6944456ee316c55
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -52,11 +52,11 @@
%endif
Name: %{gh_project}
-%global upstream_version 9.3.0
+%global upstream_version 9.3.1
#global upstream_prever RC2
# use 9.3.0~RC2 < 9.3 (for plugin compatibility check)
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -76,8 +76,6 @@ Source6: %{name}-minify.php
# Override PHP configuration for php-fpm
Source7: %{name}-user.ini
-Patch0: https://github.com/glpi-project/glpi/commit/3391f10eacec880aebcd4297bd2658ae13473947.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php-cli
@@ -254,7 +252,7 @@ Provides: bundled(js-jquery)
Provides: bundled(js-gridstack)
Provides: bundled(js-leaflet-control-osm-geocoder)
Provides: bundled(prism)
-Provides: bundled(tiny_mce) = 4.3.13
+Provides: bundled(tiny_mce) = 4.7.13
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -301,7 +299,6 @@ techniciens grâce à une maintenance plus cohérente.
%prep
%setup -q -n %{name}-%{gh_commit}
-%patch0 -p1
grep %{upstream_version} inc/define.php
@@ -330,7 +327,7 @@ mkdir vendor
sed -e "s,##DATADIR##,%{_datadir}," \
%{SOURCE5} > vendor/autoload.php
-mv lib/tiny_mce/license.txt LICENSE.tiny_mce
+mv lib/tiny_mce/lib/license.txt LICENSE.tiny_mce
mv lib/chartist-js-0.10.1/LICENSE-MIT LICENSE.chartist-js
mv lib/chartist-plugin-legend-0.6.0/LICENSE LICENSE.chartist-plugin-legend
mv lib/chartist-plugin-tooltip-0.0.17/LICENSE LICENSE.chartist-plugin-tooltip
@@ -344,10 +341,6 @@ mv lib/leaflet/plugins/leaflet-control-osm-geocoder/LICENSE LICENSE.leaflet-cont
rm scripts/glpi_cron_*.sh
sed -i -e 's/\r//' LICENSE.tiny_mce
-for fic in LISEZMOI.txt
-do
- iconv -f ISO-8859-15 -t UTF-8 $fic >a && mv a $fic
-done
cat >cron <<EOF
# GLPI core
@@ -430,13 +423,6 @@ done >%{name}.lang
%check
%if %{with_tests}
-user=$(id -un)
-if [ "$user" = "remi" ]; then
- # See https://github.com/glpi-project/glpi/issues/4165
- # Strangely fails locally, ok in mock
- rm tests/functionnal/Auth.php
-fi
-
RET=0
: Hack for vendor
sed -e '/Development dependencies/s:^://:' -i tests/bootstrap.php
@@ -495,7 +481,7 @@ cp %{SOURCE12} inc/downstream.php
: Run upstream test suite
php scripts/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_GB || RET=1
-atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage \
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
-d tests/units || RET=1
atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
-d tests/functionnal || RET=1
@@ -600,6 +586,9 @@ fi
%changelog
+* Wed Sep 12 2018 Remi Collet <remi@remirepo.net> - 9.3.1-1
+- update to 9.3.1
+
* Tue Jul 3 2018 Remi Collet <remi@remirepo.net> - 9.3.0-2
- add upstream patch to fix SQL injection CVE-2018-13049